Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Why is unwanted code (div/link64_adl_tabid/number) added in text editors (ckEditor, WordPress, etc.)?

  • 5 replies
  • 5 have this problem
  • 512 views
  • Last reply by mkoontz

more options

I recently noticed that when I am working in WordPress, or using an online text editor, or tech support anywhere, I am getting hidden code added at the bottom of the text area box:

521

I have tried using IE/Safari/Chrome on the same sites and none of them add this code. While the code is set to "display:none", it still shows up sometimes. I have to remember to check every page in code view, delete it, then save while in code view. As soon as I switch to "visual" mode, that code is inserted again.

I have searched for link64_adl_tabid and find other people asking about this with no solution, as well as links to pages that contain this code (like forums, tech support, etc.). Anywhere that people are posting, there seems to be this hidden code added.

I also tried using Firefox with all add-ons disabled - it still occurred.

Any ideas? It's driving me crazy and it's a real PITA to have to remember to remove it all the time.

Chosen solution

I downloaded the All Downloader Professional extension that's on your list and it does indeed contains code to create and to read that div with the id "link64_adl_tabid" (in link64_adl_overlay.js, one of its component files).

That should not affect a basic textarea field, because the code appends to the document body. In a rich text area, though, you are editing a small independent document, so it makes sense that it gets injected into the Visual editor.

The add-on author probably could fix this problem by not adding the div to a document that is contenteditable. But I don't recommend trying to fix the extension yourself.

Could you try disabling it and test again? You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Read this answer in context 👍 4

All Replies (5)

more options

There is a company named Link64 GmbH that makes a Windows program named Videodownloader Ultimate and Startpage 24, an alternate home page. Do you use anything from this company?

Please check the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group by date. Anything interesting from around the time you first noticed this problem?

more options

Using Google's date filtering option, I see this ID showing up in online postings starting around February 2015. Whatever it is seems to be a recently launched infection.

more options

Chosen Solution

I downloaded the All Downloader Professional extension that's on your list and it does indeed contains code to create and to read that div with the id "link64_adl_tabid" (in link64_adl_overlay.js, one of its component files).

That should not affect a basic textarea field, because the code appends to the document body. In a rich text area, though, you are editing a small independent document, so it makes sense that it gets injected into the Visual editor.

The add-on author probably could fix this problem by not adding the div to a document that is contenteditable. But I don't recommend trying to fix the extension yourself.

Could you try disabling it and test again? You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

more options

It worked. You have no idea how much I appreciate this.

I disabled All Downloader Professional, but I had to remove it and restart Firefox for it to be gone.

This is going to save me so many minutes a day.

+1000 points to you.

Julie

more options

Thank you very much jscher2000! I was experiencing this same problem but with Joomla articles instead of WordPress. I can confirm that the "All Downloader Professional extension" was the problem. Just like njaknjak1 posted, disabling the extension did not solve the problem. I had to remove it and restart Firefox/Nightly. After performing this action I no longer see the code showing up in my Joomla articles.