Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I set the new tab to open as a blank page?

more options

I have tried "How do I turn the New Tab page off?" in https://support.mozilla.org/en-US/kb/new-tab-page-show-hide-and-customize-top-sites

But still the new tab is opening with (chrome://quick_start/content/index.html" "Fast Start" and the words 'Snap Deal' already entered in the search bar. See the screen shot. I need a blank page shown when a new tab is open.

Unless this can be done, I have to switch my default browser.

Chosen solution

Thanks for the reply jscher2000. After posting the question, I uninstalled Firefox and then downloaded afresh and installed. Still the problem persisted. After about 2 hours I again uninstalled, downloaded afresh and installed. This time it worked perfectly as before. So, now I do not have the problem. Thank you.

Read this answer in context 👍 1

All Replies (7)

more options

Here's how you can change your new tab page:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

more options

Chosen Solution

Thanks for the reply jscher2000. After posting the question, I uninstalled Firefox and then downloaded afresh and installed. Still the problem persisted. After about 2 hours I again uninstalled, downloaded afresh and installed. This time it worked perfectly as before. So, now I do not have the problem. Thank you.

more options

If it comes back then you can check this:

more options

I have set my new tab settings in about:config to about:blank but I am still getting a page full of thumbnails every time I open a new tab. This has always worked for me in the past (ie: EVERY time Firefox updates) but this time it is not working!

more options

Hi Nannup_Real_Estate, Firefox 41 no longer uses the browser.newtab.url setting in about:config because it was constantly attacked by malware. Starting in Firefox 41, you need an add-on to change the new tab page.

This assumes you don't like seeing the gear there and want a truly blank page... otherwise, you can use the gear icon to blank the page.

Here are some options (I learn of more all the time):

  • If you already use either the "Classic Theme Restorer" or "Tab Mix Plus" extension: There is an option somewhere (!) in its extensive settings dialogs to select a different new tab page.

Please only use one of these methods at a time, otherwise there may be conflicts and dysfunctionality.

Setting up New Tab Override and Custom New Tab

After installing one of these extensions, you need to use its Options page to set the desired new tab page (instead of using about:config).

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, find New Tab Override or Custom New Tab and click its Options button. (See first screen shot attached.)

New Tab Override

Depending on the height of your screen, you may need to scroll down to enter the desired address into the form. (See second screen shot attached.) For example:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Then tab or click away from that form field and you can test using Ctrl+t.

Custom New Tab

Entering your preferred home page address is simple. If you do not check either of the boxes, the extension will set the focus in the page so, for example, the cursor will be in the Google search box. (See third screen shot attached.) I had to exit Firefox and start it up again before Custom New Tab started working, but this may have been due to testing so many extensions back-to-back.

Success?

more options

The browser.newtab.url pref is no longer supported in Firefox 41 and later, so you can no longer use this to set the new tab page. You need to use an extension to change the new tab page in the current Firefox 41 release and later.

You can look at this extension to set the new tab page:

You can set the new tab URL setting via the Options/Preferences of the extension on the about:addons page.

You can look at this extension if you use the home page as the new tab page.

Classic Theme Restorer includes this feature as well. In current CTR versions (1.3.9+) you find "New tab page url" in the Tabs (1) section.

You can use these special pages for the new tab page or use the URL of a web page. the default new tab page with the tiles is about:newtab

  • the default home page is about:home
  • for a blank page you can use about:blank
  • for Super Start you can use about:superstart
more options

Thank you jscher2000 and Cor-el for your replies. My problem is all solved and it was super easy! :D