X
Tap here to go to the mobile version of the site.

Support Forum

The latest update opens links into a window without toolbars or being able to view ( scroll) the entire page. What setting, if any, will change this?

Posted

Since the 38.0.1 update any link inside a page will open a new but non functioning window, it has no toolbars and will not scroll down the page. Bookmarks function normally, it only seems to be an issue following links. They open normally in tabs, it seems to only be an issue if open links in a new window is selected

Since the 38.0.1 update any link inside a page will open a new but non functioning window, it has no toolbars and will not scroll down the page. Bookmarks function normally, it only seems to be an issue following links. They open normally in tabs, it seems to only be an issue if open links in a new window is selected

Modified by viburnum

Additional System Details

Installed Plug-ins

  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 17.0 r0
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 38.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.1/WINNT/en-US/

Extensions

  • NoSquint 2.1.9 (nosquint@urandom.ca)
  • McAfee SiteAdvisor 3.7.2 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 760 Ti OEM
  • adapterDescription2: Intel(R) HD Graphics 4600
  • adapterDeviceID: 0x1189
  • adapterDeviceID2: 0x0412
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterRAM: 2048
  • adapterRAM2: Unknown
  • adapterSubsysID: 107410de
  • adapterSubsysID2: 0000000c
  • adapterVendorID: 0x10de
  • adapterVendorID2: 0x8086
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 12-13-2014
  • driverDate2: 9-29-2014
  • driverVersion: 9.18.13.4709
  • driverVersion2: 10.18.10.3960
  • info: {u'AzureContentBackend': u'direct2d 1.1', u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 760 Ti OEM Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?

Question owner

I tried that and it's the same. No toolbars and a frozen page

I tried that and it's the same. No toolbars and a frozen page
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Helpful Reply

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Do you use automatic private browsing mode, which generally is set in the Options dialog, Privacy panel, as "Firefox will: Never remember history"? A user with that setting reported getting limited feature windows in that mode and I wonder whether it is a pattern.

Ref: Private Browsing issues: New window is a "pop-up" & Right-clicking bookmarks shows grayed-out options (unsolved)

Do you use automatic private browsing mode, which generally is set in the Options dialog, Privacy panel, as "Firefox will: Never remember history"? A user with that setting reported getting limited feature windows in that mode and I wonder whether it is a pattern. Ref: [https://support.mozilla.org/questions/1062333 Private Browsing issues: New window is a "pop-up" & Right-clicking bookmarks shows grayed-out options] (unsolved)
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157890 answers
See: *http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Helpful Reply

Based on another thread where the user tested a bunch of things, there appears to be a bug in Firefox 38.0.1 involving this set of circumstances:

(1) Tabbed browsing turned off (2) Private window (3) Link with target="_blank" (not a scripted link)

The new window opens without menus, toolbars, scroll bars, etc.

Currently known workarounds:

(1) Use tabbed browsing (2) Shift+click links to open in a new window with the standard features

Based on another thread where the user tested a bunch of things, there appears to be a bug in Firefox 38.0.1 involving this set of circumstances: (1) Tabbed browsing turned off (2) Private window (3) Link with target="_blank" (not a scripted link) The new window opens without menus, toolbars, scroll bars, etc. Currently known workarounds: (1) Use tabbed browsing (2) Shift+click links to open in a new window with the standard features
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Here's a brief update:

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks.

Another workaround is to change certain hidden setting related to dialog-style windows. This will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.

Here are the steps:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste feat and pause while the list is filtered

(3) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.

Here's a brief update: Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. Another workaround is to change certain hidden setting related to dialog-style windows. This will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed. Here are the steps: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''feat''' and pause while the list is filtered (3) For every preference that starts with '''dom.disable_window_open_feature.''' if it is not "true", double-click it to switch it to true. You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.