Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Microsoft Silverlight cannot be activated. There is no ability to select activate because the dropdown cannot be selected even though it is the newest version

  • 2 replies
  • 15 have this problem
  • 1390 views
  • Last reply by cor-el

more options

I am unable to activate Microsoft Silverlight. I have attached a screenshot for review. It is the only plugin that says "disabled" next to it. I have updated to the most recent version and there is no option on the plugins page to acivate it as it says "never activate" and no other selections are selectable.

Chosen solution

Unfortunately, your screen shot did not come through. You can attach it to a reply in this thread if you like.

If you have not Quit Firefox and started it up again since installing Silverlight, please try that in case a file is locked.

Could you also check in the preferences editor as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste npc and pause while the list is filtered

(3) If you find a preference for plugin.state.npctrl which is set to anything other than one, try to double-click it and set it to 1. For reference:

  • 0 => Never Activate
  • 1 => Ask to Activate
  • 2 => Always Activate

If the preference has a status other than "user set" such as "locked", then that would indicate a different issue.

Read this answer in context 👍 2

All Replies (2)

more options

Chosen Solution

Unfortunately, your screen shot did not come through. You can attach it to a reply in this thread if you like.

If you have not Quit Firefox and started it up again since installing Silverlight, please try that in case a file is locked.

Could you also check in the preferences editor as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste npc and pause while the list is filtered

(3) If you find a preference for plugin.state.npctrl which is set to anything other than one, try to double-click it and set it to 1. For reference:

  • 0 => Never Activate
  • 1 => Ask to Activate
  • 2 => Always Activate

If the preference has a status other than "user set" such as "locked", then that would indicate a different issue.

more options

Are there any messages show for this plugin on the about:plugins page?

You can open about: pages via the location/address bar.