X
Tap here to go to the mobile version of the site.

Support Forum

In Youtube video only plays in the upper left corner of screen.

Posted

Okay. The issue is that since the update to Firefox 37.0.2 I am having video playback issues on Youtube.com and Sometimes Newgrounds.com. In Youtube many videos I play only now show in the upper left hand corner of the screen and the size of that video does not change even in full screen. it remains the size of a small tile. I have tried disabling add ons, and pretty much everything suggested on various web sites. On New Grounds some videos and some games are flipped upside down and backwards as the occasional video but the video issue on Newgrounds is not as bad as the issue Firefox has with some of the games.

I have tried the exact same videos and games on Internet Exploder and I do not get any of these issues. This only began to happen after the update to 37.0.2.

I am using Windows 8 (FULLY UP TO DATE) and I have the latest version of Flash. I have managed to narrow this down to a Firefox issue and many others have stated in various sites addressing this issue as a bug in Firefox. I have to agree with this observation. Likewise my video drivers are up to date as well. My computer uses the Intel 4600 drivers.

Comp specs pertaining to this issue: ASrock Z97 Pro3 Intel graphics (onboard) 16GB of RAM

Okay. The issue is that since the update to Firefox 37.0.2 I am having video playback issues on Youtube.com and Sometimes Newgrounds.com. In Youtube many videos I play only now show in the upper left hand corner of the screen and the size of that video does not change even in full screen. it remains the size of a small tile. I have tried disabling add ons, and pretty much everything suggested on various web sites. On New Grounds some videos and some games are flipped upside down and backwards as the occasional video but the video issue on Newgrounds is not as bad as the issue Firefox has with some of the games. I have tried the exact same videos and games on Internet Exploder and I do not get any of these issues. This only began to happen after the update to 37.0.2. I am using Windows 8 (FULLY UP TO DATE) and I have the latest version of Flash. I have managed to narrow this down to a Firefox issue and many others have stated in various sites addressing this issue as a bug in Firefox. I have to agree with this observation. Likewise my video drivers are up to date as well. My computer uses the Intel 4600 drivers. Comp specs pertaining to this issue: ASrock Z97 Pro3 Intel graphics (onboard) 16GB of RAM

Chosen solution

If a right-click on the player on YouTube shows a pale menu mentioning the HTML5 player, then that is using built-in features of Firefox. If it mentions the Flash player, then it is using the Flash plugin. That would be useful to know for next steps.


This is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here:

"3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

That takes effect the next time you exit and start Firefox up again.

(B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting for this:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Shockwave Flash 17.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

guigs 1072 solutions 11697 answers

HI Dr.Motorfinger, Thank you for your question, I understand that your drivers are up to date. Are they custom, or are they the recommended drivers for your hardware? Are the WebGL drivers up to date in Firefox as well? Upgrade your graphics drivers to use hardware acceleration and WebGL

Please make sure that all of your extensions and plugins are up to date.

Refreshing the page or changing the video quality on the youtube page may be a temporary work around, however this can also be a bug in the site if this happens on multiple computers.

HI Dr.Motorfinger, Thank you for your question, I understand that your drivers are up to date. Are they custom, or are they the recommended drivers for your hardware? Are the WebGL drivers up to date in Firefox as well? [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Please make sure that all of your extensions and plugins are up to date. Refreshing the page or changing the video quality on the youtube page may be a temporary work around, however this can also be a bug in the site if this happens on multiple computers.

Question owner

Every last detail is up to date. The video drivers are from Intel them self. I have heard of others also experiencing the exact same issue so I know I am not alone. BUT Youtube uses Flash do they not? Flash is up to date but I also have had issues on Newgrounds where certain videos and games appear flipped upside down and reversed. To add insult to injury some Newgrounds videos are affected. My suspicion is not the site itself but Flash. The common threads concerning this issue as I see them are these, Select sites that depend on Flash video (ie. Youtube, Newgrounds), Flash, and Firefox and its latest update(s).

Don't get me wrong. I also have seen threads in other forums pertaining to this issue and Google Chrome! Could it be that Flash is Honked up??? I mean in all honesty Flash is now using HTML5 is it not? And that is still sort of new? So could the bug itself lie in how Flash HTML5 communicates with Firefox (and Chrome)?

I have seen people downgrading Firefox and fixing the playback issue. I also seen other idea that might or might not work for other people and so far did not work for me. What is suspicious is how this all started after the latest update for Firefox.

Every last detail is up to date. The video drivers are from Intel them self. I have heard of others also experiencing the exact same issue so I know I am not alone. BUT Youtube uses Flash do they not? Flash is up to date but I also have had issues on Newgrounds where certain videos and games appear flipped upside down and reversed. To add insult to injury some Newgrounds videos are affected. My suspicion is not the site itself but Flash. The common threads concerning this issue as I see them are these, Select sites that depend on Flash video (ie. Youtube, Newgrounds), Flash, and Firefox and its latest update(s). Don't get me wrong. I also have seen threads in other forums pertaining to this issue and Google Chrome! Could it be that Flash is Honked up??? I mean in all honesty Flash is now using HTML5 is it not? And that is still sort of new? So could the bug itself lie in how Flash HTML5 communicates with Firefox (and Chrome)? I have seen people downgrading Firefox and fixing the playback issue. I also seen other idea that might or might not work for other people and so far did not work for me. What is suspicious is how this all started after the latest update for Firefox.
jscher2000
  • Top 10 Contributor
8886 solutions 72699 answers

Helpful Reply

Do you have a "higher than HD resolution" screen?

YouTube has switched most Firefox users to an HTML5 video player by default. You typically can tell which one you're using -- HTML5 or Flash -- from the right-click context menu.

If you want to force the Flash player on YouTube, there are a couple of extensions to accomplish that. I have no idea which is better:

Or if you want to make sure you're using the HTML5 player, see this page: https://www.youtube.com/html5

Do you have a "higher than HD resolution" screen? YouTube has switched most Firefox users to an HTML5 video player by default. You typically can tell which one you're using -- HTML5 or Flash -- from the right-click context menu. If you want to force the Flash player on YouTube, there are a couple of extensions to accomplish that. I have no idea which is better: * https://addons.mozilla.org/firefox/addon/youtube-flash-player/ * https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ Or if you want to make sure you're using the HTML5 player, see this page: https://www.youtube.com/html5

Question owner

My monitors both do support HD BUT neither are larger than 22." Also I AM using HTML5. I just had an update to Flash this morning so we shall see if Adobe fixed the bug or not.

My monitors both do support HD BUT neither are larger than 22." Also I AM using HTML5. I just had an update to Flash this morning so we shall see if Adobe fixed the bug or not.

Question owner

Nope, the update by Adobe didn't fix SQUAT. My computer likewise is not some "Old" or outdated machine. I thought HTML5 was supported by Flash (Adobe). So if I can force my computer to just use Flash then what really is going on here? Is HTML5 really that messed up? Or is Google and Youtube just falling behind on dealing with bugs on their site?

Nope, the update by Adobe didn't fix SQUAT. My computer likewise is not some "Old" or outdated machine. I thought HTML5 was supported by Flash (Adobe). So if I can force my computer to just use Flash then what really is going on here? Is HTML5 really that messed up? Or is Google and Youtube just falling behind on dealing with bugs on their site?
jscher2000
  • Top 10 Contributor
8886 solutions 72699 answers

Chosen Solution

If a right-click on the player on YouTube shows a pale menu mentioning the HTML5 player, then that is using built-in features of Firefox. If it mentions the Flash player, then it is using the Flash plugin. That would be useful to know for next steps.


This is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case:

(1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily.

(2) Disable hardware acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here:

"3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

That takes effect the next time you exit and start Firefox up again.

(B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista and higher)

The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting for this:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

If a right-click on the player on YouTube shows a pale menu mentioning the HTML5 player, then that is using built-in features of Firefox. If it mentions the Flash player, then it is using the Flash plugin. That would be useful to know for next steps. ---- This is some standard guidance that addresses the most common issues with the Flash Player plugin. I'm sure you've seen some of it before, but just in case: (1) If you have any recorders/downloaders that interact with Flash media make sure they are as up-to-date as possible, or disable them temporarily. (2) Disable hardware acceleration in Firefox and in Flash (A) In Firefox, un-check the box here: "3-bar" menu button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available" That takes effect the next time you exit and start Firefox up again. (B) In Flash, right-click the media and choose Settings, then the first mini-tab and uncheck the box to use hardware acceleration. More information in this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues (3) Disable protected mode (Windows Vista and higher) The protected mode feature of the Flash player plugin has security benefits, but seems to have compatibility issues on some systems. There is a hidden setting for this: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''flash''' and pause while the list is filtered (C) Double-click the '''dom.ipc.plugins.flash.disable-protected-mode''' preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Helpful Reply

Disabling protected mode worked! NOW I can view videos full screen youtube no problem!

Thanks. That was a solution I had not read about.

Disabling protected mode worked! NOW I can view videos full screen youtube no problem! Thanks. That was a solution I had not read about.