X
Tap here to go to the mobile version of the site.

Support Forum

forward button disappears on home page

Posted

I have asked this without result. When using firefox, I can do a search, go to a page, go to deeper pages, click the back button and forward button; but when I click the back button to the home page, the forward button disappears. I have done this by accident or design many times. When I back up to the home page, I have to start all over again, redo the search and it is extremely frustrating. This is NOT fixed by the "Restore Defaults." It seems that if I back up to my home page [Usually Google Search] then Firefox assumes that I will not want to go forward again. I do NOT want another ADD-ON for this. I merely want the forward button in all windows where there is a forward page. How can I get that? I hate to say it, but this happens enough that I have been using Chrome for searches and just general surfing. In my opinion, the forward button show be in ALL windows, grayed out if necessary, but there. But I can accept it disappearing when there is NO forward page. But not when there is a forward page. Note: this NEVER happens in Chrome [and others.] See pictures 1. Google search 2. Search for Yellowstone 3. Go to Yellowstone site 4. Click back button to Search for Yellowstone page. 5. Click back to Google page. Where is the forward button so that I can go forward to the Yellowstone search???

I have asked this without result. When using firefox, I can do a search, go to a page, go to deeper pages, click the back button and forward button; but when I click the back button to the home page, the forward button disappears. I have done this by accident or design many times. When I back up to the home page, I have to start all over again, redo the search and it is extremely frustrating. This is NOT fixed by the "Restore Defaults." It seems that if I back up to my home page [Usually Google Search] then Firefox assumes that I will not want to go forward again. I do NOT want another ADD-ON for this. I merely want the forward button in all windows where there is a forward page. How can I get that? I hate to say it, but this happens enough that I have been using Chrome for searches and just general surfing. In my opinion, the forward button show be in ALL windows, grayed out if necessary, but there. But I can accept it disappearing when there is NO forward page. But not when there is a forward page. Note: this NEVER happens in Chrome [and others.] See pictures 1. Google search 2. Search for Yellowstone 3. Go to Yellowstone site 4. Click back button to Search for Yellowstone page. 5. Click back to Google page. Where is the forward button so that I can go forward to the Yellowstone search???
Attached screenshots

Chosen solution

Thanks for the follow up, but to test, I cleaned the machine, and loaded Mozilla again. It still does the same thing. I will study your reference to follow up, though. .................................... Later: Yes, my home page was listed as https://www.google.com. But I deleted that and changed it. Then deleted that and changed it back to https://www.google.com. And now it seems to work. It may have been a cache thing that did not clear properly. A note the same thing happened when I changed the home page to https:/www.bing.com. But after I deleted it and reentered it, Bing now works properly as the homepage. [Though I switched back to google.] I have no real idea why I have to enter the homepage, save it, delete it, and renter it to make it work correctly. ............................ But your note made me try things, so thanks. don

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Citrix Online App Detector Plugin
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • Office Plugin for Netscape Navigator
  • Office Authorization plug-in for NPAPI browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • Shockwave Flash 15.0 r0
  • 5.1.30514.0
  • NPWLPG
  • nprt

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Try changing your home page to the secure address (this full URL):

https://www.google.com/

I think the problem is that if your homepage is the older non-secure address:

http://www.google.com/

Then when you go back to it the Google redirect runs a second time, trashing your forward history.

Try changing your home page to the secure address (this full URL): https://www.google.com/ I think the problem is that if your homepage is the older non-secure address: http://www.google.com/ Then when you go back to it the Google redirect runs a second time, trashing your forward history.

Question owner

i have used the https address for years. that has nothing to do with it. it happens if i make anything my home page.

i have used the https address for years. that has nothing to do with it. it happens if i make anything my home page.
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

fryque said

i have used the https address for years. that has nothing to do with it. it happens if i make anything my home page.

If you look at the URLs in your first and last screen shots, they contain the parameter gws_rd=ssl which is Google-speak for an automatic redirect from the HTTP to the HTTPS address. That is coming from somewhere, and if it isn't your home page address, maybe it is an old bookmark. Anyway, the point is that starting from a clean https://www.google.com/ you should be able to go back to that page without losing your forward history.

''fryque [[#answer-726810|said]]'' <blockquote>i have used the https address for years. that has nothing to do with it. it happens if i make anything my home page.</blockquote> If you look at the URLs in your first and last screen shots, they contain the parameter <code>gws_rd=ssl</code> which is Google-speak for an automatic redirect from the HTTP to the HTTPS address. That is coming from somewhere, and if it isn't your home page address, maybe it is an old bookmark. Anyway, the point is that starting from a clean https://www.google.com/ you should be able to go back to that page without losing your forward history.

Chosen Solution

Thanks for the follow up, but to test, I cleaned the machine, and loaded Mozilla again. It still does the same thing. I will study your reference to follow up, though. .................................... Later: Yes, my home page was listed as https://www.google.com. But I deleted that and changed it. Then deleted that and changed it back to https://www.google.com. And now it seems to work. It may have been a cache thing that did not clear properly. A note the same thing happened when I changed the home page to https:/www.bing.com. But after I deleted it and reentered it, Bing now works properly as the homepage. [Though I switched back to google.] I have no real idea why I have to enter the homepage, save it, delete it, and renter it to make it work correctly. ............................ But your note made me try things, so thanks. don

Thanks for the follow up, but to test, I cleaned the machine, and loaded Mozilla again. It still does the same thing. I will study your reference to follow up, though. .................................... Later: Yes, my home page was listed as https://www.google.com. But I deleted that and changed it. Then deleted that and changed it back to https://www.google.com. And now it seems to work. It may have been a cache thing that did not clear properly. A note the same thing happened when I changed the home page to https:/www.bing.com. But after I deleted it and reentered it, Bing now works properly as the homepage. [Though I switched back to google.] I have no real idea why I have to enter the homepage, save it, delete it, and renter it to make it work correctly. ............................ But your note made me try things, so thanks. don