X
Tap here to go to the mobile version of the site.

Support Forum

firefox is blocking page content how to turn it off

Posted

firefox shows me the website im trying to go to but part of it is blocked and i got to click the icon next to the web address to unblock it how do i turn it off so i never have to click the icon next to the web address?

firefox shows me the website im trying to go to but part of it is blocked and i got to click the icon next to the web address to unblock it how do i turn it off so i never have to click the icon next to the web address?

Chosen solution

Did you click the toolbar button ("A") of the extension to change the background color of the icon from green to red?

Red means that you allow mixed content. You should only set this to red on websites that you trust and if the site isn't working properly.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Plug-in for detecting Nero Kwik Media.
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

Muhammad_Faizan 8 solutions 86 answers

Hello Are you using extension Adblock or Adblock plus they might be blocking the contents, just pause adblock at that page.

or check this article for more help https://support.mozilla.org/en-US/kb/block-and-unblock-websites-parental-controls-firef

Do reply if you still encounter any problem.

Hello Are you using extension Adblock or Adblock plus they might be blocking the contents, just pause adblock at that page. or check this article for more help https://support.mozilla.org/en-US/kb/block-and-unblock-websites-parental-controls-firef Do reply if you still encounter any problem.
Abhishek Singh Kushwah 3 solutions 36 answers

You are probably using an extension or a plugin which blocks certain content such as images & videos or advertisements.

It may also be possible that your plugin is not updated and therefore firefox shows a red mark and asks you again, if its safe to play.

You should check by going through Options -> Addons or type about:addons in location bar to confirm the problem.

You are probably using an extension or a plugin which blocks certain content such as images & videos or advertisements. It may also be possible that your plugin is not updated and therefore firefox shows a red mark and asks you again, if its safe to play. You should check by going through Options -> Addons or type about:addons in location bar to confirm the problem.

Modified by Abhishek Singh Kushwah

Question owner

Muhammad_Faizan said

Hello Are you using extension Adblock or Adblock plus they might be blocking the contents, just pause adblock at that page. or check this article for more help https://support.mozilla.org/en-US/kb/block-and-unblock-websites-parental-controls-firef Do reply if you still encounter any problem.

i have everything turned off it even does it in safe mode

''Muhammad_Faizan [[#answer-726328|said]]'' <blockquote> Hello Are you using extension Adblock or Adblock plus they might be blocking the contents, just pause adblock at that page. or check this article for more help https://support.mozilla.org/en-US/kb/block-and-unblock-websites-parental-controls-firef Do reply if you still encounter any problem. </blockquote> i have everything turned off it even does it in safe mode

Question owner

onyx5500 said

firefox shows me the website im trying to go to but part of it is blocked and i got to click the icon next to the web address to unblock it how do i turn it off so i never have to click the icon next to the web address?

i Really do not like how firefox blocks safe websites that i need to get to ican see the site but when part of it is blocked i can't click on what i need to click on i really want to remove the block on all sites so i do not have to click on the block to remove it every time i go to the website please help me im willing to pay to fix this problem

''onyx5500 [[#question-1061211|said]]'' <blockquote> firefox shows me the website im trying to go to but part of it is blocked and i got to click the icon next to the web address to unblock it how do i turn it off so i never have to click the icon next to the web address? </blockquote> i Really do not like how firefox blocks safe websites that i need to get to ican see the site but when part of it is blocked i can't click on what i need to click on i really want to remove the block on all sites so i do not have to click on the block to remove it every time i go to the website please help me im willing to pay to fix this problem
VoodooDaddy 1 solutions 18 answers

Please check if all your plugins are up-to-date. To do this, go to the Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each yellow or red button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

Please check if all your plugins are up-to-date. To do this, go to the [https://www.mozilla.org/plugincheck/ Plugin Check site]. Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow ''Update'' button or a red ''Update now'' button, please update these immediately. To do so, please click each yellow or red button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.
Abhishek Singh Kushwah 3 solutions 36 answers

Post the screenshot of your blocked content or the part of page which does not load for further analysis.

Post the screenshot of your blocked content or the part of page which does not load for further analysis.
VoodooDaddy 1 solutions 18 answers

I need to Know What Plugin it is Blocking, On the Page that is Being Blocked on the Left side next to the Page Back Button is a Icon on that Icon you can chose to allow or block it will have the Name in the Pop-up.

Please Reply With Plugin Name.

I need to Know What Plugin it is Blocking, On the Page that is Being Blocked on the Left side next to the Page Back Button is a Icon on that Icon you can chose to allow or block it will have the Name in the Pop-up. Please Reply With Plugin Name.
VoodooDaddy 1 solutions 18 answers

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Click the menu button New Fx Menu , choose History, and then "Clear Recent History...".
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article. If this Worked for you Reply and I will send you the Next Step

Hello, Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #Click the menu button [[Image:New Fx Menu]], choose History, and then "Clear Recent History...". #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the "Clear Now" button. Further information can be found in the [[Delete browsing, search and download history on Firefox]] article. If this Worked for you Reply and I will send you the Next Step

Modified by VoodooDaddy

Question owner

VoodooDaddy said

Please check if all your plugins are up-to-date. To do this, go to the Plugin Check site. Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately. To do so, please click each yellow or red button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

i do not have any plugins that are turned on and it blocks the websites even in safe mode

''VoodooDaddy [[#answer-726370|said]]'' <blockquote> Please check if all your plugins are up-to-date. To do this, go to the [https://www.mozilla.org/plugincheck/ Plugin Check site]. Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow ''Update'' button or a red ''Update now'' button, please update these immediately. To do so, please click each yellow or red button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure. </blockquote> i do not have any plugins that are turned on and it blocks the websites even in safe mode
VoodooDaddy 1 solutions 18 answers

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

Run AdwCleaner to inspect your Web Browser and Report Back.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Windows 8 has antivirus built-in already.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. Run AdwCleaner to inspect your Web Browser and Report Back. You can try these free programs to scan for malware, which work with your existing antivirus software: * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/viruses/disinfection/5350 Anti-Rootkit Utility - TDSSKiller] * [http://general-changelog-team.fr/en/downloads/viewdownload/20-outils-de-xplode/2-adwcleaner AdwCleaner] (for more info, see this [http://www.bleepingcomputer.com/download/adwcleaner/ alternate AdwCleaner download page]) * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] [http://windows.microsoft.com/MSE Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Windows 8 has antivirus [http://www.microsoft.com/security/pc-security/windows8.aspx#antivirus built-in] already. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Did this fix your problems? Please report back to us!
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

VoodooDaddy said

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. Run AdwCleaner to inspect your Web Browser and Report Back. You can try these free programs to scan for malware, which work with your existing antivirus software: Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Windows 8 has antivirus built-in already. Further information can be found in the Troubleshoot Firefox issues caused by malware article. Did this fix your problems? Please report back to us!
# AdwCleaner v4.203 - Logfile created 09/05/2015 at 13:25:56
# Updated 30/04/2015 by Xplode
# Database : 2015-05-09.1 [Server]
# Operating system : Windows 8.1  (x64)
# Username : jeremie - ONYX550
# Running from : C:\Users\johon\Downloads\adwcleaner_4.203.exe
# Option : Cleaning

***** [ Services ] *****


***** [ Files / Folders ] *****

Folder Deleted : C:\ProgramData\{46df0322-89a4-d927-46df-f032289a0c8a}
Folder Deleted : C:\Program Files (x86)\app_setup
Folder Deleted : C:\ProgramData\gnimgapbplpgofmkbfmnpcaaikdphjjf

***** [ Scheduled tasks ] *****


***** [ Shortcuts ] *****


***** [ Registry ] *****

Key Deleted : HKCU\Software\YorkNewCin
Key Deleted : HKCU\Software\HighDefAction
Key Deleted : HKCU\Software\ArenaHD
Key Deleted : HKLM\SOFTWARE\YorkNewCin
Key Deleted : HKLM\SOFTWARE\HighDefAction
Key Deleted : HKLM\SOFTWARE\ArenaHD
Key Deleted : [x64] HKLM\SOFTWARE\YorkNewCin
Key Deleted : [x64] HKLM\SOFTWARE\HighDefAction
Key Deleted : [x64] HKLM\SOFTWARE\ArenaHD
Data Deleted : HKU\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings [ProxyServer] - hxxp=127.0.0.1:50188;hxxps=127.0.0.1:50188
Data Deleted : HKU\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings [ProxyEnable] - 1
Data Deleted : HKU\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings [ProxyOverride] - <-loopback>

***** [ Web browsers ] *****

-\\ Internet Explorer v11.0.9600.17416


-\\ Mozilla Firefox v37.0.2 (x86 en-US)

[gff6hwwp.default-1429214447490\prefs.js] - Line Deleted : user_pref("extensions.enabledAddons", "Tangofox%40haven667:4.6");
[gff6hwwp.default-1429214447490\prefs.js] - Line Deleted : user_pref("extensions.xpiState", "{\"app-profile\":{\"jid1-dwtFBkQjb3SIQp@jetpack\":{\"d\":\"C:\\\\Users\\\\johon\\\\AppData\\\\Roaming\\\\Mozilla\\\\Firefox\\\\Profiles\\\\gff6hwwp.default-1429214447[...]
[gff6hwwp.default-1429214447490\prefs.js] - Line Deleted : user_pref("general.skins.selectedSkin", "Tangofox");

-\\ Google Chrome v42.0.2311.135

[C:\Users\johon\AppData\Local\Google\Chrome\User Data\Default\Web Data] - Deleted [Search Provider] : hxxp://search.aol.com/aol/search?q={searchTerms}
[C:\Users\johon\AppData\Local\Google\Chrome\User Data\Default\Web Data] - Deleted [Search Provider] : hxxp://www.ask.com/web?q={searchTerms}

*************************

AdwCleaner[R0].txt - [3504 bytes] - [18/04/2015 15:38:12]
AdwCleaner[R1].txt - [2926 bytes] - [09/05/2015 13:23:13]
AdwCleaner[S0].txt - [3249 bytes] - [18/04/2015 15:38:54]
AdwCleaner[S1].txt - [2548 bytes] - [09/05/2015 13:25:56]

########## EOF - C:\AdwCleaner\AdwCleaner[S1].txt - [2607  bytes] ##########

i sent you a screen shot of what firefox is doing

''VoodooDaddy [[#answer-726393|said]]'' <blockquote> Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of. Run AdwCleaner to inspect your Web Browser and Report Back. You can try these free programs to scan for malware, which work with your existing antivirus software: * [http://www.microsoft.com/security/scanner/default.aspx Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/viruses/disinfection/5350 Anti-Rootkit Utility - TDSSKiller] * [http://general-changelog-team.fr/en/downloads/viewdownload/20-outils-de-xplode/2-adwcleaner AdwCleaner] (for more info, see this [http://www.bleepingcomputer.com/download/adwcleaner/ alternate AdwCleaner download page]) * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] [http://windows.microsoft.com/MSE Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Windows 8 has antivirus [http://www.microsoft.com/security/pc-security/windows8.aspx#antivirus built-in] already. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Did this fix your problems? Please report back to us! </blockquote> <pre><nowiki># AdwCleaner v4.203 - Logfile created 09/05/2015 at 13:25:56 # Updated 30/04/2015 by Xplode # Database : 2015-05-09.1 [Server] # Operating system : Windows 8.1 (x64) # Username : jeremie - ONYX550 # Running from : C:\Users\johon\Downloads\adwcleaner_4.203.exe # Option : Cleaning ***** [ Services ] ***** ***** [ Files / Folders ] ***** Folder Deleted : C:\ProgramData\{46df0322-89a4-d927-46df-f032289a0c8a} Folder Deleted : C:\Program Files (x86)\app_setup Folder Deleted : C:\ProgramData\gnimgapbplpgofmkbfmnpcaaikdphjjf ***** [ Scheduled tasks ] ***** ***** [ Shortcuts ] ***** ***** [ Registry ] ***** Key Deleted : HKCU\Software\YorkNewCin Key Deleted : HKCU\Software\HighDefAction Key Deleted : HKCU\Software\ArenaHD Key Deleted : HKLM\SOFTWARE\YorkNewCin Key Deleted : HKLM\SOFTWARE\HighDefAction Key Deleted : HKLM\SOFTWARE\ArenaHD Key Deleted : [x64] HKLM\SOFTWARE\YorkNewCin Key Deleted : [x64] HKLM\SOFTWARE\HighDefAction Key Deleted : [x64] HKLM\SOFTWARE\ArenaHD Data Deleted : HKU\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings [ProxyServer] - hxxp=127.0.0.1:50188;hxxps=127.0.0.1:50188 Data Deleted : HKU\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings [ProxyEnable] - 1 Data Deleted : HKU\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet Settings [ProxyOverride] - <-loopback> ***** [ Web browsers ] ***** -\\ Internet Explorer v11.0.9600.17416 -\\ Mozilla Firefox v37.0.2 (x86 en-US) [gff6hwwp.default-1429214447490\prefs.js] - Line Deleted : user_pref("extensions.enabledAddons", "Tangofox%40haven667:4.6"); [gff6hwwp.default-1429214447490\prefs.js] - Line Deleted : user_pref("extensions.xpiState", "{\"app-profile\":{\"jid1-dwtFBkQjb3SIQp@jetpack\":{\"d\":\"C:\\\\Users\\\\johon\\\\AppData\\\\Roaming\\\\Mozilla\\\\Firefox\\\\Profiles\\\\gff6hwwp.default-1429214447[...] [gff6hwwp.default-1429214447490\prefs.js] - Line Deleted : user_pref("general.skins.selectedSkin", "Tangofox"); -\\ Google Chrome v42.0.2311.135 [C:\Users\johon\AppData\Local\Google\Chrome\User Data\Default\Web Data] - Deleted [Search Provider] : hxxp://search.aol.com/aol/search?q={searchTerms} [C:\Users\johon\AppData\Local\Google\Chrome\User Data\Default\Web Data] - Deleted [Search Provider] : hxxp://www.ask.com/web?q={searchTerms} ************************* AdwCleaner[R0].txt - [3504 bytes] - [18/04/2015 15:38:12] AdwCleaner[R1].txt - [2926 bytes] - [09/05/2015 13:23:13] AdwCleaner[S0].txt - [3249 bytes] - [18/04/2015 15:38:54] AdwCleaner[S1].txt - [2548 bytes] - [09/05/2015 13:25:56] ########## EOF - C:\AdwCleaner\AdwCleaner[S1].txt - [2607 bytes] ########## </nowiki></pre> i sent you a screen shot of what firefox is doing

Modified by cor-el

Question owner

cor-el said

Can you attach a screenshot?
  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

i have tried safe ode same problem here is a sreen shot

''cor-el [[#answer-726400|said]]'' <blockquote> Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes </blockquote> i have tried safe ode same problem here is a sreen shot
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

If there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location/address bar then that means that mixed active content is blocked.

You can check that in the Web Console (Firefox/Tools > Web Developer)m see:

If there is a shield icon to the left of the "[[Site Identity Button|Site Identity Button]]" (globe/padlock) on the location/address bar then that means that mixed active content is blocked. *https://support.mozilla.org/kb/how-does-content-isnt-secure-affect-my-safety *https://developer.mozilla.org/Security/MixedContent *https://addons.mozilla.org/firefox/addon/toggle-mixed-active-content/ You can check that in the Web Console (Firefox/Tools > Web Developer)m see: *https://developer.mozilla.org/Security/MixedContent

Question owner

cor-el said

If there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location/address bar then that means that mixed active content is blocked. You can check that in the Web Console (Firefox/Tools > Web Developer)m see:

how can i turn it off so i never worry about it i will pay to have it fixed if i half to

''cor-el [[#answer-726407|said]]'' <blockquote> If there is a shield icon to the left of the "[[Site Identity Button|Site Identity Button]]" (globe/padlock) on the location/address bar then that means that mixed active content is blocked. *https://support.mozilla.org/kb/how-does-content-isnt-secure-affect-my-safety *https://developer.mozilla.org/Security/MixedContent *https://addons.mozilla.org/firefox/addon/toggle-mixed-active-content/ You can check that in the Web Console (Firefox/Tools > Web Developer)m see: *https://developer.mozilla.org/Security/MixedContent </blockquote> how can i turn it off so i never worry about it i will pay to have it fixed if i half to
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

You can use this extension to have a toolbar button to toggle security.mixed_content.block_active_content true/false


Note that there are two kinds of mixed content:

  • Active content like scripts and content loaded in iframes
  • Passive content like images and media files

Firefox blocks active mixed content by default (security.mixed_content.block_active_content = true) and shows a blocked content shield on the location bar, but allows passive display content (security.mixed_content.block_display_content = false) and shows a warning exclamation icon on the location bar.

You can open the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) and check the Net log for lines with a red vertical bar and a mixed content warning icon. Clear the log and reload the page to get an updated log.

You can use this extension to have a toolbar button to toggle security.mixed_content.block_active_content true/false *https://addons.mozilla.org/firefox/addon/toggle-mixed-active-content/ ---- Note that there are two kinds of mixed content: *Active content like scripts and content loaded in iframes *Passive content like images and media files Firefox blocks active mixed content by default (security.mixed_content.block_active_content = true) and shows a blocked content shield on the location bar, but allows passive display content (security.mixed_content.block_display_content = false) and shows a warning exclamation icon on the location bar. * https://developer.mozilla.org/Security/MixedContent You can open the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) and check the Net log for lines with a red vertical bar and a mixed content warning icon. Clear the log and reload the page to get an updated log.

Question owner

cor-el said

You can use this extension to have a toolbar button to toggle security.mixed_content.block_active_content true/false

Note that there are two kinds of mixed content:

  • Active content like scripts and content loaded in iframes
  • Passive content like images and media files

Firefox blocks active mixed content by default (security.mixed_content.block_active_content = true) and shows a blocked content shield on the location bar, but allows passive display content (security.mixed_content.block_display_content = false) and shows a warning exclamation icon on the location bar.

You can open the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) and check the Net log for lines with a red vertical bar and a mixed content warning icon. Clear the log and reload the page to get an updated log.

the extension you sent me does not work

''cor-el [[#answer-726415|said]]'' <blockquote> You can use this extension to have a toolbar button to toggle security.mixed_content.block_active_content true/false *https://addons.mozilla.org/firefox/addon/toggle-mixed-active-content/ ---- Note that there are two kinds of mixed content: *Active content like scripts and content loaded in iframes *Passive content like images and media files Firefox blocks active mixed content by default (security.mixed_content.block_active_content = true) and shows a blocked content shield on the location bar, but allows passive display content (security.mixed_content.block_display_content = false) and shows a warning exclamation icon on the location bar. * https://developer.mozilla.org/Security/MixedContent You can open the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) and check the Net log for lines with a red vertical bar and a mixed content warning icon. Clear the log and reload the page to get an updated log. </blockquote> the extension you sent me does not work
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

Chosen Solution

Did you click the toolbar button ("A") of the extension to change the background color of the icon from green to red?

Red means that you allow mixed content. You should only set this to red on websites that you trust and if the site isn't working properly.

Did you click the toolbar button ("A") of the extension to change the background color of the icon from green to red? Red means that you allow mixed content. You should only set this to red on websites that you trust and if the site isn't working properly.

Question owner

so it has to be red?

so it has to be red?
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

Yes, but only if you really need to disable this security feature. This warning icon is there for a reason.

Yes, but only if you really need to disable this security feature. This warning icon is there for a reason. *https://support.mozilla.org/kb/how-does-content-isnt-secure-affect-my-safety