X
Tap here to go to the mobile version of the site.

Support Forum

Why do tabs and windows sometimes ignore the keyboard shortcut (CMD+W)? I keep having to go to File>Close Tab

Posted

Tabs in Firefox seem to ignore my commands sometimes, seemingly on random. Maybe more so when the tab contains a video, although I could be mistaken.

I'm using a 13-inch, Mid-2009 Macbook Pro running OSX 10.10.2 (the latest build.), but this also happens on my stepdad's 17-inch, Early-2008 Macbook Pro as well.

Tabs in Firefox seem to ignore my commands sometimes, seemingly on random. Maybe more so when the tab contains a video, although I could be mistaken. I'm using a 13-inch, Mid-2009 Macbook Pro running OSX 10.10.2 (the latest build.), but this also happens on my stepdad's 17-inch, Early-2008 Macbook Pro as well.

Chosen solution

If a plugin like Flash has focus then the plugin receives all key presses and you would have to click outside the plugin to remove the focus from the plugin and make the keyboard work again. I don't think that protected mode for Flash applies to Mac.

On Mac you may also not have the possibility to switch to the HTML5 media player as an alternative because with this player the keyboard shortcuts will function.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Provides information about the default web browser
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0

Application

  • Firefox 37.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
  • Support URL: https://support.mozilla.org/1/firefox/37.0.2/Darwin/en-US/

Extensions

  • FirefoxAdKiller 0.87 ({b1df372d-8b32-4c7d-b6b4-9c5b78cf6fb1})
  • Reddit Enhancement Suite 4.5.4 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Updated Ad Blocker for Firefox 11+ 0.7.7 ({4DC70064-89E2-4a55-8FC6-E8CDEAE3618C})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 863
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

Helpful Reply

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Helpful Reply

I think the most common reason would be a plugin intercepting the keyboard. This can happen if you use the controls on a Flash video, for example.

This is copy/pasted from an old post:

Over the past couple of years, users have noticed that the Flash player on YouTube was particularly "sticky" or tenacious when it came to capturing keyboard focus.

Last time I looked into this, about a year ago, I posted this summary of previously mentioned workarounds:

(1) Full screen the video and then switch back

press f then Esc - focus will move back to the page

(2) Switch to another application window and then back {WINDOWS}

press Alt+tab then Alt+tab - focus will move back to the page

(3) Click on a different tab then click back - focus will move back to the page

Some users also reported that the YouTube player behaves normally (i.e., clicking the page regains control) if you disable the Flash Player plugin's protected mode feature. There is now a hidden preference for this:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste flash and pause while the list is filtered

(C) Double-click the dom.ipc.plugins.flash.disable-protected-mode preference to switch its value from false to true.

This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

I think the most common reason would be a plugin intercepting the keyboard. This can happen if you use the controls on a Flash video, for example. ''This is copy/pasted from an old post:'' Over the past couple of years, users have noticed that the Flash player on YouTube was particularly "sticky" or tenacious when it came to capturing keyboard focus. Last time I looked into this, about a year ago, I posted this summary of previously mentioned workarounds: (1) Full screen the video and then switch back press f then Esc - focus will move back to the page (2) Switch to another application window and then back {WINDOWS} press Alt+tab then Alt+tab - focus will move back to the page (3) Click on a different tab then click back - focus will move back to the page Some users also reported that the YouTube player behaves normally (i.e., clicking the page regains control) if you disable the Flash Player plugin's protected mode feature. There is now a hidden preference for this: (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (B) In the search box above the list, type or paste '''flash''' and pause while the list is filtered (C) Double-click the '''dom.ipc.plugins.flash.disable-protected-mode''' preference to switch its value from false to true. This might not take effect until all Flash has been unloaded for a few minutes, or you close Firefox.

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
17476 solutions 157949 answers

Chosen Solution

If a plugin like Flash has focus then the plugin receives all key presses and you would have to click outside the plugin to remove the focus from the plugin and make the keyboard work again. I don't think that protected mode for Flash applies to Mac.

On Mac you may also not have the possibility to switch to the HTML5 media player as an alternative because with this player the keyboard shortcuts will function.

If a plugin like Flash has focus then the plugin receives all key presses and you would have to click outside the plugin to remove the focus from the plugin and make the keyboard work again. I don't think that protected mode for Flash applies to Mac. On Mac you may also not have the possibility to switch to the HTML5 media player as an alternative because with this player the keyboard shortcuts will function.
FredMcD
  • Top 10 Contributor
4246 solutions 59405 answers

I think these will help you out;

Close Tab by Double Click {web link} Allows you to close tabs by double-clicking on them.


Rights To Close {web link} Right double-click anywhere on web page to close current tab.

I think these will help you out; '''[https://addons.mozilla.org/en/firefox/addon/close-tab-by-double-click/ Close Tab by Double Click]''' {web link} Allows you to close tabs by double-clicking on them. ---------------------------------- '''[https://addons.mozilla.org/en-US/firefox/addon/rights-to-close/ Rights To Close]''' {web link} Right double-click anywhere on web page to close current tab.

Modified by FredMcD

Question owner

That's it! Thank you for the assistance.

That's it! Thank you for the assistance.