Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have a problem with an error message for ad blocker that interferes with watching videos

  • 6 replies
  • 6 have this problem
  • 32 views
  • Last reply by jscher2000

more options

Whenever I try to watch a video, I get this error message:

Oops, you have an ad blocker enabled!

To watch this episode, please disable it and refresh the page.

I removed adblocker, refreshed the page and the error message still came up. I installed bluhell firewall and disabled that, refreshed the page and the error message still comes up. I added remove it permanently, clicked on remove and that hasn't helped. I never had these problems before.

Chosen solution

Maybe a different extension is in play. Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Do you still get that message?

Read this answer in context 👍 3

All Replies (6)

more options

Chosen Solution

Maybe a different extension is in play. Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Do you still get that message?

more options

More generally, when you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

prp255 said

Whenever I try to watch a video, I get this error message: Oops, you have an ad blocker enabled! To watch this episode, please disable it and refresh the page. I removed adblocker, refreshed the page and the error message still came up. I installed bluhell firewall and disabled that, refreshed the page and the error message still comes up. I added remove it permanently, clicked on remove and that hasn't helped. I never had these problems before.

Thanks for your quick response. Re-starting the browser in safe mode with the addon's disabled did the trick. I hope this will help others having this same problem.

more options

Since Safe Mode is more of a testing mode than a daily use mode -- you'll miss your add-ons at some point -- I think the next step is to consider which of the extensions might be affecting the site. If you are not able to discover that through trial and error, you could post a list of what you have. The easiest way to extract that is to use the support information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

You can scroll down and manually select and copy the Extensions table, or use the button at the upper left labeled "Copy text to clipboard" and then paste into a reply. If you use the button, there will be a lot of additional data after the extension list that you may need to delete before posting (sometimes it exceeds the length limit on a reply).

more options

Here are the extensions I am running. I didn't go through and test each one.

Auto-Sort Bookmarks 2.7 true sortbookmarks@bouanto BetterPrivacy 1.68 true Bluhell Firewall 2.5.1 true Blur (Formerly DoNotTrackMe) 4.5.1334 Bookmark Deduplicator 1.3.1 true Classic Theme Restorer 1.3.1.1 true Click&Clean 4.1 Ghostery 5.4.5 Google™ Translator Lite 0.1.6 Multirow Bookmarks Toolbar NoScript 2.6.9.22 QuickJava 2.0.6 SiteCheck extension for Firefox 1.0.3 WOT 20131118 true YouTube™ Flash® Player

more options

Several of these could affect ads...

I think you said you already tested with Bluhell Firewall turned off.

Does anything show as blocked on the NoScript drop-down?

Do you know whether Blur or Ghostery could be blocking the ads?