Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I open a new tab it opens "bing.com" and I don't like it - how can I get it switched to "google.com"

  • 7 replies
  • 20 have this problem
  • 10199 views
  • Last reply by pgsc

more options

When I open a new tab it opens "bing.com" and I don't like it - how can I get it switched to "google.com"

Chosen solution

Here's how you can change your new tab page:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

Read this answer in context 👍 54

All Replies (7)

more options

Chosen Solution

Here's how you can change your new tab page:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

more options

I have tried this several times even, but it does not stop this from happening. In addition I have searched for any unwanted programs or addons, and still not found a solution even after going trough the paces of virus and malware search.

I even have one add on to stop unwanted websites from opening.

What have turned up is that the following string is causing this: http://go.microsoft.com/fwlink/?LinkID=219472&clcid=0x409

Since that is a microsoft.com address it does not prevent my block of the bing.com tab.

more options

Hi TheAnt, does the Microsoft link appear in the browser.newtab.url setting when you view it in about:config? What happens when you edit it? For example:

  • It doesn't change
  • It changes, but doesn't work
  • It changes, it works until you exit and start Firefox up again
  • It changes, it works until you shut down Windows and start it up again
  • It changes and works for some random amount of time
more options

Hello jscher and thank you for your reply - and attempt to help.

No the go.microsoft link do not apper in my about:config either. I have a hunch it is somewhere in the configuration for my Firefox but a search for the string itself came up with nothing.

I think my problem is the same as some other persons have reported. And also in their case they stated that the usual steps of removing malware and editing about:config wouldn't solve the problem. I can add that I have checked control panel and looked for any unwanted programs. nothing there.

This matter have brought me to the limit of my current knowledge of computers and browsers. That is the reason I ask how I can configure Firefox to not open one extra tab on startup with bing.com.

If the problem is in my own windows registry, we can leave it there - as long as I can find a solution to this annoying behaviour. =)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

nick6505 said

When I open a new tab it opens "bing.com" and I don't like it - how can I get it switched to "google.com"

YAY!! I've read hours worth of recommended fixes. This one worked!! Thank you so much.

more options

Check your installed programs for Lavasoft Web Companion. It seems this is a current piggy-back install which it causing this problem now. It should be near the bottom of the list.

Modified by pgsc