Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Yahoo Mail keyboard shortcuts no longer working

  • 10 replies
  • 4 have this problem
  • 23 views
  • Last reply by Jonathan147

more options

Normally, when using Yahoo Mail with Firefox, I can use keyboard shortcuts for underline, bold and italic. Now when I hit CONTROL-U I get "PAGE SOURCE" while CONTROL-I brings up BOOKMARKS. The lack of underline shortcut is a serious problem because there is no corresponding button. I did change this PAGE SOURCE shortcut, to avoid conflict, but this changes nothing. Any ideas?

Normally, when using Yahoo Mail with Firefox, I can use keyboard shortcuts for underline, bold and italic. Now when I hit CONTROL-U I get "PAGE SOURCE" while CONTROL-I brings up BOOKMARKS. The lack of underline shortcut is a serious problem because there is no corresponding button. I did change this PAGE SOURCE shortcut, to avoid conflict, but this changes nothing. Any ideas?

Chosen solution

Just to update you on Yahoo-Firefox shortcuts, as of yesterday, things went back to normal by themselves - thanks in any event for your help

Read this answer in context 👍 0

All Replies (10)

more options

I never knew Yahoo mail had these keyboard shortcuts...

If I open Firefox's Web Console in the lower part of the tab using Ctrl+Shift+w, when I press Ctrl+i or Ctrl+u there is an error which says

TypeError: e.halt is not a function

So it seems that the keyboard interception is getting fumbled by Yahoo and is getting caught by Firefox. Probably they need to fix this on their end -- their scripts are too complicated for me to sort out.

more options

Thank you. I confirm, in addition to PAGE SOURCE window oddly opening, when I try to underline with CONTROL-U, that WEB CONSOLE gives me the same TypeError. Hopefully, someone at Firefox will eventually notice it...

more options

As a temporary workaround for underline, how about a bookmarklet? That's a script you save as a bookmark. It does require a mouse click, but it's better than nothing.

The script is simply this (all one line):

javascript:void(document.execCommand("underline",false,null));

To install it, select and copy it.

Then right-click on the Bookmarks Toolbar in the vicinity of where you want the button and choose New Bookmark.

Click in the Location box and paste the script (Ctrl+v)

Click in the Name box and type Underline or the name of your choice

Then click Add Bookmark

Now, with text selected in the compose area, clicking the button should toggle underlining on and off.


Note to self: This article lists more possible commands: https://developer.mozilla.org/docs/Web/API/Document/execCommand

more options

That was very nice of you to go to all the trouble of explaining that. If I were desperate, I'd follow your instructions, but the color and bold face options are still working in Yahoo Mail, so I'll make do with those for the time being, and if need be, I have Outlook 2013. I must confess that I'm a bit lazy and have not yet checked out this problem with Explorer, which, quite frankly, is user-unfriendly and hence I never use it, except in cases like this. My best guess is that it's a Firefox Yahoo glitch, and certainly not the first time I've had to deal with weird shit with Yahoo, so I'm gonna wait it out until Mr FixIt fixes it. But again, merci beaucoup d'avoir pris la peine

more options

You can also try this extension:

more options

Thanks for this add-on. I installed it and see that it puts a toolbar top of screen. However, when I try to use it with Yahoo Mail, I see that when choosing the TO or SUBJECT line, the toolbar is active and when I go into the text box to send a message, the toolbar is greyed out. Any idea how to fix this? Thanks.

more options

I haven't tested the Text Formatting Toolbar extension, but it might be designed only for normal form text entry fields, and for editors that have an HTML or Code view. The kind of "rich text" editor used on webmail sites doesn't use form fields, but instead uses an editable web page in a frame.

more options

Thanks. For the record, I just tested Yahoo Mail under Explorer and all shortcuts work normally. So, apparently, the shortcut problem is a Firefox problem (still unfixed by Firefox)

more options

If this is a problem caused by Firefox failing to comply with web standards, someone from Yahoo probably will submit a bug report on it.

If this is a problem caused by Firefox turning off an old nonstandard behavior that some websites used, then the websites will need to change what they are doing, or Mozilla will have to be convinced to undo the decision -- that sometimes happens.

As I said earlier, Yahoo's script is too complicated for me to know which of those is the actual issue.

If you want to file a bug report to get the ball rolling, here's where you would do that:

more options

Chosen Solution

Just to update you on Yahoo-Firefox shortcuts, as of yesterday, things went back to normal by themselves - thanks in any event for your help