Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is there an easier way to edit bookmarks?

  • 13 replies
  • 8 have this problem
  • 968 views
  • Last reply by cor-el

more options

I have had a hard time editing bookmarks.

When I select "edit this bookmark," from the menu, I get a flashing pain-light on my screen, but no way to edit the bookmark.

When I hit command-D, from the keyboard, I get a mini-menu but it is hard to put the bookmark in the right folder.

When I open the bookmarks folder, it opens in its own window, instead of another tab in the same window, and it's hard to navigate between the two windows, and I can search for the bookmarks, but I can't search for the right folders to put them in.

All Replies (13)

more options

does bookmark side bar help? probably cmd+B

also check out some bookmark addons : https://addons.mozilla.org/en-US/firefox/search/?q=bookmark&platform=WINNT&appver=36.0.1

more options

It does help.

I see it is under View>Sidebar>Bookmarks instead of under Bookmarks.

It is still annoying to have the Bookmarks>Edit this Bookmark flash on the screen and not work.

It would still help to be able to open the Bookmarks Window/Show All Bookmarks as a tab instead of as a separate window.

I haven't yet been able to find anything in the add-ons manager to help here, but I haven't looked that long.

more options

MarjaE said

When I select "edit this bookmark," from the menu, I get a flashing pain-light on my screen

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

FredMcD said

MarjaE said
When I select "edit this bookmark," from the menu, I get a flashing pain-light on my screen

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Let me go over this again:

When I select "edit this bookmark," from the menu, I get a flashing pain-light on my screen, but no way to edit the bookmark.

How would I make a screenshot of a flashing pain-image? I think the menu option opens the same menu that command-D opens, but closes it a fraction of a second later. I'm not sure. It is painful and it isn't helpful.

more options

The kind of like a camera flash? That's a new one.on me. Are you sure it was not your computer taking a snapshot?


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

You can create a bookmark with the location set to this chrome URL to open the bookmarks as they appear in the sidebar in a tab.

  • chrome://browser/content/bookmarks/bookmarksPanel.xul

Note that Firefox uses the "chrome://" protocol to access its own internal files and also access files from extensions (no connection with Google Chrome).

more options

The flash has gone away, and the menu appears normally again. I don't know what has changed.

FredMcD said

The kind of like a camera flash? That's a new one.on me. Are you sure it was not your computer taking a snapshot?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Thanks, but no, more like rapid animation. I have a lot of trouble with the flashing pain-lights on some newspapers, the flashing pain-gifs on some other websites, etc. I have to disable autoplay and disable anim-paining-ated gifs. But that really deserves its own question, going over the different tools to deal with the different types of autoplay and animation.

cor-el said

You can create a bookmark with the location set to this chrome URL to open the bookmarks as they appear in the sidebar in a tab.
  • chrome://browser/content/bookmarks/bookmarksPanel.xul

Note that Firefox uses the "chrome://" protocol to access its own internal files and also access files from extensions (no connection with Google Chrome).

Thanks, although I'd hoped to be able to use the tools for the bookmarks window, that is useful.

more options

One more thing: when searching bookmarks, how do I search for a specific bookmark folder?

more options

Type the name in the search box. It should come up.

more options

It doesn't come up, that's why I'm asking.

more options

The only way to know to search for a folder is via the bookmarks sidebar (Ctrl+B). If the tree children panel has focus then you can jump to a specific item (bookmark or folder) by quickly pressing its first letters and quickly means quite quick or otherwise a new search is started. Note that only bookmarks and folders that are visible can be found this way, so it won't work if the folder is in a collapsed folder. To only search folder you can do this in the left pane (folder tree) or the Bookmarks Manager (Library). This way to locate an item works in a lot of cases where a tree is used.

more options

I use the bookmarks library, though it still doesn't open as a tab, or the bookmarks panel. I don't have any experience with the sidebar. I can't easily type control-b.

I know that searching for folders does. not. work. in the library.

more options

Using the search bar in the Library doesn't work to locate a folder. You would have to click in the left pane to set focus to that pane. If you type a letter then Firefox jumps to the next item that starts with this letter. If you can type two or three characters quickly enough then you jump to the item that starts with those characters.