Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox no longer plays vines or twitter gifs

more options

After I updated to version 35.0.1 I noticed that vines, both on twitter and on the vine site, and animated gifs in twitter no longer play. The gifs never even show up, and the vines load but can't play. Checked both in Chrome and they worked fine there.

Restarted in Safe Mode with all addons disabled but no luck. All extensions/addons are up to date. Switching media.windows-media-foundation.enabled back and forth does not fix.

Chosen solution

Hi, I understand that gifs will not play on vine.co and other sites.

When you changed the about:config entry media.windows-media-foundation.enabled, please restart Firefox and load the website bypassing the cache:

Reload the webpage while bypassing the cache using one of the following steps:

  • Hold down the Shift key and click the Reload button with a left click.

OR

  • Press Ctrl + F5 or Ctrl + Shift + R (Windows and Linux)
  • Press Command + Shift + R (Mac)

Let us know if this solves the issues you are having.

Read this answer in context 👍 3

All Replies (3)

more options

Chosen Solution

Hi, I understand that gifs will not play on vine.co and other sites.

When you changed the about:config entry media.windows-media-foundation.enabled, please restart Firefox and load the website bypassing the cache:

Reload the webpage while bypassing the cache using one of the following steps:

  • Hold down the Shift key and click the Reload button with a left click.

OR

  • Press Ctrl + F5 or Ctrl + Shift + R (Windows and Linux)
  • Press Command + Shift + R (Mac)

Let us know if this solves the issues you are having.

more options

You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if content from a specific domain is blocked and has a file size 0 (zero).

more options

guigs2 said

Hi, I understand that gifs will not play on vine.co and other sites. When you changed the about:config entry media.windows-media-foundation.enabled, please restart Firefox and load the website bypassing the cache: Reload the webpage while bypassing the cache using one of the following steps:
  • Hold down the Shift key and click the Reload button with a left click.
OR
  • Press Ctrl + F5 or Ctrl + Shift + R (Windows and Linux)
  • Press Command + Shift + R (Mac)
Let us know if this solves the issues you are having.

Thanks! I switched media.windows-media-foundation.enabled back to True, which is default and restarted Firefox. I loaded a vine page from the address bar history and it started playing. Tested twitter gifs and they load too. All good to go!