X
Tap here to go to the mobile version of the site.

Support Forum

Firefox now opens new tabs in new Firefox sessions. This is new behaviour and is a nuisance. How do I stop it?

Posted

This may be a Windows problem or it may be a Firefox issue.

I think it started when I installed updated Firefox to version 35.

Firefox 35 is running in Windows 8.1 on a desktop.

When I click a link in my Firefox browser, I've set FF to open new windows in a new tab instead.

It doesn't.

It opens a new window altogether that sits at the far end of my Windows task bar. If I have several tabs running, the taskbar displays the main program icon, which is pinned to the taskbar, and way over to the right it displays an icon that shows another session of Firefox. If there are three new sessions running, that icon on the right shows layers.

To close Firefox, I have to select each session and close it individually.

In the past, the Windows taskbar icon showed just one Firefox icon, although it would show layers if there was more than one tab open. Now it's showing the two as described above.

This is a nuisance. Is it caused by Firefox 35, and if so, how do I stop it?

This may be a Windows problem or it may be a Firefox issue. I think it started when I installed updated Firefox to version 35. Firefox 35 is running in Windows 8.1 on a desktop. When I click a link in my Firefox browser, I've set FF to open new windows in a new tab instead. It doesn't. It opens a new window altogether that sits at the far end of my Windows task bar. If I have several tabs running, the taskbar displays the main program icon, which is pinned to the taskbar, and way over to the right it displays an icon that shows another session of Firefox. If there are three new sessions running, that icon on the right shows layers. To close Firefox, I have to select each session and close it individually. In the past, the Windows taskbar icon showed just one Firefox icon, although it would show layers if there was more than one tab open. Now it's showing the two as described above. This is a nuisance. Is it caused by Firefox 35, and if so, how do I stop it?

Chosen solution

To close all of Firefox; Menu > Files > Exit.

There are also add-ons available that can put a Close Button on the toolbar. Go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) and search for what you want.


Open Firefox. Once the second icon is displayed, mouse to the first icon, right click and Unpin it. Close that one if it is still on the bar. Now go to the other icon, and pin it. Restart Firefox.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0

Application

  • Firefox 35.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0/WINNT/en-US/

Extensions

  • McAfee Security Scan Plus 1.0 ({e4f94d1e-2f53-401e-8885-681602c0ddd8}) (Inactive)
  • Norton Toolbar 2014.7.10.16 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 8570
  • adapterDescription2:
  • adapterDeviceID: 0x6611
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 7-31-2013
  • driverDate2:
  • driverVersion: 13.150.102.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 8570 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
3774 solutions 52283 answers

Type about:preferences#general<enter> in the address bar. Check the settings under Tabs

Type '''about:preferences#general'''<enter> in the address bar. Check the settings under '''Tabs'''

Question owner

Thanks, Fred. The settings checked under "Tabs" are Open new windows in a new tab instead, and When I open...switch to it immediately.

Maybe I'm describing the problem incorrectly. Firefox is 'pinned' to my taskbar. When clicked, a second FF icon appears to the right and it is not pinned. It appears to be an entirely new session. New tabs open in it.

My home page is a web page with links with the target=_blank attribute. When I click one a new session starts with two tabs in it, my home page and the page for the url I linked to. The attached image shows four FF sessions running, three of them with two tabs, resulting from clicking 3 links on my home page. Instead of one "unlit" icon and one "lit" icon with seven tabs shared between four sessions, there should be one icon, lit, with one session with four tabs.

I think this started happening when FF upgraded to version 35, but it may have been when Windows 8.1 upgraded itself, if that happened recently. I've only noticed this behaviour for a few days; until then FF stayed in one session with multiple tabs, and only the pinned program icon showing in the task bar.

This ONLY occurs with Firefox. My other browsers, IE 11, Opera 26 and Safari, just use the one pinned icon.

Thanks, Fred. The settings checked under "Tabs" are Open new windows in a new tab instead, and When I open...switch to it immediately. Maybe I'm describing the problem incorrectly. Firefox is 'pinned' to my taskbar. When clicked, a second FF icon appears to the right and it is not pinned. It appears to be an entirely new session. New tabs open in it. My home page is a web page with links with the target=_blank attribute. When I click one a new session starts with two tabs in it, my home page and the page for the url I linked to. The attached image shows four FF sessions running, three of them with two tabs, resulting from clicking 3 links on my home page. Instead of one "unlit" icon and one "lit" icon with seven tabs shared between four sessions, there should be one icon, lit, with one session with four tabs. I think this started happening when FF upgraded to version 35, but it may have been when Windows 8.1 upgraded itself, if that happened recently. I've only noticed this behaviour for a few days; until then FF stayed in one session with multiple tabs, and only the pinned program icon showing in the task bar. This ONLY occurs with Firefox. My other browsers, IE 11, Opera 26 and Safari, just use the one pinned icon.

Modified by DavidinDelta

FredMcD
  • Top 10 Contributor
3774 solutions 52283 answers

Chosen Solution

To close all of Firefox; Menu > Files > Exit.

There are also add-ons available that can put a Close Button on the toolbar. Go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) and search for what you want.


Open Firefox. Once the second icon is displayed, mouse to the first icon, right click and Unpin it. Close that one if it is still on the bar. Now go to the other icon, and pin it. Restart Firefox.

To close all of Firefox; '''Menu > Files > Exit.''' There are also add-ons available that can put a '''Close Button''' on the toolbar. Go to the '''[https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page]''' {web link} (There’s a lot of good stuff here) and search for what you want. -------------------------- Open Firefox. Once the second icon is displayed, mouse to the first icon, right click and '''Unpin''' it. Close that one if it is still on the bar. Now go to the other icon, and pin it. Restart Firefox.

Question owner

Thank you, Fred. that solved my problem.

Thank you, Fred. that solved my problem.

Helpful Reply

Followup - the Firefox update to version 35.01 caused the same issue again. Thanks to Fred, I was able to fix it right away.

I'm pretty sure the fault is caused by some change in the installer used for versions 35 and 35.01 because no previous updates caused the problem.

Followup - the Firefox update to version 35.01 caused the same issue again. Thanks to Fred, I was able to fix it right away. I'm pretty sure the fault is caused by some change in the installer used for versions 35 and 35.01 because no previous updates caused the problem.