Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Updated to Firefox 35 and now I get a Javascript error message

  • 11 replies
  • 150 have this problem
  • 19343 views
  • Last reply by banchormin

more options

My Firefox updated to version 35 and now on every page I go I get this javascript error message: : 'navigator' getter called on an object that does not implement window interface. I'm not sure what is the source of the error. I have not installed any new extensions. I'm attaching an image so you can see the error message.

Attached screenshots

Chosen solution

It was indeed caused by an Add-On. I disabled all of them and enabled them back one by one. The culprit is Fast Search by Surf Canyon 3.4.3. Anyone having this issue should just disable the add-on. Maybe this will be fixed with a future update.

Read this answer in context 👍 11

All Replies (11)

more options

This is most likely caused by an add-on. Please try to Reset Firefox and see if that helps, Refresh Firefox - reset add-ons and settings

more options

Chosen Solution

It was indeed caused by an Add-On. I disabled all of them and enabled them back one by one. The culprit is Fast Search by Surf Canyon 3.4.3. Anyone having this issue should just disable the add-on. Maybe this will be fixed with a future update.

more options

Please report this to that add-ons support page.

more options

I've reported it to the folks who make the add-on. They are working on it to see if they can replicate the issue.

more options

The problems is resolved if you install v5.4.0 from http://www.surfcanyon.com/extension.jsp.

https://addons.mozilla.org/en-US/firefox/addon/google-assistant-by-surf-canyo/ is currently v3.4.3 but we are working on getting that updated.

If any need any assistance or would like to provide feedback, please contact us at http://www.surfcanyon.com/contact.jsp.

more options

Thank you for the assistance!

more options

EAngueira said

My Firefox updated to version 35 and now on every page I go I get this javascript error message: : 'navigator' getter called on an object that does not implement window interface. I'm not sure what is the source of the error. I have not installed any new extensions. I'm attaching an image so you can see the error message.


The problems is resolved if you install v5.4.0 from http://www.surfcanyon.com/extension.jsp.

https://addons.mozilla.org/en-US/firefox/addon/google-assistant-by-surf-canyo/ is currently v3.4.3 but we are working on getting that updated.

If any need any assistance or would like to provide feedback, please contact us at http://www.surfcanyon.com/contact.jsp.

more options

For the ones that use SoundClouder downloader 1.0.0.6 from pc-gizmos, it's causing this problem too.

more options

Since my Firefox updated to version 35 I too have had this problem. Difference is that I have never used Surf Canyon nor would ever possibly use it. I have had to go back to version 33 to eradicate both this navigator:getter error and also the unclosable tabs error that recently appeared. If I reset firefox then the navigator:getter error disappears but the tab problem remains. But with over 40 extensions and 12 user scripts running it takes some narrowing down. I have no different extensions or user scripts than I had with version 33, so I can only conclude that a change in Firefox's guts have caused these problems. Any thoughts are welcome.

more options

It is possible that a change in Firefox broke an existing extension (especially if it was an extension that hasn't been updated recently). Mozilla makes no guarantees that extensions won't break in the future, and though we try to keep breakage down to a minimum, it's inevitable that some extensions will break.

You should update to 35 (since running old versions leaves you vulnerable to attacks) and then try disabling half your extensions. If the problem goes away, you know it was that half. If it's still there, it's in the other half. Keep doing this to narrow down the problem extension. Also, see if there are any extensions you don't need or use anymore, it's good to clean them up once in a while. Sometimes the reason you need an extension in the past isn't valid anymore, the feature was added to Firefox, or you just installed it and forgot and never used it. This can help your overall Firefox performance as well.

more options

My Error was also caused by an addon. Greasedlightbox 1.1. I disabled all and re-enabled them until the error showed up on this app. thanks