Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search bar and address bar isn't working when a new tab is opened

more options

When a new tab is opened, neither the address bar search or the search on the page work. Nothing at all happens when search or the arrow is clicked.

Chosen solution

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

Read this answer in context 👍 0

All Replies (12)

more options

Hello Gallawa, try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

thank you

more options

You can try to open a new window in case there is a problem with the current window.

more options

Tried searching in safe mode, still didn't work. Even opening new windows won't allow me to search. I can only search if I go to the Yahoo homepage and use the search on that page. I tried an in private browsing window and typed in an address. Still didn't work.

more options

Gallawa said

When a new tab is opened, neither the address bar search or the search on the page work. Nothing at all happens when search or the arrow is clicked.

Before new tab opened in the Duck Duck Go search box now it opens on the address bar.

more options

No search anywhere on any tab works except on the very first tab that opens when you first open Firefox. Any subsequent tab searches do not work. Address bar does not work, the search next to the address bar does not work, and the search above the tiles does not work.

more options

My major consern is that you use NT4 and I just wonder if your system can handle programs developed 18 years after your OS. If your pc is of the same age, there could be a memory isue that prevent you from searching.

more options

Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

No I don't use NT4. It is Windows XP and is a gaming computer. No memory issues.

more options

I just tried changing the compatibility mode shutting down the program and starting again. Didn't work.  :( For some reason I'm being blocked from adding any search engine.

more options

Chosen Solution

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

more options

Gallawa said

When a new tab is opened, neither the address bar search or the search on the page work. Nothing at all happens when search or the arrow is clicked.

I think it may be fixed. When I turned everything off last night, it wasn't working. When I turned the system back on this AM and booted Firefox, it asked me to include 2 add ons. Did that and the search is working.

Thanks for all your help!

more options

I am having the same problem - even in safe mode. I've refreshed Firefox, deleted all cookies, emptied my cache, but nothing works. I'm also getting a message the firefox is failing to sync, and "this object has moved". I know these are all different issues, but I suspect that there is a link.

I have very limited ftp knowledge, so please assume I know nothing when responding. Really hope you can help!