Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Reddit not displaying properly after updating Firefox.

  • 2 replies
  • 5 have this problem
  • 2486 views
  • Last reply by ZombieToast

more options

Although I have been very reluctant to do so, I just updated Firefox to version 34.0.5 and I've just about got everything looking/working the way I want, but for some reason, I am having a couple of issues with Reddit not displaying properly. If you take a look at the screenshot I've attached, you can see that the CSS appears to be screwy. This doesn't happen on any other browser and it didn't happen before I updated. I have tried clearing my cache and cookies, but that didn't make a difference. I have also tried starting Firefox in Safe Mode with all add-ons disabled, but this problem still persists.

On top of that, I'm having an issue with Firefox not saving the state of pages when I go back or forward. What I mean is that while browsing a thread on Reddit, if I collapse several comments and then click on a link, when I go back to the thread, the comments will no longer be collapsed. Firefox is essentially refreshing the page whenever I leave it and come back, which I do NOT want. This wasn't an issue before updating and, so far, it seems to only be a problem on Reddit (but I haven't entirely confirmed this).

What can I do to resolve these annoyances? Any help would be appreciated!

Attached screenshots

Modified by ZombieToast

Chosen solution

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if (CSS) content is blocked and has a file size 0 (zero).

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can open the Web Console (Firefox/Tools > Web Developer). Check on the Network tab if (CSS) content is blocked and has a file size 0 (zero).

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Thanks for the reply! I had tried those first steps previously and they didn't work, but when I started up Firefox today, everything was displaying normally. I guess I just needed to give it more time.

Just for the heck of it, I tried to forget the site as you suggested, but doing so caused Firefox to stop responding. I suspect it may be because I have so many pages in my history. I might try manually deleting some of my history files and see if that will make a difference. Now that I am aware of this feature, I'd like to be able to use it occasionally.

As for my auto-refreshing issue, I tried changing the value of "browser.cache.check_doc_frequency" from 3 to 2 and I thought that fixed it, but the problem still persists. Not really sure what I can do about this and it has me tempted to revert back to an older version of Firefox.

EDIT: Nevermind, I figured out the refreshing problem. I was unknowingly connecting to Reddit via https instead of regular http. Apparently the secure version of the site is set up to work this way and it wasn't an issue with Firefox at all.

Thanks again!

Modified by ZombieToast