Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox rounded buttons rendering issue

  • 2 replies
  • 4 have this problem
  • 1193 views
  • Last reply by utopic

more options

Hello,

It seems that Firefox has issues with rounded buttons (as far as I can tell).

I will post a couple of screenshots to demonstrate:

http://screencast.com/t/EJ2wIJMrna

a refresh of the same page, produces different artifacts, of the same nature:

http://screencast.com/t/NBqrrqTQVp8

Sometimes, if you refresh a page enough times, you might not get such artifacts.

The webpage from the screenshots is: https://developer.mozilla.org/en-US/docs/Web/CSS/border-radius but I've seen this issue on a lot of pages, occasionally even on the Google search page.

I'm running the latest, official, stable version of Firefox, but I've been noticing this issue for at least the last 2-3 versions of the browser.

Modified by utopic

Chosen solution

You can try to disable OMTC and leave hardware acceleration in Firefox enabled.

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

You can try to disable OMTC and leave hardware acceleration in Firefox enabled.

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

Thank you for the reply, cor-el.

OMTC does not make any difference, but disabling hardware acceleration solves this issue.