X
Tap here to go to the mobile version of the site.

Support Forum

Firefox opens to http.com instead of home page

Posted

I have my home page set to MSN.com and before all my problems with Firefox 34 started it had always opened to that page. Now suddenly, even though the home page is still set to MSN.com Firefox is opening to something called http.com. I have no idea where this is coming from or how to stop it. The images I've uploaded will show that the home page is still set and what I get when I open Firefox. Does anyone know what is going on and how to stop it?

I have my home page set to MSN.com and before all my problems with Firefox 34 started it had always opened to that page. Now suddenly, even though the home page is still set to MSN.com Firefox is opening to something called http.com. I have no idea where this is coming from or how to stop it. The images I've uploaded will show that the home page is still set and what I get when I open Firefox. Does anyone know what is going on and how to stop it?
Attached screenshots

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • 5.1.30514.0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.1.151
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • Firefox 33.1.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.1.1/WINNT/en-US/

Extensions

  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • QuickJS 1.3 ({bb65e674-b194-4b6e-8033-5fa0afe3a198})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 210
  • adapterDescription2:
  • adapterDeviceID: 0x0a65
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 2-8-2014
  • driverDate2:
  • driverVersion: 9.18.13.3489
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 210 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.frecency_experiment: 1
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141113143407
  • browser.startup.homepage: http://www.msn.com/
  • browser.startup.homepage_override.buildID: 20141113143407
  • browser.startup.homepage_override.mstone: 33.1.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 33.1.1
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • media.gmp-gmpopenh264.autoupdate: False
  • media.gmp-gmpopenh264.lastUpdate: 1415361668
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1419776514
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1419773884
  • places.history.expiration.transient_current_max_pages: 67089
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • plugin.state.np32dsw: 2
  • plugin.state.npctrl: 2
  • plugin.state.npnv3dv: 2
  • plugin.state.npnv3dvstreaming: 2
  • plugin.state.nppdf: 2
  • plugin.state.npqtplugin: 2
  • privacy.cpd.cookies: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1419688738

Misc

  • User JS: Yes
  • Accessibility: No
the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40160 answers

What's that you have typed in the Search Bar?

What's that you have typed in the Search Bar?

Question owner

the-edmeister said

What's that you have typed in the Search Bar?

http.com I was trying to find something that would tell me how to get rid of this thing. This all started when Mozilla automatically updated me to Firefox 34 and I haven't been able to get rid of it ever since. That second image is the first thing I got when I opened Firefox for the first time after is was updated.

''the-edmeister [[#answer-670418|said]]'' <blockquote> What's that you have typed in the Search Bar? </blockquote> http.com I was trying to find something that would tell me how to get rid of this thing. This all started when Mozilla automatically updated me to Firefox 34 and I haven't been able to get rid of it ever since. That second image is the first thing I got when I opened Firefox for the first time after is was updated.

Modified by wildchild1954

cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157978 answers

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

You can check the home page setting: *Tools > Options > General > Startup: Home page Firefox supports multiple home pages separated by '|' (pipe) symbols. *https://support.mozilla.org/kb/How+to+set+the+home+page You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

Question owner

cor-el said

You can check the home page setting:
  • Tools > Options > General > Startup: Home page
Firefox supports multiple home pages separated by '|' (pipe) symbols. You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

I've already been through all of these steps and things for setting the home page. None of them work to stop this http.com (which is apparently some kind of virus or malware). And like I said, this seems to have come with the recent update to Firefox 34 because I never had it before.

''cor-el [[#answer-670491|said]]'' <blockquote> You can check the home page setting: *Tools > Options > General > Startup: Home page Firefox supports multiple home pages separated by '|' (pipe) symbols. *https://support.mozilla.org/kb/How+to+set+the+home+page You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program. </blockquote> I've already been through all of these steps and things for setting the home page. None of them work to stop this http.com (which is apparently some kind of virus or malware). And like I said, this seems to have come with the recent update to Firefox 34 because I never had it before.
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157978 answers

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware

Question owner

cor-el said

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. You can also do a check for a rootkit infection with TDSSKiller. See also:

OK with the exception of Microsoft Safety Scanner and Kaspersky (both of which failed to download) I downloaded and ran the other programs on your list. I already had AVG and Malwarebytes and had run them. Not a one of these did me any good at all. I opened Firefox and bingo! there was the damned site for http:com again. So now what do I try?

''cor-el [[#answer-670506|said]]'' <blockquote> Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware </blockquote> OK with the exception of Microsoft Safety Scanner and Kaspersky (both of which failed to download) I downloaded and ran the other programs on your list. I already had AVG and Malwarebytes and had run them. Not a one of these did me any good at all. I opened Firefox and bingo! there was the damned site for http:com again. So now what do I try?
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157978 answers

Did you check the target line in the (desktop) shortcut that you use to launch Firefox?


Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then also create a new profile.


Did you check the target line in the (desktop) shortcut that you use to launch Firefox? ---- Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the full Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then also create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

Question owner

cor-el said

Did you check the target line in the (desktop) shortcut that you use to launch Firefox?

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then also create a new profile.


Yes, I have checked the target line. Yes, I have done a complete uninstall and new install. I even deleted the personal information since I have the bookmarks backed up. Maybe what I should be saying is that when I open Firefox it opens with two windows and the front one is that freaking http.com thing and the other is my actual homepage. And I know this has to be something with Firefox because IE doesn't do it. All I want to do is get rid of the http.com thing when I open Firefox.

''cor-el [[#answer-670620|said]]'' <blockquote> Did you check the target line in the (desktop) shortcut that you use to launch Firefox? ---- Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the full Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then also create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall </blockquote> Yes, I have checked the target line. Yes, I have done a complete uninstall and new install. I even deleted the personal information since I have the bookmarks backed up. Maybe what I should be saying is that when I open Firefox it opens with two windows and the front one is that freaking http.com thing and the other is my actual homepage. And I know this has to be something with Firefox because IE doesn't do it. All I want to do is get rid of the http.com thing when I open Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157978 answers
You can try: *http://www.removalvideos.com/guide-to-remove-www-http-com-useful-removal-tips/

Question owner

cor-el said

You can try:

Been there and done that already too. Found that one while doing a search for information on how to remove this. Didn't work. I'm going to try doing a complete uninstall and installing 33.1.1 instead. Then I'll shut off the update function and see how that works.

''cor-el [[#answer-670630|said]]'' <blockquote> You can try: *http://www.removalvideos.com/guide-to-remove-www-http-com-useful-removal-tips/ </blockquote> Been there and done that already too. Found that one while doing a search for information on how to remove this. Didn't work. I'm going to try doing a complete uninstall and installing 33.1.1 instead. Then I'll shut off the update function and see how that works.

Question owner

I had already tried that other thing you suggested as well. However after uninstalling completely the 34.0.5 version I restarted my computer before installing 33.1.1. I then immediately went into options and turned off the update function. Shut down Firefox. Started it again and glory be that darned thing seems to be gone since it didn't happen. I think I'll just quietly sit here using 33.1.1 and avoiding 34.0.5 as much as possible. Thanks for all the help you have tried to give me.!!

I had already tried that other thing you suggested as well. However after uninstalling completely the 34.0.5 version I restarted my computer before installing 33.1.1. I then immediately went into options and turned off the update function. Shut down Firefox. Started it again and glory be that darned thing seems to be gone since it didn't happen. I think I'll just quietly sit here using 33.1.1 and avoiding 34.0.5 as much as possible. Thanks for all the help you have tried to give me.!!

Question owner

Looks like I was wrong. It worked OK the first time but I just opened Firefox again and there was the damned thing again. So I still need help to get rid of it. And no, it didn't update to 34.0.5 so that isn't it.

Looks like I was wrong. It worked OK the first time but I just opened Firefox again and there was the damned thing again. So I still need help to get rid of it. And no, it didn't update to 34.0.5 so that isn't it.