X
Tap here to go to the mobile version of the site.

Support Forum

cannot change my homepage

Posted

Using Mozilla Firefox 34.0 with Windows 7. I want to change my homepage. I change the homepage in both the tools/options and/or the menu/options...the little house works perfectly. I close Firefox. When I reopen Firefox my homepage is set to the old webpage not the new one. I went through the Reset Firefox procedure...no help. What can I do?

Using Mozilla Firefox 34.0 with Windows 7. I want to change my homepage. I change the homepage in both the tools/options and/or the menu/options...the little house works perfectly. I close Firefox. When I reopen Firefox my homepage is set to the old webpage not the new one. I went through the Reset Firefox procedure...no help. What can I do?

Chosen solution

Ok, hit Ctrl+Alt+Del button and go to Windows Task Manager. Check first Application tab if any suspicious apps are running. Then check for Processes – you could start killing one by one and check if it resolve the issue. Try to stay away from system processes. If the comp crashes then reboot.

Now, here is a work around (not perfect): create shortcut with the homepage and bookmark with home page and use it. Please let me know if you would like more details how to do this.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • Office Live Update v1.5
  • Shockwave Flash 16.0 r0
  • Shockwave Flash 14.0 r0
  • Shockwave Flash 12.0 r0
  • Shockwave Flash 13.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0

More Information

esimin 1 solutions 6 answers

The issue could be not with Firefox, but with a newly installed program that sits in memory and constantly overwrites the home page. I would start with rebooting PC, and testing for the issue. Go to uninstall programs in Control Panel and see what was recently installed. I also would try to disable Firefox add ons.

The issue could be not with Firefox, but with a newly installed program that sits in memory and constantly overwrites the home page. I would start with rebooting PC, and testing for the issue. Go to uninstall programs in Control Panel and see what was recently installed. I also would try to disable Firefox add ons.

Question owner

esimin said

The issue could be not with Firefox, but with a newly installed program that sits in memory and constantly overwrites the home page. I would start with rebooting PC, and testing for the issue. Go to uninstall programs in Control Panel and see what was recently installed. I also would try to disable Firefox add ons.
''esimin [[#answer-667204|said]]'' <blockquote> The issue could be not with Firefox, but with a newly installed program that sits in memory and constantly overwrites the home page. I would start with rebooting PC, and testing for the issue. Go to uninstall programs in Control Panel and see what was recently installed. I also would try to disable Firefox add ons. </blockquote>

Question owner

I have used Firefox for about one year and have not changed my homepage from the first day. That homepage has now been taken down. So I have not tried to change homepage for a year. So all new programs and updates for the last year would be suspect. How do I figure out which one could be suspect?

I do not believe that I have any Firefox add ons. The menu/add ons does not indicate any. How do I find them and disable?

I have used Firefox for about one year and have not changed my homepage from the first day. That homepage has now been taken down. So I have not tried to change homepage for a year. So all new programs and updates for the last year would be suspect. How do I figure out which one could be suspect? I do not believe that I have any Firefox add ons. The menu/add ons does not indicate any. How do I find them and disable?
esimin 1 solutions 6 answers

Let’s step back. Could you please try this: 1. Reboot your PC 2. Open Fierefox 3. Go to the new website you want to be home 4. Go Menu -> Options -> General tab 5. Press ‘Use Current Pages’ button and choose ‘When Firefox starts: Show my home page’ 6. Press ‘OK’ button 7. Close & Open Firefox, check if the issue go away or not

Considering what is the suspect – usually it is something that comes with free software. For example MS Office is not a suspect, but some free shopping bar that comes with good free soft could be doing this.

Let’s step back. Could you please try this: 1. Reboot your PC 2. Open Fierefox 3. Go to the new website you want to be home 4. Go Menu -> Options -> General tab 5. Press ‘Use Current Pages’ button and choose ‘When Firefox starts: Show my home page’ 6. Press ‘OK’ button 7. Close & Open Firefox, check if the issue go away or not Considering what is the suspect – usually it is something that comes with free software. For example MS Office is not a suspect, but some free shopping bar that comes with good free soft could be doing this.

Modified by esimin

Question owner

I did all 7 steps (have done this about 20 times by now) and when I start up Firefox the old homepage still comes up.

I did all 7 steps (have done this about 20 times by now) and when I start up Firefox the old homepage still comes up.
jayelbe 49 solutions 280 answers

Hi jayhawk73,

There are some instructions in this article that might be helpful: How to fix preferences that won't save

Hi jayhawk73, There are some instructions in this article that might be helpful: [[How to fix preferences that won't save]]
esimin 1 solutions 6 answers

Chosen Solution

Ok, hit Ctrl+Alt+Del button and go to Windows Task Manager. Check first Application tab if any suspicious apps are running. Then check for Processes – you could start killing one by one and check if it resolve the issue. Try to stay away from system processes. If the comp crashes then reboot.

Now, here is a work around (not perfect): create shortcut with the homepage and bookmark with home page and use it. Please let me know if you would like more details how to do this.

Ok, hit Ctrl+Alt+Del button and go to Windows Task Manager. Check first Application tab if any suspicious apps are running. Then check for Processes – you could start killing one by one and check if it resolve the issue. Try to stay away from system processes. If the comp crashes then reboot. Now, here is a work around (not perfect): create shortcut with the homepage and bookmark with home page and use it. Please let me know if you would like more details how to do this.

Question owner

I started through the Windows Task Manager--big job...I like the work around...I will use it. Thanks!

I started through the Windows Task Manager--big job...I like the work around...I will use it. Thanks!
esimin 1 solutions 6 answers

Yep, all the best

Yep, all the best
cor-el
  • Top 10 Contributor
  • Moderator
16332 solutions 147386 answers

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.