Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not displaying corectly in remote desktop

  • 2 replies
  • 4 have this problem
  • 12070 views
  • Last reply by FUBAR-BDHR

more options

This issue has existed with firefox for as long as I can remember. If I start up firefox on any computer then log into that computer from another using remote desktop the firefox window displays as nothing by a big black box. There are not controls, menus, or even an x to close it. It can be closed by right clicking on the taskbar and choosing close window. Now if I start firefox while logged in from remote desktop it works just fine. Even if I disconnect and reconnect it will still display correctly. The problem only occurs if firefox is launched from the computer then I remote in. The open webpages, tabs, ect do not matter as I can restore the previous session just fine. Some of the computer have no addons installed so that rules those out as a possible cause.

Is there any solution to this? It's usually not a big deal as it usually only involves one computer but occasionally like today I had to reboot every system on my network and load up firefox to do some stuff then remote into those systems just now only to have to restart firefox on every one.

Chosen solution

hello FUBAR-BDHR, that may well be an issue with hardware acceleration - please try to disable hardware acceleration in the firefox menu ≡ > options > advanced > general (that setting will take a restart of the browser to take effect) & see if the situation changes...

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

hello FUBAR-BDHR, that may well be an issue with hardware acceleration - please try to disable hardware acceleration in the firefox menu ≡ > options > advanced > general (that setting will take a restart of the browser to take effect) & see if the situation changes...

more options

Looks like that fixed the issue at least on the one machine I tried it on.