X
Tap here to go to the mobile version of the site.

Support Forum

I get the message "Untrusted Connection" just with Firefox; not with IExplorer.

Posted

This Connection is Untrusted You have asked Firefox to connect securely to bay174.mail.live.com, but we can't confirm that your connection is secure.

Technical Details An error occurred during a connection to bay174.mail.live.com. Peer's certificate has been marked as not trusted by the user. (Error code: sec_error_untrusted_cert)

(The option to "I understand the risks" is not there.)

This Connection is Untrusted You have asked Firefox to connect securely to bay174.mail.live.com, but we can't confirm that your connection is secure. Technical Details An error occurred during a connection to bay174.mail.live.com. Peer's certificate has been marked as not trusted by the user. (Error code: sec_error_untrusted_cert) (The option to "I understand the risks" is not there.)

Chosen solution

Hi ianiab, your Firefox settings folder (profile folder) is hidden. To find cert8.db and other files, you can access the folder from inside Firefox using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new Windows Explorer window listing your settings files and various subfolders.

Note: Please fully close all Firefox windows before renaming or removing any settings files.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • 5.1.30514.0
  • GEPlugin
  • iLok Client Helper Plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 33.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.1/WINNT/en-US/

Extensions

  • AdDetector 0.17 (19b15b40-23f9-11e4-8c21-0800200c9a66@jetpack)
  • Advanced SystemCare Surfing Protection 2.0 (iobitascsurfingprotection@iobit.com)
  • Lightbeam 1.1.0 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • Privacy Badger Firefox 0.2.3 (jid1-MnnxcxisBPnSXQ@jetpack)
  • RealDownloader 1.3.1 ({DAC3F861-B30D-40dd-9166-F4E75327FAC7})
  • Skype Click to Call 7.3.16540.9015 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Hotspot Shield Extension 3.13 (afext@anchorfree.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 7025 / NVIDIA nForce 630a
  • adapterDescription2:
  • adapterDeviceID: 0x03d6
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvd3dum
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: B ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 9.18.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 7025 / NVIDIA nForce 630a Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 4
  • browser.cache.memory.capacity: 65536
  • browser.display.background_color: #C0C0C0
  • browser.display.show_image_placeholders: True
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 7
  • browser.privatebrowsing.autostart: True
  • browser.search.useDBForOrder: false
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140923175406
  • browser.startup.homepage: https://www.yahoo.com/
  • browser.startup.homepage_override.buildID: 20141106120505
  • browser.startup.homepage_override.mstone: 33.1
  • browser.urlbar.autocomplete.enabled: True
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 33.1
  • general.useragent.extra.btrs: BTRS5841
  • media.gmp-gmpopenh264.lastUpdate: 1413412491
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1417206034
  • network.cookie.prefsMigrated: True
  • network.http.max-connections: 48
  • network.http.max-connections-per-server: 16
  • network.http.max-persistent-connections-per-proxy: 16
  • network.http.max-persistent-connections-per-server: 8
  • network.http.pipelining.maxrequests: 8
  • network.http.request.max-start-delay: 0
  • places.database.lastMaintenance: 1417191175
  • places.history.expiration.transient_current_max_pages: 100646
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • plugin.state.npdlplugin: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.npitunes: 0
  • plugin.state.nppl: 0
  • plugin.state.npqtplugin: 0
  • plugin.state.nprndlchromebrowserrecordext: 0
  • plugin.state.nprndlhtml5videoshim: 0
  • plugin.state.nprndlpepperflashvideoshim: 0
  • plugin.state.nprpplugin: 0
  • plugin.state.npwlpg: 0
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.disable_button.openCertManager: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1416608254

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

You can use the https://mail.live.com link instead. It is best to avoid bookmarking links to specific servers that website use for load balancing and use a link without such a special server.

You can use the https://mail.live.com link instead. It is best to avoid bookmarking links to specific servers that website use for load balancing and use a link without such a special server.

Question owner

It doesn't work.

It doesn't work.
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

Another user reported an error with that same server: Hotmail untrusted connection,why? (although marked solved, the problem came back).

Is this an isolated problem or have you received certificate errors on other sites recently?

Another user reported an error with that same server: [https://support.mozilla.org/questions/1019979 Hotmail untrusted connection,why?] (although marked solved, the problem came back). Is this an isolated problem or have you received certificate errors on other sites recently?
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Helpful Reply

You can try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

See also:

You can try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored. If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate. See also: *http://www.networking4all.com/en/support/tools/site+check/report/?fqdn=bay174.mail.live.com&protocol=https

Question owner

It is an isolated problem, and it only occurs with Firefox; not with other browsers like Avant or IExplorer. And it is a recent problem. 4 or 5 days ago Outlook.com was working OK with Firefox.

It is an isolated problem, and it only occurs with Firefox; not with other browsers like Avant or IExplorer. And it is a recent problem. 4 or 5 days ago Outlook.com was working OK with Firefox.

Question owner

Mi PC doesn't have the cert8.db and cert_override.txt files (even viewing system files and folders)

Mi PC doesn't have the cert8.db and cert_override.txt files (even viewing system files and folders)
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

Chosen Solution

Hi ianiab, your Firefox settings folder (profile folder) is hidden. To find cert8.db and other files, you can access the folder from inside Firefox using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new Windows Explorer window listing your settings files and various subfolders.

Note: Please fully close all Firefox windows before renaming or removing any settings files.

Hi ianiab, your Firefox settings folder (profile folder) is hidden. To find cert8.db and other files, you can access the folder from inside Firefox using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. This should launch a new Windows Explorer window listing your settings files and various subfolders. Note: Please fully close all Firefox windows before renaming or removing any settings files.

Question owner

It worked!! Thank you very much.

It worked!! Thank you very much.

Question owner

Sorry! It worked but just partially. Now, being in the Outlook.com site I receive again the message: This Connection is Untrusted You have asked Firefox to connect securely to bay174.mail.live.com, but we can't confirm that your connection is secure.

Technical Details An error occurred during a connection to bay174.mail.live.com. Peer's certificate has been marked as not trusted by the user. (Error code: sec_error_untrusted_cert)

Sorry! It worked but just partially. Now, being in the Outlook.com site I receive again the message: This Connection is Untrusted You have asked Firefox to connect securely to bay174.mail.live.com, but we can't confirm that your connection is secure. Technical Details An error occurred during a connection to bay174.mail.live.com. Peer's certificate has been marked as not trusted by the user. (Error code: sec_error_untrusted_cert)
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Do you have security software that might be causing this issue?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

Do you have security software that might be causing this issue? Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

Question owner

How could a security software cause a problem just four days ago (not before)and only on Firefox but not in other browsers? I'll do the test, anyway.

How could a security software cause a problem just four days ago (not before)and only on Firefox but not in other browsers? I'll do the test, anyway.
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

Even though your Firefox is reporting this somewhat rare error -- "Peer's certificate has been marked as not trusted by the user." -- it could indicate a more common situation of having a wrong or unknown issuer for the certificate. Are you able to inspect the certificate using the technique in this post: https://support.mozilla.org/questions/1019979#answer-636533 ? If so, what appears in the "Issued by" section?

Even though your Firefox is reporting this somewhat rare error -- "Peer's certificate has been marked as not trusted by the user." -- it could indicate a more common situation of having a wrong or unknown issuer for the certificate. Are you able to inspect the certificate using the technique in this post: https://support.mozilla.org/questions/1019979#answer-636533 ? If so, what appears in the "Issued by" section?

Question owner

Hi jscher, I read the entire https://support...#answer-636533, but was unable to identify any certificate inspection technique.

Nonetheless, in that page you say that "System clock: inaccurate date, time, or time zone" is one of the causes of problems connecting to secure sites, and I always use a VPN (StrongVPN) with an IP in the United Kingdom, while my computer has a UTC-06:00 time zone.

Today I have verified that Firefox works OK if I didn't use the VPN. It only reports outlook.com to be an untrusted connection when I use the VPN. But all other browsers work OK with the VPN. Firefox has been working 1 year OK with the VPN, and the problem started 5 or 6 days ago, and it is a problem just with outlook.com.

Hi jscher, I read the entire https://support...#answer-636533, but was unable to identify any certificate inspection technique. Nonetheless, in that page you say that "System clock: inaccurate date, time, or time zone" is one of the causes of problems connecting to secure sites, and I always use a VPN (StrongVPN) with an IP in the United Kingdom, while my computer has a UTC-06:00 time zone. Today I have verified that Firefox works OK if I didn't use the VPN. It only reports outlook.com to be an untrusted connection when I use the VPN. But all other browsers work OK with the VPN. Firefox has been working 1 year OK with the VPN, and the problem started 5 or 6 days ago, and it is a problem just with outlook.com.
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

Hi ianiab, the technique was in the post I linked to:

  • Type or paste chrome://pippki/content/exceptionDialog.xul into the address bar and press Enter to open the "Add Exception" dialog in a tab
  • Click the "Get Certificate" button, then click the "View button
  • What is listed in the "Issued by" section?

I'm not sure why you get different results connecting directly vs. through StrongVPN. A date/time/time zone issue usually would affect lots of secure sites and not just one, so I doubt that is the cause.

Hi ianiab, the technique was in the post I linked to: * Type or paste '''chrome://pippki/content/exceptionDialog.xul''' into the address bar and press Enter to open the "Add Exception" dialog in a tab * Firefox should highlight https:// on the line for Location. Change that to '''https://bay174.mail.live.com/''' * Click the "Get Certificate" button, then click the "View button * What is listed in the "Issued by" section? ---- I'm not sure why you get different results connecting directly vs. through StrongVPN. A date/time/time zone issue usually would affect lots of secure sites and not just one, so I doubt that is the cause.

Question owner

Hi sjcher, Yesterday I reinstalled Firefox. Previously I had the version in English and now I installed the version in Spanish (just trying to fix the problem), so the messages are in Spanish, but they can be translated as: "The certificate cannot be verified because the issuer is unknown..." "Organization: Microsoft Corporation..."

Hi sjcher, Yesterday I reinstalled Firefox. Previously I had the version in English and now I installed the version in Spanish (just trying to fix the problem), so the messages are in Spanish, but they can be translated as: "The certificate cannot be verified because the issuer is unknown..." "Organization: Microsoft Corporation..."
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

Hi ianiab, can you copy/paste all 3 lines from the Issued by section or post a screen shot?

Hi ianiab, can you copy/paste all 3 lines from the Issued by section or post a screen shot?

Helpful Reply

The screen shot.

The screen shot.
jscher2000
  • Top 10 Contributor
8789 solutions 71880 answers

I think the certificate you're seeing is legitimate. You may be able to add an exception on that full-page exception dialog.

Maybe Firefox is getting thrown off by the time zone difference caused by your proxy, although, that doesn't really make sense because all important dates and times should be in relation to GMT anyway.

As far as I know, Firefox's SSL cert-checking code hasn't changed appreciable since Firefox 33.0, and before that, Firefox 31.0, so I don't think a recent recent point update would have caused this, but to be fair, I haven't searched the bug database to see what might have been tweaked.

I think the certificate you're seeing is legitimate. You may be able to add an exception on that full-page exception dialog. Maybe Firefox is getting thrown off by the time zone difference caused by your proxy, although, that doesn't really make sense because all important dates and times should be in relation to GMT anyway. As far as I know, Firefox's SSL cert-checking code hasn't changed appreciable since Firefox 33.0, and before that, Firefox 31.0, so I don't think a recent recent point update would have caused this, but to be fair, I haven't searched the bug database to see what might have been tweaked.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked *https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware
Guy... 0 solutions 18 answers

I alse had this horrible annoying problem and I just managed to fix it.

I'm using Replay Media Catcher (it captures video/audio from the internet), and I found out that when the program is open everything is fine, so I searched google and found this: https://replaymediacatcher.zendesk.com/hc/en-us/articles/202520104-Why-did-I-lose-internet-connectivity-after-using-RMC5-

And so what fixed it for me was going to: Internet Options >> Connections >> LAN settings >> Unchecking the third option "Use a proxy server for your LAN" (here's a screenshot to help - http://oi59.tinypic.com/206hml0.jpg) And also disabling the option "Monitor HTTPS/SSL" in Replay Media Catcher.

I hope this helps :)

I alse had this horrible annoying problem and I just managed to fix it. I'm using Replay Media Catcher (it captures video/audio from the internet), and I found out that when the program is open everything is fine, so I searched google and found this: https://replaymediacatcher.zendesk.com/hc/en-us/articles/202520104-Why-did-I-lose-internet-connectivity-after-using-RMC5- And so what fixed it for me was going to: '''Internet Options >> Connections >> LAN settings >> Unchecking the third option "Use a proxy server for your LAN"''' (here's a screenshot to help - http://oi59.tinypic.com/206hml0.jpg) And also disabling the option "Monitor HTTPS/SSL" in Replay Media Catcher. I hope this helps :)