X
Tap here to go to the mobile version of the site.

Support Forum

firefox not in default programs

Posted

Firefox is not listed in the Windows Set Your Default Programs list.

Firefox is not listed in the Windows Set Your Default Programs list.

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 13.0 r0
  • 5.1.30514.0
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • BlackBerry WebSL Browser Plug-In
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 33.1.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.1.1/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • IDS_SS_NAME IDS_SS_VERSION ({D19CA586-DD6C-4a0a-96F8-14644F340D60}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2: NVIDIA Quadro K3000M
  • adapterDeviceID: 0x0166
  • adapterDeviceID2: 0x11be
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 9-26-2012
  • driverDate2: 1-24-2013
  • driverVersion: 9.17.10.2867
  • driverVersion2: 9.18.13.1110
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.frecency_experiment: 3
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141113143407
  • browser.startup.homepage_override.buildID: 20141113143407
  • browser.startup.homepage_override.mstone: 33.1.1
  • extensions.lastAppVersion: 33.1.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • media.gmp-gmpopenh264.lastUpdate: 1416600031
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1416600031
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Turn on Always Check Firefox Default Browser.

Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Turn on '''Always Check Firefox Default Browser.'''

Question owner

It didn't work. Perhaps need to reinstall.

It didn't work. Perhaps need to reinstall.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Open Windows Internet Explorer. Go thru the options and have it made the default program. But do not select to have it check if it is the default. Close IE. Open Firefox, and do the same. But have FF check for default.

Open Windows Internet Explorer. Go thru the options and have it made the default program. But do not select to have it check if it is the default. Close IE. Open Firefox, and do the same. But have FF check for default.