Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Keyboard doesn´t use the correct symbols

  • 2 replies
  • 2 have this problem
  • 39032 views
  • Last reply by JanePJ

more options

Using the shift key doesn´t produce the ´correct´ symbol. For example, SHIFT + 2 produces " rather than @. (To type this I had to type it out in word first, where the shift key does work normally, and copy and past in this Details box. From left to right on the keyboard, these are the symbols I get with the shift key

§"#$%&_()'?

As you can imagine this makes it very difficult and irritating to work in firefox. Hopefully you have a solution for this. Thanks, Jane

Chosen solution

It is possible that you have switched the keyboard layout by accident by using the key sequence to rotate the keyboard layout.

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

  • Make sure that you have the Language bar visible on the Windows Taskbar
  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application
  • The default key combination to rotate the layout is the Ctrl+Shift or Alt+Shift combination that is used in Firefox for menu items, so it is possible to change the layout accidentally.
  • To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift)
  • Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence
Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

It is possible that you have switched the keyboard layout by accident by using the key sequence to rotate the keyboard layout.

Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

  • Make sure that you have the Language bar visible on the Windows Taskbar
  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application
  • The default key combination to rotate the layout is the Ctrl+Shift or Alt+Shift combination that is used in Firefox for menu items, so it is possible to change the layout accidentally.
  • To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift)
  • Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence
more options

Thanks a lot, it's worked. I need to read over the lower part of your answer again to understand how to avoid this problem from recurring, but at least now I can work properly in firefox.