Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I get a "Secure Connection Failed" error with google stating "certificate contains the same serial number"

  • 7 replies
  • 14 have this problem
  • 18753 views
  • Last reply by schro_cat

more options

When I click on a link for a google search, I get the "Secure Connection Failed" error in Firefox. It states, "Please contact the server administrator or email correspondent and give them the following information: Your certificate contains the same serial number as another certificate issued by the certificate authority."

I have followed the instructions here: https://support.mozilla.org/en-US/kb/Certificate%20contains%20the%20same%20serial%20number%20as%20another%20certificate and looked at this article: https://support.mozilla.org/en-US/questions/1028103?esab=a&as=aaq

I have uninstalled and reinstalled Firefox, deleted the entire profiles folder, and reset Firefox. I see that the older (orphaned) article points to my router. However, I have a new router and have updated its software. There is no button to add an exception (as noted in the article), so I can't just bypass it. This problem does not occur with IE, so I have a hard time believing it is my router.

How do I troubleshoot this issue? I really don't want to change browsers.

Chosen solution

I finally tracked down the issue. The answer was found here: https://support.mozilla.org/en-US/questions/1028985

It turns out that Avast has a web shield that passes https through its own certificate check. This functionality obviously doesn't quite work right and loses track of the certificates. Disabling "https scanning" in Avast settings fixed the problem.

Read this answer in context 👍 4

All Replies (7)

more options

Here is a screen shot of the error.

more options

Do the browser.xul.error_pages.* prefs have the default value on the about:config page?

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

more options

cor-el, The browser.xul.error_pages.* have the default values. I am, and always have been, using the Default Theme. I had, as part of my troubleshooting, deleted the entire profile folder and reinstalled the program. So, unless this cert8.db file exists somewhere else, it was already deleted and recreated with a fresh install of FF.

I will try the safe-mode to see if that remedies the problem. I don't think I have any non-standard add-ons. I have not installed any since the fresh reinstall of Firefox. As part of the troubleshooting, I have either disabled or set those that do exist to 'Ask to activate.'

I will report back with the results from running in safe-mode.

more options

I opened FF in safe mode and had a different issue come up. Facebook only loaded as text, no images, no scripts. I don't know if this is a related issue, but it has also been intermittently happening.

I'm going to call it a night, but I'll work with safe mode tomorrow and see if there is any change.

more options

I did not see the connection error today while running in safe mode (though I did see the text-only Facebook issue). So, I came out of safe mode and followed the instructions on the 'Troubleshoot issues with plugins' page. I have all plugins set to 'Never Activate,' but I continue to get the connection error. Since I have all of the plugins disabled, and the problem persists, I'm not sure what to do next.

As I said before, I have already uninstalled and reinstalled FF, have deleted the entire profiles folder, and Reset Firefox from the troubleshooting dialogue.

Any ideas on what to try next?

more options

What does the certificate chain show when you check that in other browsers that work? Who is the issuer of the certificate and does it end with a built-in root certificate or with a special certificate provided by other (security) software.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.


In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder in profile folder)
  • default toolbar layout is used
  • JavaScript JIT compilers are disabled
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
more options

Chosen Solution

I finally tracked down the issue. The answer was found here: https://support.mozilla.org/en-US/questions/1028985

It turns out that Avast has a web shield that passes https through its own certificate check. This functionality obviously doesn't quite work right and loses track of the certificates. Disabling "https scanning" in Avast settings fixed the problem.