X
Tap here to go to the mobile version of the site.

Support Forum

waking laptop from sleep, ffx lost all icons, (bookmarks, navigation, stop/reload, download and extension icons.

Posted

windows 8.1 update one. laptop goes to sleep mode, upon starting the laptop up again, i lose all icons of firefox i.e. the forward/back navigation buttons(still there and clickable but now black arrow) download icon, and bookmark icons. all buttons still clickable but lost the black icon in them, all i see is ust white backround and have to try and guess which button is which from memory because even pointing mouse over the icon brings a white box which usually contains info on the button. problem fixed when close firefox and restart again but thats not a permanent solution as i lose tabs that were open.

any help appreciated.

windows 8.1 update one. laptop goes to sleep mode, upon starting the laptop up again, i lose all icons of firefox i.e. the forward/back navigation buttons(still there and clickable but now black arrow) download icon, and bookmark icons. all buttons still clickable but lost the black icon in them, all i see is ust white backround and have to try and guess which button is which from memory because even pointing mouse over the icon brings a white box which usually contains info on the button. problem fixed when close firefox and restart again but thats not a permanent solution as i lose tabs that were open. any help appreciated.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • The plugin allows you to have a better experience with Microsoft SharePoint

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Helpful Reply

If you're not using private browsing, the History menu should have the option to Restore Previous Session.

But regarding the main issue, I don't know whether anyone has posted about this before. Does it make any difference if you disable Firefox's use of hardware acceleration? This is a standard workaround for incompatible graphics card/chipset driver software. You can switch the setting here:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

That takes effect after you exit and start Firefox up again.

In the interim, if you see this again, could you try to force Firefox to repaint the window by minimizing and restoring the problem window. You can minimize a window "blind" by pressing Alt+Spacebar and then n (or you can minimize all windows by holding down the Window key and pressing d).

If you're not using private browsing, the History menu should have the option to Restore Previous Session. But regarding the main issue, I don't know whether anyone has posted about this before. Does it make any difference if you disable Firefox's use of hardware acceleration? This is a standard workaround for incompatible graphics card/chipset driver software. You can switch the setting here: "3-bar" menu button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" That takes effect after you exit and start Firefox up again. In the interim, if you see this again, could you try to force Firefox to repaint the window by minimizing and restoring the problem window. You can minimize a window "blind" by pressing Alt+Spacebar and then n (or you can minimize all windows by holding down the Window key and pressing d).
cor-el
  • Top 10 Contributor
  • Moderator
17680 solutions 159921 answers

Helpful Reply

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check if there is an update for your graphics display driver.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver. *https://support.mozilla.org/kb/how-do-i-upgrade-my-graphics-drivers

Question owner

i dont have any themes on firefox and i only have 2 extensions which are adblock plus and favicon reloader. i've tried disabling those and even tried a new installation of firefox and still get the same. however, disabling the hardware acceleration seems to be the problem, slightly rectifying the issue with the icons all back but the tabs area is black(see image).

my graphics card is up to date according to HP and DriverPack Solution.

thanks for your help and time, much appreciated.

i dont have any themes on firefox and i only have 2 extensions which are adblock plus and favicon reloader. i've tried disabling those and even tried a new installation of firefox and still get the same. however, disabling the hardware acceleration seems to be the problem, slightly rectifying the issue with the icons all back but the tabs area is black(see image). my graphics card is up to date according to HP and DriverPack Solution. thanks for your help and time, much appreciated.
cor-el
  • Top 10 Contributor
  • Moderator
17680 solutions 159921 answers

Is that a screenshot with hardware acceleration disabled?

You can try to set this pref to false on the about:config page.

  • layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

If that works then you can check if enabling hardware acceleration is possible.

Is that a screenshot with hardware acceleration disabled? You can try to set this pref to false on the <b>about:config</b> page. *layers.offmainthreadcomposition.enabled = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config If that works then you can check if enabling hardware acceleration is possible.