Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hello, Does anyonr know how to "PERMANTLY" disable that annoying caret browsing feature for good.....

  • 8 replies
  • 27 have this problem
  • 4820 views
  • Last reply by Heavyoak

more options

It's odd it only keeps popping up (caret browsing) when I use the Google search engine of which I like to use as my primary search enging and does not happen when I use other search engines such as Yahoo, Bing and so on. "I just want to disable it for good". I have tried everything I know, went into the about config page and changed the browsing features to false and it still do not disable it along with other steps to try to permanently disable it and it still comes back. I have Firefox version 33 with Windows 7. ANY help with this annoying feature would be appreciated, Thank you....

Chosen solution

Google's special handling of the down and up arrow keys -- they move a blue triangle from one result to the next -- is done in JavaScript you load from the site, and is not caused by Firefox's caret browsing feature.

Based on threads on Google's support forum:

  • The blue arrow appears when you are not logged in to a Google account (I didn't test logged in)

I an not aware of any other way to disable it other than to log in or turn off instant results. It's always possible someone created an add-on to do that.

Read this answer in context 👍 3

All Replies (8)

more options

Hello,

Can you check your settings in:

  • Tools (or New Fx Menu) > Options > Advanced > General

Disable Always use the cursor keys to navigate within pages if it is enabled. If that doesn't work, enter about:preferences in your address bar and try changing that same setting there as well.

more options

Hello Cory, They ( Always use the cursor keys to navigate within pages ) were already unchecked. I have tried sooooooooooo many ways of trying to disable caret browsing for good and that darn feature does not want to go away. I'm consider myself pretty good at fixing computer/program issuses , but this annoying feature has me stumped. Is this feature some how hard wired/embedded in Firefox so one cannot disable it for good? (They Mozzila should make this feature a add on if anyone wants it they can download it, it seems a lotttttttt more users dislike this feature then ones who like it). Any other suggestions you may have will be appreciated, Thank you..........

more options

hi david, have you already tried setting the accessibility.browsewithcaret_shortcut.enabled preference in about:config to false? in case this is not enough, you could also lock "accessibility.browsewithcaret" to false with the method described in http://kb.mozillazine.org/Locking_preferences

more options

Also, you can put accessibility.browsewithcaret_shortcut.enabled along with accessibility.browsewithcaret in a user.js file so those pref's will be set every time Firefox is launched (if it should change "all by itself" for some reason).

user_pref("accessibility.browsewithcaret_shortcut.enabled", false); 
user_pref("accessibility.browsewithcaret", false);

http://kb.mozillazine.org/User.js_file I use this extension - http://webdesigns.ms11.net/chromeditp.html - for working with the 3 "user" files in Firefox.

more options

Caret Out {web link} Disables change of the caret browse mode by shortcut key(F7).

more options

Chosen Solution

Google's special handling of the down and up arrow keys -- they move a blue triangle from one result to the next -- is done in JavaScript you load from the site, and is not caused by Firefox's caret browsing feature.

Based on threads on Google's support forum:

  • The blue arrow appears when you are not logged in to a Google account (I didn't test logged in)

I an not aware of any other way to disable it other than to log in or turn off instant results. It's always possible someone created an add-on to do that.

more options

Thanks jscher2000, that seems to have solved this annoying problem that only happened when using Google search engine, (checked mark "never show instant results") Now I'll have to look for an add-on (if any) to make sure it never creeps back up on me, Thank YOU again.....

more options

if you don't like the display of other search providers, you can disable all of them.

Type about:config in the browser's address bar and hit enter.

Confirm you will be careful if the prompt appears.

Search for browser.search.showOneOffButtons and set it to false.