X
Tap here to go to the mobile version of the site.

Support Forum

Can't enable JavaScript to run YouTube videos.

Posted

I read the information given on the site about enabling Java Script, but it does not work. Under my tools/options menu, the site's instructions say to click on Firefox. There is no title of Firefox in my options box. Going through the list of General, Tabs, Content, Applications, Privacy, Security, Sync and Advanced, there is nothing under any of them titled Preferences or any box that says to enable anything. How do I enable Javascript for Firefox 33?

Part of my living is reviewing YouTube videos- I can't play any without this. Please help me. Thank you

I read the information given on the site about enabling Java Script, but it does not work. Under my tools/options menu, the site's instructions say to click on Firefox. There is no title of Firefox in my options box. Going through the list of General, Tabs, Content, Applications, Privacy, Security, Sync and Advanced, there is nothing under any of them titled Preferences or any box that says to enable anything. How do I enable Javascript for Firefox 33? Part of my living is reviewing YouTube videos- I can't play any without this. Please help me. Thank you

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • VLC media player Web Plugin 2.1.3
  • Inquisit Mozilla Plugin 4.0.6.0
  • 5.1.30514.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0

More Information

jscher2000
  • Top 10 Contributor
8583 solutions 70196 answers

Helpful Reply

JavaScript is enabled by default, and if JavaScript is not enabled, lots of sites around the web will tell you that. If this problem is only on YouTube, then it could be a different issue, such as Flash not being activated on YouTube for some reason.

To check your JavaScript setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste javas and pause while the list is filtered

(3) If the javascript.enabled preference is bolded and "user set" to false, double-click it to switch it back to true.

JavaScript is enabled by default, and if JavaScript is not enabled, lots of sites around the web will tell you that. If this problem is only on YouTube, then it could be a different issue, such as Flash not being activated on YouTube for some reason. To check your JavaScript setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''javas''' and pause while the list is filtered (3) If the '''javascript.enabled''' preference is bolded and "user set" to false, double-click it to switch it back to true.
jscher2000
  • Top 10 Contributor
8583 solutions 70196 answers

If you have installed NoScript or any other extension to manage which sites are allowed to run JavaScript, become familiar with their features. For NoScript, for example, you should find a button with a blue S on a white circle. When scripts are fully or partially disabled on a page, there will be a red circle-slash symbol over the button. Use this button to allow scripts for the main site and its related resource sites.

If you have installed NoScript or any other extension to manage which sites are allowed to run JavaScript, become familiar with their features. For NoScript, for example, you should find a button with a blue S on a white circle. When scripts are fully or partially disabled on a page, there will be a red circle-slash symbol over the button. Use this button to allow scripts for the main site and its related resource sites.

Helpful Reply

Thank you. Javascript was enabled, and I have the latest Adobe flash player as instructed by YouTube. I'll post the same issue there- it's a safe bet that I'm not the only one experiencing a problem.

Thank you. Javascript was enabled, and I have the latest Adobe flash player as instructed by YouTube. I'll post the same issue there- it's a safe bet that I'm not the only one experiencing a problem.
jscher2000
  • Top 10 Contributor
8583 solutions 70196 answers

If you have a moment, could you copy/paste the error message you're getting, or post a screenshot of it? Perhaps that will jog a memory of someone here.

Also, if you use any video recorder/downloader add-ons, make sure they are as up-to-date as possible.

You also could test with extensions disabled in Firefox by using YouTube in Firefox's Safe Mode. (That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.)

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

If you have a moment, could you copy/paste the error message you're getting, or post a screenshot of it? Perhaps that will jog a memory of someone here. Also, if you use any video recorder/downloader add-ons, make sure they are as up-to-date as possible. You also could test with extensions disabled in Firefox by using YouTube in Firefox's Safe Mode. (That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]].) You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled Not all add-ons are disabled: Flash and other plugins still run After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Any difference?

Question owner

I have installed Noscript, uninstalled and reinstalled Firefox, ensured that everything that says javascript is enabled in about:config and still nothing. Youtube videos do not play. This was never a problem until I upgraded to Firefox 33. Is anyone working on a solution for this?

I have installed Noscript, uninstalled and reinstalled Firefox, ensured that everything that says javascript is enabled in about:config and still nothing. Youtube videos do not play. This was never a problem until I upgraded to Firefox 33. Is anyone working on a solution for this?
the-edmeister
  • Moderator
5391 solutions 40026 answers

NoScript is like the opposite of what you need! As installed it will disable JavaScript for all websites and you need to enable JavaScript domain-by-domain for each website that you visit.

That problem is yours, works fine for most users of Firefox 33 on YouTube.

NoScript is like the opposite of what you need! As installed it will disable JavaScript for all websites and you need to enable JavaScript domain-by-domain for each website that you visit. That problem is ''yours'', works fine for most users of Firefox 33 on YouTube.
jscher2000
  • Top 10 Contributor
8583 solutions 70196 answers

Allow me to ask this question again: what is the exact error message you are getting?

If you do not get any error messages, does the plugin notification ("Lego") button in the address bar shows that Flash is enabled and running on the page?

I suggested testing YouTube in Firefox's Safe Mode. What was the result of that test?

Allow me to ask this question again: ''what is the exact error message you are getting?'' If you do not get any error messages, does the plugin notification ("Lego") button in the address bar shows that Flash is enabled and running on the page? I suggested testing YouTube in Firefox's Safe Mode. ''What was the result of that test?''

Question owner

I get the message which shows on the YouTube viewing screen:

An error occurred, please try again later. learn more

I get the message which shows on the YouTube viewing screen: An error occurred, please try again later. learn more

Question owner

I restarted it in Safe Mode and received the same error message. I also tried installing Firefox 29, hoping an earlier version would not have the problem. I was wrong- it's still there. Same error message as above.

I restarted it in Safe Mode and received the same error message. I also tried installing Firefox 29, hoping an earlier version would not have the problem. I was wrong- it's still there. Same error message as above.
jscher2000
  • Top 10 Contributor
8583 solutions 70196 answers

Any difference in a private window (you can use Ctrl+Shift+p to launch a private window)?


I'm not sure anyone really knows what causes the "An error occurred, please try again later." error after ruling out issue such as cookie and content blocks. Some suggested workarounds I've seen include:

(1) Switch players

YouTube offers an HTML5 preference to minimize use of the Flash player. However, it may not be as full featured as Flash and some videos are not transcoded to HTML5-player-compatible formats. See this article for more information on this option: http://www.ghacks.net/2014/06/13/fix-error-occurred-please-try-later-youtube-error/

(2) Change connection settings

Some users have had success switching their DNS servers to OpenDNS to bypass problems in parts of Google's infrastructure. You also could try Google's Public DNS servers. See this forum thread for more information on this option: https://productforums.google.com/d/msg/youtube/q8kuI162ryw/YkQfop3CP1wJ

OpenDNS: https://use.opendns.com/

Google Public DNS: https://developers.google.com/speed/public-dns/docs/using

Any difference in a private window (you can use Ctrl+Shift+p to launch a private window)? ---- I'm not sure anyone really knows what causes the "An error occurred, please try again later." error after ruling out issue such as cookie and content blocks. Some suggested workarounds I've seen include: (1) Switch players YouTube offers an HTML5 preference to minimize use of the Flash player. However, it may not be as full featured as Flash and some videos are not transcoded to HTML5-player-compatible formats. See this article for more information on this option: http://www.ghacks.net/2014/06/13/fix-error-occurred-please-try-later-youtube-error/ (2) Change connection settings Some users have had success switching their DNS servers to OpenDNS to bypass problems in parts of Google's infrastructure. You also could try Google's Public DNS servers. See this forum thread for more information on this option: https://productforums.google.com/d/msg/youtube/q8kuI162ryw/YkQfop3CP1wJ OpenDNS: https://use.opendns.com/ Google Public DNS: https://developers.google.com/speed/public-dns/docs/using

Question owner

I'll give these a try and let you know. I truly appreciate your help.

I'll give these a try and let you know. I truly appreciate your help.

Question owner

The first one didn't work, so I'm gonna try the second one tomorrow.

The first one didn't work, so I'm gonna try the second one tomorrow.
jazbutis 1 solutions 8 answers

I am being informed by a number of sites/pages (including FireFox Synch) that JavaScript is not enabled. This is running vanilla (untouched after install) FireFox 33.0.1 (newly upgraded from 33.0.0) on an ASUS tablet running Windows 8.1. All of the sites/pages in question run just fine on other windows machines in FireFox. When I try to go to <about:enabled> in the address bar, FireFox throws an "invalid address" error.

I am being informed by a number of sites/pages (including FireFox Synch) that JavaScript is not enabled. This is running vanilla (untouched after install) FireFox 33.0.1 (newly upgraded from 33.0.0) on an ASUS tablet running Windows 8.1. All of the sites/pages in question run just fine on other windows machines in FireFox. When I try to go to <about:enabled> in the address bar, FireFox throws an "invalid address" error.

Modified by jazbutis

jscher2000
  • Top 10 Contributor
8583 solutions 70196 answers

Hi jazbutis, I posted my comments in your separate question here: https://support.mozilla.org/questions/1027761

To avoid confusion, let's continue with your issue over there.

Hi jazbutis, I posted my comments in your separate question here: https://support.mozilla.org/questions/1027761 To avoid confusion, let's continue with your issue over there.
cor-el
  • Top 10 Contributor
  • Moderator
17346 solutions 156811 answers

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then also create a new profile.


Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the full Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then also create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall