Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps blocking my webpage from changing to a new page - I don't want it to do this. How to I stock the blocks?

  • 7 replies
  • 2 have this problem
  • 726 views
  • Last reply by ideato

more options

When working in several different programs (Auctiva is one) I get a message that Firefox blocked my webpages attempt to direct me to a new page. Sometimes I can click allow, but sometimes the message is gone so fast i have No Option. In most cases this page switch is necessary for what I am doing to happen - in Auctivia my listing won't post to eBay for hours if it can't switch pages. How can I stop Firefox for blocking these page switches. It is happening more and more. I have adjusted everything I can think of in settings, but nothing helps.

Karen

Chosen solution

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
  3. copy (from here) the accessibility.blockautorefresh and paste it in the search field
  4. now you have the preference and the value, if it is false it is OK, otherwise double-click on it to make it false
  5. exit the about:config page, exit firefox and restart it.

do the same with network.http.prompt-temp-redirect , note we want true as a value in that one.


thanks

Read this answer in context 👍 1

All Replies (7)

more options

Hello klraver, do you have the Web Developer extension ?

thank you

more options

No I do not have the Web Developer Extension.

Karen

more options

Can you check the next preferences in about:config

  • network.http.prompt-temp-redirect must be true
  • accessibility.blockautorefresh must be false

thanks

Modified by ideato

more options

I'm sorry I've never done that before - just tell me how to reach about:config!

Karen

more options

Chosen Solution

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
  3. copy (from here) the accessibility.blockautorefresh and paste it in the search field
  4. now you have the preference and the value, if it is false it is OK, otherwise double-click on it to make it false
  5. exit the about:config page, exit firefox and restart it.

do the same with network.http.prompt-temp-redirect , note we want true as a value in that one.


thanks

more options

Thank you, Thank you! You were very kind to take to time and effort to walk me through the parts I did not know. I take every change I get to learn something new and I really appreciate you kindness and your help.

Karen

more options

You are welcome Karen