X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

What happened to the search engine drop down menu

Posted

Hello, I am using Firefox 32.0.3. There used to be a drop down search engine menu on Firefox. Has it been removed from the latest version or is there some settings adjustment I can make to get it back? Thanks for any feedback.

Hello, I am using Firefox 32.0.3. There used to be a drop down search engine menu on Firefox. Has it been removed from the latest version or is there some settings adjustment I can make to get it back? Thanks for any feedback.

Chosen solution

thank you. i got the search bar with drop down menu back.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Version 5.38.4.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Shockwave Flash 15.0 r0
  • Next Generation Java Plug-in 10.65.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.30514.0
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 32.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
  • Support URL: https://support.mozilla.org/1/firefox/32.0.3/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Advertising Cookie Opt-out 1.5 (optout@google.com)
  • Flagfox 5.0.8 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • HTTPS-Everywhere 4.0.1 (https-everywhere@eff.org)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • MAFIAAFire Redirector 0.9d (MafiaaFire@mafiaafire.com)
  • MAFIAAFIRE: Gee! No evil! 1.0.0.0 (CustomGoogle@mafiaafire.com)
  • Personas Plus 1.7.3 (personas@christopher.beard)
  • Skype Click to Call 7.3.16540.9015 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Lightbeam 1.0.10.2 (jid1-F9UJ2thwoAm5gQ@jetpack) (Inactive)
  • Xmarks 4.3.3 (foxmarks@kei.com) (Inactive)
  • XULRunner 1.9.1 ({5165B45E-5439-4C90-A807-BBC886C38347}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 3300 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9614
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 384
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: B ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 4-19-2011
  • driverDate2:
  • driverVersion: 8.850.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 3300 Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 1
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 180
  • browser.places.smartBookmarksVersion: 7
  • browser.search.suggest.enabled: False
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140923175406
  • browser.startup.homepage: https://ixquick.com/do/search|https://ixquick.com/do/search|https://addons.mozilla.org/en-US/firefox/addon/searchreset/|https://ixquick.com/do/search|https://www.ixquick.com/
  • browser.startup.homepage_override.buildID: 20140923175406
  • browser.startup.homepage_override.mstone: 32.0.3
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.checkCompatibility.3.6: True
  • extensions.lastAppVersion: 32.0.3
  • font.internaluseonly.changed: False
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.cookieBehavior: 3
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1413151253
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1298314124
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1411943213

Misc

  • User JS: Yes
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

The search bar works the same as always: click the icon on the left end to drop down the list of search engines.

On the built-in home page (about:home) and the built-in new tab page (about:newtab) there is a glitch in that if you switch from Google to another search engine plugin that hasn't encoded its icon in a particular way, the list becomes inaccessible because there's nothing to click. Or at least I haven't found a way.

So the search bar still is the best place to make a switch. If yours is not displaying, it might have "overflowed" off the main toolbar (look for a large >> button) or it could be among the unused controls in the Customize dialog -- in which case you can add it back to your toolbar.

Some articles that might help:

Success?


I don't see "Default Tab" on your extensions list, but that and some other add-ons may substitute their own search box for Firefox's search bar. If you suspect such foul play, you could test in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

The search bar works the same as always: click the icon on the left end to drop down the list of search engines. On the built-in home page (about:home) and the built-in new tab page (about:newtab) there is a glitch in that if you switch from Google to another search engine plugin that hasn't encoded its icon in a particular way, the list becomes inaccessible because there's nothing to click. Or at least I haven't found a way. So the search bar still is the best place to make a switch. If yours is not displaying, it might have "overflowed" off the main toolbar (look for a large >> button) or it could be among the unused controls in the Customize dialog -- in which case you can add it back to your toolbar. Some articles that might help: * [[Search bar - add, change and manage search engines on Firefox]] * [[Customize Firefox controls, buttons and toolbars]] Success? ---- I don't see "Default Tab" on your extensions list, but that and some other add-ons may substitute their own search box for Firefox's search bar. If you suspect such foul play, you could test in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled Not all add-ons are disabled: Flash and other plugins still run After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (''not'' Reset). Any difference?
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Thank you for posting your detailed configuration information. It shows that your have a user.js file, which is an optional settings file that you or a system administrator or third party software can use to override your saved Firefox settings. This article describes how to locate and inspect or delete that file in that that is what is overriding your preferred search engine: How to fix preferences that won't save.

Thank you for posting your detailed configuration information. It shows that your have a user.js file, which is an optional settings file that you or a system administrator or third party software can use to override your saved Firefox settings. This article describes how to locate and inspect or delete that file in that that is what is overriding your preferred search engine: [[How to fix preferences that won't save]].
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Note that your System Details list shows that you have preferences that were used in previous Firefox versions and that are no longer supported in the current Firefox release, so it might be a good time to also delete the prefs.js file to reset all prefs.

Note that your System Details list shows that you have preferences that were used in previous Firefox versions and that are no longer supported in the current Firefox release, so it might be a good time to also delete the prefs.js file to reset all prefs.

Question owner

what are the steps to do this? thank you.

what are the steps to do this? thank you.

Chosen Solution

thank you. i got the search bar with drop down menu back.

thank you. i got the search bar with drop down menu back.
brianvt 0 solutions 7 answers

Helpful Reply

I don't understand what this 'solution' is telling me to do. The 'search settings' window looks the same as it always has, but the latest Firefox download only gives me one choice of search engine, i.e. what I've chosen as the default. I've tried a couple of different defaults, and neither Google nor DuckDuckGo gives me the drop-down. Do I have to go through this annoying rigamarole every time I want to use a different search engine, which I need to do quite often? Do I have to set Yahoo as the default? That didn't work either, but would be about as useful as going back to Alta Vista. C'mon folks, this is seriously annoying.

I don't understand what this 'solution' is telling me to do. The 'search settings' window looks the same as it always has, but the latest Firefox download only gives me one choice of search engine, i.e. what I've chosen as the default. I've tried a couple of different defaults, and neither Google nor DuckDuckGo gives me the drop-down. Do I have to go through this annoying rigamarole every time I want to use a different search engine, which I need to do quite often? Do I have to set Yahoo as the default? That didn't work either, but would be about as useful as going back to Alta Vista. C'mon folks, this is seriously annoying.
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

Note that this thread is about Firefox 32.

In the current Firefox 34 release there is a new "one-off" search bar. You can type one letter to make a drop-down list appear where you can see suggestions and also a row at the bottom where you can select other search engines that are enabled.

Click the search engine icon and click "Change Search Settings" to open the Search tab in Options/Preferences (positioned between Tabs and Content) to select the default search engine and select which search engines to show in the search bar drop-down list.

See also:

Note that this thread is about Firefox 32. In the current Firefox 34 release there is a new "one-off" search bar. You can type one letter to make a drop-down list appear where you can see suggestions and also a row at the bottom where you can select other search engines that are enabled. Click the search engine icon and click "Change Search Settings" to open the Search tab in Options/Preferences (positioned between Tabs and Content) to select the default search engine and select which search engines to show in the search bar drop-down list. See also: *https://support.mozilla.org/kb/Search+bar
brianvt 0 solutions 7 answers

OK, this works. Thanks. How do I change the sequence of search engine icons that show up? Some icons are more intuitive than others.

OK, this works. Thanks. How do I change the sequence of search engine icons that show up? Some icons are more intuitive than others.
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

You can change the order via the previously used "Manage Search Engines" window that you can open via this chrome URI via the location bar (or bookmark).

  • chrome://browser/content/search/engineManager.xul

This order is stored in the search-metadata.json file in the profile folder.

  • browser.search.useDBForOrder = true
You can change the order via the previously used "Manage Search Engines" window that you can open via this chrome URI via the location bar (or bookmark). *chrome://browser/content/search/engineManager.xul This order is stored in the search-metadata.json file in the profile folder. *browser.search.useDBForOrder = true
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Hi brianvt, the order should be the same as it was before the update.

At some point, you will be able to change the order in the Options dialog on the Search panel. However, that feature wasn't ready in time for Firefox 34.0.5. Hopefully in Firefox 35.0.

Search engine sequence is stored in a settings file named search-metadata.json in your currently active profile folder. These JSON-format data files are difficult to edit because they are in a very compact format meant to be read by computers and not humans. However, if you squint at it very hard, or search it in a text editor, you will see for each different search plugin:

"order":

followed by a number. If changing the sequence is really critical, you could try editing this file (with Firefox closed), but it's probably a good idea to create a backup in case something goes terribly wrong. see the tool listed in cor-el's post above: https://support.mozilla.org/questions/1025088#answer-662668.

Hi brianvt, the order should be the same as it was before the update. At some point, you will be able to change the order in the Options dialog on the Search panel. However, that feature wasn't ready in time for Firefox 34.0.5. Hopefully in Firefox 35.0. Search engine sequence is stored in a settings file named search-metadata.json in your currently active profile folder. These JSON-format data files are difficult to edit because they are in a very compact format meant to be read by computers and not humans. However, if you squint at it very hard, or search it in a text editor, you will see for each different search plugin: "order": followed by a number. If changing the sequence is really critical, <s>you could try editing this file (with Firefox closed), but it's probably a good idea to create a backup in case something goes terribly wrong.</s> <u>see the tool listed in cor-el's post above: [https://support.mozilla.org/questions/1025088#answer-662668].</u>

Modified by jscher2000

brianvt 0 solutions 7 answers

I'll wait for the next version. This isn't crucial.

Though I will say, having used the new feature a few times now, that the old way was much more logical, i.e. choosing which browser to use before starting to type in a search.

I'll wait for the next version. This isn't crucial. Though I will say, having used the new feature a few times now, that the old way was much more logical, i.e. choosing which browser to use before starting to type in a search.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Helpful Reply

Hi brianvt, if you find the new design less productive, it is possible to switch back to the old search bar. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste search and pause while the list is filtered

(3) Double-click the browser.search.showOneOffButtons preference to switch it from true to false

This doesn't affect the current window, but each new window you open (Ctrl+n) will have the old Search bar.

Hi brianvt, if you find the new design less productive, it is possible to switch back to the old search bar. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box that appears above the list, type or paste '''search''' and pause while the list is filtered (3) Double-click the '''browser.search.showOneOffButtons''' preference to switch it from true to false This doesn't affect the current window, but each new window you open (Ctrl+n) will have the old Search bar.
thetechlady 2 solutions 18 answers

jscheer2000,

This issue is NOT solved. We know how to use the drop-down menu in the search bar. We would use it if it were there. In Firefox 34.0.5 the little arrow pointing down no longer is there. When I pass my cursor over the magnifying glass, I get "Change search settings." Nothing drops down. I don't want to change my search settings. I simply would like to use a different search occasionally. Why don't we have a choice anymore?

jscheer2000, This issue is NOT solved. We know how to use the drop-down menu in the search bar. We would use it if it were there. In Firefox 34.0.5 the little arrow pointing down no longer is there. When I pass my cursor over the magnifying glass, I get "Change search settings." Nothing drops down. I don't want to change my search settings. I simply would like to use a different search occasionally. Why don't we have a choice anymore?
thetechlady 2 solutions 18 answers

I don't like this. Now in 34.0.5, if I want to use a different search engine, I have to click on three different things rather than just one click on the drop-down menu. BRING BACK THE DROP DOWN MENU! This feels like Mozilla is trying to force us to use its search engine by making it more difficult to use another. I may have to change my default search away from Duckduckgo, if this continues. I can't stand it when an organization tries to force us to use their products. It's bad enough that I have to put up with that crap from Microsoft and Google. I didn't expect it from Mozilla.

I don't like this. Now in 34.0.5, if I want to use a different search engine, I have to click on three different things rather than just one click on the drop-down menu. BRING BACK THE DROP DOWN MENU! This feels like Mozilla is trying to force us to use its search engine by making it more difficult to use another. I may have to change my default search away from Duckduckgo, if this continues. I can't stand it when an organization tries to force us to use their products. It's bad enough that I have to put up with that crap from Microsoft and Google. I didn't expect it from Mozilla.
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40224 answers

Locking this thread which was for Firefox 32.0.3 as the "problems" with Firefox 34 are quite different. Please ask a new question for help with your problem.

https://support.mozilla.org/en-US/questions/new

''Locking this thread which was for Firefox 32.0.3 as the "problems" with Firefox 34 are quite different. Please ask a new question for help with your problem.'' https://support.mozilla.org/en-US/questions/new