Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I fix this error message, The address wasn't understood Firefox doesn't know how to open this address, because one of the following protocols (connectag

  • 4 replies
  • 18 have this problem
  • 37713 views
  • Last reply by grranchgirl

more options

We have a new computer and I cannot get my garmin running watch to sync with mozilla. The error message that I keep getting is"The address wasn't understood

Firefox doesn't know how to open this address, because one of the following protocols (connectagent) isn't associated with any program or is not allowed in this context.

   You might need to install other software to open this address." 

Help please

Chosen solution

Hi grranchgirl, so you have one set to "Always Activate" and one set to "Never Activate"?

I'm not sure whether the terms "modern" and "classic" mean anything to you, but there is a thread on Garmin's forums that might be useful -- it's very long and I didn't read all of it.

https://forums.garmin.com/showthread.php?79956-Modern-Garmin-Connect-mostly-doesn-t-work-in-both-Firefox-and-Chrome&p=330634#post330634

Read this answer in context 👍 2

All Replies (4)

more options

This is for a special URL that starts with

connectagent:// 

instead of with

http://

is that right?

Two thoughts:

(1) Could you try changing a setting for your Garmin plugin. Here's what I mean:

Open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins.

Find your Garmin plugin change "Ask to Activate" to "Always Activate".

Your system information seems to list two different versions of a similarly named plugin. I'm not sure whether that is causing a problem.

(2) Does Garmin's documentation specify any extra steps to set up Firefox, other than installing its add-ons?

more options

I had two plug ins the same, I disabled one of them. Still have the same problem and I can't find any other info. More help please :(

more options

Chosen Solution

Hi grranchgirl, so you have one set to "Always Activate" and one set to "Never Activate"?

I'm not sure whether the terms "modern" and "classic" mean anything to you, but there is a thread on Garmin's forums that might be useful -- it's very long and I didn't read all of it.

https://forums.garmin.com/showthread.php?79956-Modern-Garmin-Connect-mostly-doesn-t-work-in-both-Firefox-and-Chrome&p=330634#post330634

more options

Thanks so much for your help, I don't know what I will do when they stop using classic but maybe they will have that all sorted by then :)