X
Tap here to go to the mobile version of the site.

Support Forum

After upgrading to the newest version of firefox Juniper J-Web management doesnot show the pages correct

Posted

The Juniper J-web management (java?!) page is not viewed right. With Firefox in fullscreen mode, You will see a purple line in top; in windowed mode the graphics looks resized with a small symbol in the lower right corner. But you can't resize.

The Juniper J-web management (java?!) page is not viewed right. With Firefox in fullscreen mode, You will see a purple line in top; in windowed mode the graphics looks resized with a small symbol in the lower right corner. But you can't resize.

Chosen solution

Hi sander.terhorst, and thank you FredMcD for the tag! This is in response to the Helpdesk tag where we can get some Mozilla eyes on this. So far I understand that after the recent update, the Juniper J-web management page is not showing correctly when Firefox is in full screen as well as when all of the add ons are disabled, nothing shows. But if you try to resize the web page, some of the html will show like here

Some troubleshooting thoughts: Have you reported to the developer of this interface as well? Does this happen in other browsers?

Are the css rules for the site using the align webkit? Please note to the developer that the rule was removed: https://developer.mozilla.org/en-US/F.../31

Does the html page start with: []?

Does the css on that page use: vertical-align: top; ?

Does this site use flash? Please make sure that this is up to date to version 15.

Most of these questions are along the lines of site compatibility. It seems as if we have done all the troubleshooting we can for the current Firefox, however if it does not appear this way in other browsers, it is most likely a web compatibility issue. webcompat.com is a great place to help get issues like this solved.

However in the meantime, please update your plugins, and try a new profile to make sure its not a corrupt profile, this will help investigate this further.

Thank you!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.30514.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Citrix Offline Plug-in Mozilla Plug-in (Win32)
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

FredMcD
  • Top 10 Contributor
4230 solutions 59026 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences in the address bar and press enter.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences in the address bar and press enter

Select Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences''' in the address bar and press enter. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences''' in the address bar and press enter Select '''Advanced > General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

See enclosed images; when you resize the firefox window, you get some clipping of the webinterface but never the complete picture. Any suggestions? Thanks.

See enclosed images; when you resize the firefox window, you get some clipping of the webinterface but never the complete picture. Any suggestions? Thanks.
FredMcD
  • Top 10 Contributor
4230 solutions 59026 answers

Have you tried the above?

How about using full screen (as a test) ?

Can you post a link to a public page?

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Open the Add-ons Manager <Control><Shift> A and disable All of them.

Have you tried the above? How about using full screen (as a test) ? Can you post a link to a public page? Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Open the '''Add-ons Manager <Control><Shift> A''' and '''disable All of them.'''

Question owner

Hi, Yes I tried all of the above. A full screen apparently doesn't show anything, but I can see a 2 pixel line in top of the screen (see enclosed screenshot with ispector screen enabled). I ve disabled all add-ons and virusscan, same result.

Best regards

Hi, Yes I tried all of the above. A full screen apparently doesn't show anything, but I can see a 2 pixel line in top of the screen (see enclosed screenshot with ispector screen enabled). I ve disabled all add-ons and virusscan, same result. Best regards
FredMcD
  • Top 10 Contributor
4230 solutions 59026 answers

In the image you posted, I noticed that the corner is darkened. Have you tried moving it with the mouse?

I have called for help on your problem.

In the image you posted, I noticed that the corner is darkened. Have you tried moving it with the mouse? I have called for help on your problem.

Question owner

Yes, without any luck (the mouse pointer doesn't change).

Yes, without any luck (the mouse pointer doesn't change).
guigs 1072 solutions 11697 answers

Chosen Solution

Hi sander.terhorst, and thank you FredMcD for the tag! This is in response to the Helpdesk tag where we can get some Mozilla eyes on this. So far I understand that after the recent update, the Juniper J-web management page is not showing correctly when Firefox is in full screen as well as when all of the add ons are disabled, nothing shows. But if you try to resize the web page, some of the html will show like here

Some troubleshooting thoughts: Have you reported to the developer of this interface as well? Does this happen in other browsers?

Are the css rules for the site using the align webkit? Please note to the developer that the rule was removed: https://developer.mozilla.org/en-US/F.../31

Does the html page start with: []?

Does the css on that page use: vertical-align: top; ?

Does this site use flash? Please make sure that this is up to date to version 15.

Most of these questions are along the lines of site compatibility. It seems as if we have done all the troubleshooting we can for the current Firefox, however if it does not appear this way in other browsers, it is most likely a web compatibility issue. webcompat.com is a great place to help get issues like this solved.

However in the meantime, please update your plugins, and try a new profile to make sure its not a corrupt profile, this will help investigate this further.

Thank you!

Hi sander.terhorst, and thank you FredMcD for the tag! This is in response to the Helpdesk tag where we can get some Mozilla eyes on this. So far I understand that after the recent update, the Juniper J-web management page is not showing correctly when Firefox is in full screen as well as when all of the add ons are disabled, nothing shows. But if you try to resize the web page, some of the html will show [https://support.mozilla.org/en-US/questions/1019096#answer-626770 like here] Some troubleshooting thoughts: Have you reported to the developer of this interface as well? Does this happen in other browsers? Are the css rules for the site using the align webkit? Please note to the developer that the rule was removed: [https://developer.mozilla.org/en-US/Firefox/Releases/31] Does the html page start with: [<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">]? Does the css on that page use: vertical-align: top; ? Does this site use flash? Please make sure that this is up to date to version 15. Most of these questions are along the lines of site compatibility. It seems as if we have done all the troubleshooting we can for the current Firefox, however if it does not appear this way in other browsers, it is most likely a web compatibility issue. webcompat.com is a great place to help get issues like this solved. However in the meantime, please update your plugins, and try a new profile to make sure its not a corrupt profile, this will help investigate this further. Thank you!

Question owner

I think all answers are 'no' (html/css/flash). Youre are right about reporting to the developer of the software: Juniper. They built great switches so they must be able to create a webinterfaces up to the standards :-) I created a case at Juniper.

I installed Opera which works fine (lot's of other issues with IE). Thanks for your post and I will keep you advised.

I think all answers are 'no' (html/css/flash). Youre are right about reporting to the developer of the software: Juniper. They built great switches so they must be able to create a webinterfaces up to the standards :-) I created a case at Juniper. I installed Opera which works fine (lot's of other issues with IE). Thanks for your post and I will keep you advised.

Helpful Reply

Response from Juniper Support:

"According to the case notes, I understand that the J-web is not working on the latest Firefox version.31. This is a know issue with the latest firefox code and we have an internal PR for this issue.

PR number: 1019929

PR description: issue after migration to Firefox V.31 and V.32Beta According to the PR notes, currently supported versions are only IE7 and FF 3.x. However the latest browsers are getting supported up to FF30, IE9&10 in the upcoming EX Junos releases."

Apparently we have to wait for the new Juniper firmware.

Response from Juniper Support: "According to the case notes, I understand that the J-web is not working on the latest Firefox version.31. This is a know issue with the latest firefox code and we have an internal PR for this issue. PR number: 1019929 PR description: issue after migration to Firefox V.31 and V.32Beta According to the PR notes, currently supported versions are only IE7 and FF 3.x. However the latest browsers are getting supported up to FF30, IE9&10 in the upcoming EX Junos releases." Apparently we have to wait for the new Juniper firmware.
guigs 1072 solutions 11697 answers

HI sander.terhorst, Thank you very much for reporting back to the thread! Keeping it open and helping other users :-)

HI sander.terhorst, Thank you very much for reporting back to the thread! Keeping it open and helping other users :-)