X
Tap here to go to the mobile version of the site.

Support Forum

Firefox will not remember to use Reader for PDF downloads

Posted

When using Gmail, I have an email with PDF attachments. For each PDF attachment, there are 3 options: Use the built-in reader, download, or copy to Google Drive. When I select download, the popup says "You have chosen to open:..." and then offers two selections: "Open with" and "Save File". Previously, the "Open with" option would remember that I wanted to use Reader with PDF file. It will no longer does that. I have to browse and find Reader each time, even though I've clicked "Do this automatically". Each time I do browse to Reader, it will use it. It simply won't remember to use Reader the next time. Under Options-Application, it does say that for PDF files, it should "Use Adobe Reader". I have reinstalled Firefox, along with making sure the profile folders in my application data were deleted, so this is a clean version.

When using Gmail, I have an email with PDF attachments. For each PDF attachment, there are 3 options: Use the built-in reader, download, or copy to Google Drive. When I select download, the popup says "You have chosen to open:..." and then offers two selections: "Open with" and "Save File". Previously, the "Open with" option would remember that I wanted to use Reader with PDF file. It will no longer does that. I have to browse and find Reader each time, even though I've clicked "Do this automatically". Each time I do browse to Reader, it will use it. It simply won't remember to use Reader the next time. Under Options-Application, it does say that for PDF files, it should "Use Adobe Reader". I have reinstalled Firefox, along with making sure the profile folders in my application data were deleted, so this is a clean version.

Chosen solution

Testing with one message, it appears that Google is sending a good content-type header ("application/pdf"). The attached screen shot shows the "Response Headers" in the web console.

Sometimes the settings file that stores your downloading handling preferences becomes corrupted with duplicate or conflicting information. Because its internal format is inscrutable, it generally is easiest to remove the file and have Firefox rebuild it. You will need to update your PDF preference again, but hopefully it will work again.

Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Start Firefox back up again, revisit Options/Applications and select your PDF preference, then test Gmail again. Any improvement?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Shockwave Flash 14.0 r0
  • 5.1.30514.0

Application

  • Firefox 32.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
  • Support URL: https://support.mozilla.org/1/firefox/32.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Norton Toolbar 2014.7.7.13 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6739
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'ATI Catalyst 14.6+']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 4-17-2014
  • driverDate2:
  • driverVersion: 14.100.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6800 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.frecency_experiment: 3
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140825202822
  • browser.startup.homepage_override.buildID: 20140825202822
  • browser.startup.homepage_override.mstone: 32.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 32.0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the file. Then rename or delete it. Restart Firefox.

Deleting the '''mimeTypes.rdf''' will reset all download actions to the default settings. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the file. Then rename or delete it. Restart Firefox.

Helpful Reply

No joy. I delete the file. Close Firefox and restart it. I go into the config-applications and I confirm the PDF association is not there. I open the email and click download. As expected, it doesn't know what app to use, so I browse to Reader and select it and tell it to do this automatically. Reader is opened. I pick the next PDF file for download, and when the popup comes up, it does not recall the Reader association. I go into config-applications, and it SAYS Reader is associated with PDF files. It just kind of ignores it.

No joy. I delete the file. Close Firefox and restart it. I go into the config-applications and I confirm the PDF association is not there. I open the email and click download. As expected, it doesn't know what app to use, so I browse to Reader and select it and tell it to do this automatically. Reader is opened. I pick the next PDF file for download, and when the popup comes up, it does not recall the Reader association. I go into config-applications, and it SAYS Reader is associated with PDF files. It just kind of ignores it.
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

See if this helps;

InlineDisposition 2 {web link} InlineDisposition 2 changes the disposition of Content-Disposition response headers from attachment to inline.

See if this helps; '''[https://addons.mozilla.org/en-US/firefox/addon/inlinedisposition-2/ InlineDisposition 2]''' {web link} InlineDisposition 2 changes the disposition of Content-Disposition response headers from attachment to inline.
jscher2000
  • Top 10 Contributor
8775 solutions 71736 answers

Chosen Solution

Testing with one message, it appears that Google is sending a good content-type header ("application/pdf"). The attached screen shot shows the "Response Headers" in the web console.

Sometimes the settings file that stores your downloading handling preferences becomes corrupted with duplicate or conflicting information. Because its internal format is inscrutable, it generally is easiest to remove the file and have Firefox rebuild it. You will need to update your PDF preference again, but hopefully it will work again.

Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Start Firefox back up again, revisit Options/Applications and select your PDF preference, then test Gmail again. Any improvement?

Testing with one message, it appears that Google is sending a good content-type header ("application/pdf"). The attached screen shot shows the "Response Headers" in the web console. Sometimes the settings file that stores your downloading handling preferences becomes corrupted with duplicate or conflicting information. Because its internal format is inscrutable, it generally is easiest to remove the file and have Firefox rebuild it. You will need to update your PDF preference again, but hopefully it will work again. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * Help menu > Troubleshooting Information In the first table on the page, click the "Show Folder" button Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * File menu > Exit Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old Start Firefox back up again, revisit Options/Applications and select your PDF preference, then test Gmail again. Any improvement?

Modified by jscher2000

Question owner

FredMcdD - Your second solution does not address my problem. I do not want to read the file within the browser. I want to download and when the download options window pops up, have the "Open with" option prepopulated with "Reader" already selected. jscher2000 - It seems like your solution is like FredMcD's first suggestion, which is to rebuild the mimeTypes.rdf. It did not work the second time either. From the attached screenshots, you can see the config setup (after the rebuild and after updating the PDF action) says Reader is to be used, but the download popup doesn't use it.

FredMcdD - Your second solution does not address my problem. I do not want to read the file within the browser. I want to download and when the download options window pops up, have the "Open with" option prepopulated with "Reader" already selected. jscher2000 - It seems like your solution is like FredMcD's first suggestion, which is to rebuild the mimeTypes.rdf. It did not work the second time either. From the attached screenshots, you can see the config setup (after the rebuild and after updating the PDF action) says Reader is to be used, but the download popup doesn't use it.

Helpful Reply

Oh boy....turns out it is OK, it's just not obvious.

Even though the download pop-up lists no application next to "Open with" (which I'm pretty sure it used to), it WILL use Reader when I click the OK button.

Another odd thing: When the popup window is not active, as if when I'm using the Snipping Tool to get a snapshot, the OK button is grayed out (that sure doesn't help when trying to get help from you guys), but when it is active, it is not grayed out and is the default button.

Oh boy....turns out it is OK, it's just not obvious. Even though the download pop-up lists no application next to "Open with" (which I'm pretty sure it used to), it WILL use Reader when I click the OK button. Another odd thing: When the popup window is not active, as if when I'm using the Snipping Tool to get a snapshot, the OK button is grayed out (that sure doesn't help when trying to get help from you guys), but when it is active, it is not grayed out and is the default button.
jscher2000
  • Top 10 Contributor
8775 solutions 71736 answers

Hi rickshein, with your setting, you should not get the Open/Save/Cancel dialog; the document should launch in Adobe Reader automatically. I noticed your dialog is a bit different than mine: yours refers to "PDF file" while mine refers to "Adobe Acrobat Document". (screenshot attached)

For some reason, your Firefox is not properly matching up the download with the application/pdf file type. Is this problem specific to Gmail or to HTTPS sites, or does it occur for other PDF downloads as well? For example:

http://www.jeffersonscher.com/gm/Google-Hit-Hider-by-Domain_About_v160.pdf

https://www.jeffersonscher.com/gm/Google-Hit-Hider-by-Domain_About_v160.pdf (secure)

Hi rickshein, with your setting, you should not get the Open/Save/Cancel dialog; the document should launch in Adobe Reader automatically. I noticed your dialog is a bit different than mine: yours refers to "PDF file" while mine refers to "Adobe Acrobat Document". (screenshot attached) For some reason, your Firefox is not properly matching up the download with the application/pdf file type. Is this problem specific to Gmail or to HTTPS sites, or does it occur for other PDF downloads as well? For example: http://www.jeffersonscher.com/gm/Google-Hit-Hider-by-Domain_About_v160.pdf https://www.jeffersonscher.com/gm/Google-Hit-Hider-by-Domain_About_v160.pdf (secure)

Question owner

When I click the links in your reply, Firefox does launch them in Reader, so it must be treating links differently than email attachments. Interesting that the popup windows don't refer to PDF files in the same way. Does your Options->Application window look like mine - does it list the content type as "Portable Document Format (PDF)". Even though mine is working OK, it is still in interesting puzzle as to why the popups display differently.

When I click the links in your reply, Firefox does launch them in Reader, so it must be treating links differently than email attachments. Interesting that the popup windows don't refer to PDF files in the same way. Does your Options->Application window look like mine - does it list the content type as "Portable Document Format (PDF)". Even though mine is working OK, it is still in interesting puzzle as to why the popups display differently.
jscher2000
  • Top 10 Contributor
8775 solutions 71736 answers

I was going to say my Options dialog looks the same, but I noticed yours has a different, more generic icon for PDF than mine. Did yours get updated after using one of the ordinary links or does it still have that other icon?

I was going to say my Options dialog looks the same, but I noticed yours has a different, more generic icon for PDF than mine. Did yours get updated after using one of the ordinary links or does it still have that other icon?

Question owner

Not sure where that came from. I just deleted/recreated the rdf file. Before I do anything after restarting Firefox, it shows the std PDF icon along with "Always ask". After resetting it to open Reader, the icon is sticking but the popup is acting as before - identifying it as "Portable Document Format" and not listing Reader. I find it somewhat interesting it's listing PDF at all. I did check my Windows file association, and in there it call it Adobe Acrobat Document. So where is Firefox getting the "Portable Document Format (PDF)" text from?

Not sure where that came from. I just deleted/recreated the rdf file. Before I do anything after restarting Firefox, it shows the std PDF icon along with "Always ask". After resetting it to open Reader, the icon is sticking but the popup is acting as before - identifying it as "Portable Document Format" and not listing Reader. I find it somewhat interesting it's listing PDF at all. I did check my Windows file association, and in there it call it Adobe Acrobat Document. So where is Firefox getting the "Portable Document Format (PDF)" text from?
FredMcD
  • Top 10 Contributor
4261 solutions 59654 answers

I delete the file. Close Firefox and restart it

The instructions say;

Now Close Firefox. Locate the file. Then rename or delete it. Restart Firefox.

''I delete the file. Close Firefox and restart it'' The instructions say; Now '''Close Firefox.''' Locate the file. Then rename or delete it. Restart Firefox.
jscher2000
  • Top 10 Contributor
8775 solutions 71736 answers

Hi rickshein, the phrase "Portable Document Format (PDF)" was added to the Options dialog when the built-in viewer was added. I think that neutral phrase was chosen because you can't assume that the user has Adobe software vs. Apple software vs. Foxit, Nitro, etc. But the Open/Save/Cancel dialog usually picks up the description from the Windows registry.

Some users reported that Firefox 31 and 32 modified how PDF files were described in the registry, for example, changing them from Adobe Acrobat Document to Firefox HTML document. This is a glitch, and when it happens, it affects all file listings throughout Windows. I'm assuming if you had that issue you would have mentioned it...

Hi rickshein, the phrase "Portable Document Format (PDF)" was added to the Options dialog when the built-in viewer was added. I think that neutral phrase was chosen because you can't assume that the user has Adobe software vs. Apple software vs. Foxit, Nitro, etc. But the Open/Save/Cancel dialog usually picks up the description from the Windows registry. Some users reported that Firefox 31 and 32 modified how PDF files were described in the registry, for example, changing them from Adobe Acrobat Document to Firefox HTML document. This is a glitch, and when it happens, it affects all file listings throughout Windows. I'm assuming if you had that issue you would have mentioned it...

Question owner

FredMcD - To be clear, I should have said: "I just CLOSED FIREFOX, deleted/recreated the rdf file. Before I do anything after restarting Firefox..." In each case, I am following the direction provided by both you and jscher2000 - use Firefox to navigate to the folder, close Firefox, delete or rename the .rdf file, then re-light Firefox. At this point, it's apparent that Firefox is launching Reader as it should. It's just not very good in the download dialog box in specifying what it's intending to do. jscher2000: I am using v.32.0.1. You are correct in that I've not noticed any strange re-identification of PDF files. FredMcd & jscher2000 - Thanks for this dialog. It is appreciated!

FredMcD - To be clear, I should have said: "I just CLOSED FIREFOX, deleted/recreated the rdf file. Before I do anything after restarting Firefox..." In each case, I am following the direction provided by both you and jscher2000 - use Firefox to navigate to the folder, close Firefox, delete or rename the .rdf file, then re-light Firefox. At this point, it's apparent that Firefox is launching Reader as it should. It's just not very good in the download dialog box in specifying what it's intending to do. jscher2000: I am using v.32.0.1. You are correct in that I've not noticed any strange re-identification of PDF files. FredMcd & jscher2000 - Thanks for this dialog. It is appreciated!