X
Tap here to go to the mobile version of the site.

Support Forum

Font looks weird in firefox

Posted

I recently restored my windows 7 version and downloaded the newest version of firefox. All the font in firefox looks smudged and is not crisp an clear at all. I have tried unchecking the hardware acceleration tab in options but it still isn't working. Any help would be greatly appreciated.

I recently restored my windows 7 version and downloaded the newest version of firefox. All the font in firefox looks smudged and is not crisp an clear at all. I have tried unchecking the hardware acceleration tab in options but it still isn't working. Any help would be greatly appreciated.

Chosen solution

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Do you have ClearType enabled for all programs in the Windows settings? Win7: Control Panel > Personalization > Window Color and Appearance > Fonts > "Adjust ClearType text"

Try to create a new Boolean pref on the about:config page via the right-click context menu with the name layout.paint_rects_separately and set the value to true and leave hardware acceleration and Direct2D enabled.

  • layout.paint_rects_separately = true
  • gfx.direct2d.disabled pref = true

That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

See also Anti-Aliasing Tuner:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Pando Web Plugin
  • Foxit Reader Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

Bakshara 1 solutions 24 answers

Theme Font & Size Changer 31.2. This Firefox add-on allows you to customize what font, size, and type of text you want to utilize.

Theme Font & Size Changer 31.2. This Firefox add-on allows you to customize what font, size, and type of text you want to utilize.
cor-el
  • Top 10 Contributor
  • Moderator
16858 solutions 152270 answers

Chosen Solution

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Do you have ClearType enabled for all programs in the Windows settings? Win7: Control Panel > Personalization > Window Color and Appearance > Fonts > "Adjust ClearType text"

Try to create a new Boolean pref on the about:config page via the right-click context menu with the name layout.paint_rects_separately and set the value to true and leave hardware acceleration and Direct2D enabled.

  • layout.paint_rects_separately = true
  • gfx.direct2d.disabled pref = true

That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

See also Anti-Aliasing Tuner:

Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB Do you have ClearType enabled for all programs in the Windows settings? Win7: Control Panel > Personalization > Window Color and Appearance > Fonts > "Adjust ClearType text" Try to create a new Boolean pref on the about:config page via the right-click context menu with the name layout.paint_rects_separately and set the value to true and leave hardware acceleration and Direct2D enabled. *layout.paint_rects_separately = true *gfx.direct2d.disabled pref = true That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config See also Anti-Aliasing Tuner: *https://addons.mozilla.org/firefox/addon/anti-aliasing-tuner/

Question owner

The clearType text solved the problem. Thanks a lot for the support.

The clearType text solved the problem. Thanks a lot for the support.