X
Tap here to go to the mobile version of the site.

Support Forum

NCH HOMEPAGE is still here at Firefox!

Posted

I asked this over and over and this page is giving me the run around! I 'm going to cut and paste this question!

I reset Firefox and NCH Software facing still opens up as my homepage!! Yes, clicked OK after reset and closed the computer . It doesn't work. I read the other people's issues with this same problem here on the forum and it doesn't work for me. Help please!

I asked this over and over and this page is giving me the run around! I 'm going to cut and paste this question! I reset Firefox and NCH Software facing still opens up as my homepage!! Yes, clicked OK after reset and closed the computer . It doesn't work. I read the other people's issues with this same problem here on the forum and it doesn't work for me. Help please!

Chosen solution

Did you try removing the NCH software (e.g., a NCH Toolbar?) from the Firefox Add-ons Extensions list (or from the Windows Control Panel) and then reset your home page? I found this uninstall guide linked from the NCH Software site:

These Firefox Support articles have more information:

You should also furnish more troubleshooting information, as follows:

  1. Use ONE of these methods to open the Firefox Troubleshooting Information page:
    • Click the menu button New Fx Menu , click on help Help-29 and select Troubleshooting Information.
    • Type about:support into the Firefox address bar and press the enter key.
  2. At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it.
  3. Now, go back to your forum post, right-click in the reply box and select Paste from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 14.0 r0
  • Google Update
  • VLC media player Web Plugin 2.1.3
  • McAfee MSS+ NPAPI Plugin
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

FredMcD
  • Top 10 Contributor
4225 solutions 58984 answers

You did not say what you did, so we may tell you to do it again.

Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

You did not say what you did, so we may tell you to do it again. Download the '''[https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Mozilla Search Reset]''' {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.
FredMcD
  • Top 10 Contributor
4225 solutions 58984 answers

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is and what it does. Also, check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder Linux: options depends on the package manager and the desktop environment

Go thru the list. If you find something that you don't know what it is, use a web search.

Troubleshoot Firefox Issues Caused By Malware {web link}

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is and what it does. Also, check the programs that are on your computer '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder '''Linux:''' options depends on the package manager and the desktop environment Go thru the list. If you find something that you don't know what it is, use a web search. '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware Troubleshoot Firefox Issues Caused By Malware]''' {web link}

Modified by James

cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157372 answers

When do you see this page?

Is that when you start Firefox or when you open the home page or a new tab?

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

When do you see this page? Is that when you start Firefox or when you open the home page or a new tab? You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

Question owner

TRIED SET A:

  1. 1 I went to TOOLS
  2. 2 OPTIONS
  3. 3 WHEN FIREFOX STARTS: chose 'show my homepage'
  4. 4 HOME PAGE: typed in www.google.com
  5. 5 CLICK OK

The NCH Software facing doesn't come after this...howeve.....the horror begins! After you shut down your computer, this demon comes back!

TRIED SET B:

I downloaded the Mozilla Search Reset and the demon NCH hasn't be exorcised. It didn;t work!

Help!

TRIED SET A: #1 I went to TOOLS #2 OPTIONS #3 WHEN FIREFOX STARTS: chose 'show my homepage' #4 HOME PAGE: typed in www.google.com #5 CLICK OK The NCH Software facing doesn't come after this...howeve.....the horror begins! After you shut down your computer, this demon comes back! TRIED SET B: I downloaded the Mozilla Search Reset and the demon NCH hasn't be exorcised. It didn;t work! Help!

Question owner

When I open the homepage after I shutdown the computer.

When I open the homepage after I shutdown the computer.

Question owner

YOU: " It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is and what it does. Also, check the programs that are on your computer"

ME: Went through that ..nothing new. I don't add a lot of things, and what I have has been there before this demon NCH came to live in my computer.

YOU: "Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder Linux: options depends on the package manager and the desktop environment Go thru the list. If you find something that you don't know what it is, use a web search."

ME: Done that right from the start.

YOU: Troubleshoot Firefox Issues Caused By Malware {web link}"

ME:

Know it already

CONCLUSION: Help!!!!!!!!!!!!!!!!!!!!!!

YOU: " It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is and what it does. Also, check the programs that are on your computer" ME: Went through that ..nothing new. I don't add a lot of things, and what I have has been there before this demon NCH came to live in my computer. YOU: "Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder Linux: options depends on the package manager and the desktop environment Go thru the list. If you find something that you don't know what it is, use a web search." ME: Done that right from the start. YOU: Troubleshoot Firefox Issues Caused By Malware {web link}" ME: Know it already CONCLUSION: Help!!!!!!!!!!!!!!!!!!!!!!

Question owner

This is what CONTINUES to rear up its ugly head AFTER I shut down my computer: defaultsearch.nchuser.com.

It AUTOMATICALLY ends up in the [ TOOLS, GENERAL ,OPTIONS] HOMEPAGE BOX: defaultsearch.nchuser.com. even though I 've changed it to www.google.com and pressed OK.

Heeeeeeeeeeeelllp....is there no salvation for me??

This is what CONTINUES to rear up its ugly head AFTER I shut down my computer: defaultsearch.nchuser.com. It AUTOMATICALLY ends up in the [ TOOLS, GENERAL ,OPTIONS] HOMEPAGE BOX: defaultsearch.nchuser.com. even though I 've changed it to www.google.com and pressed OK. Heeeeeeeeeeeelllp....is there no salvation for me??
philipp
  • Top 25 Contributor
  • Moderator
5291 solutions 23375 answers

please run a full scan of your system with security tools like the free version of malwarebytes and adwcleaner which are specialised in removing browser hijackers.

please run a full scan of your system with security tools like the [http://www.malwarebytes.org/products/malwarebytes_free free version of malwarebytes] and [http://www.bleepingcomputer.com/download/adwcleaner/ adwcleaner] which are specialised in removing browser hijackers.

Question owner

Thanks for all your replies ...but I still need hlep....elhp...pelh...HELP!

See it's affecting me!

Thanks for all your replies ...but I still need hlep....elhp...pelh...HELP! See it's affecting me!
FredMcD
  • Top 10 Contributor
4225 solutions 58984 answers

Open a new tab or window. type about:support in the address box and press enter. Or Press the Alt or F10 key to bring up the tool bar. Then Help > Troubleshooting Information.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate these files;

prefs.js - along with any files that look like this Invalidprefs.js

Then rename or delete them.

Restart Firefox.


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Open a new tab or window. type '''about:support''' in the address box and press enter. '''Or''' Press the '''Alt''' or '''F10''' key to bring up the tool bar. Then '''Help > Troubleshooting Information.''' Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate these files; prefs.js - along with any files that look like this Invalidprefs.js Then rename or delete them. Restart Firefox. ---------------------------- '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save'''

Question owner

YOU: please run a full scan of your system with security tools like the free version of malwarebytes and adwcleaner which are specialised in removing browser hijackers.

ME: Did this countless times. No go...

YOU: please run a full scan of your system with security tools like the free version of malwarebytes and adwcleaner which are specialised in removing browser hijackers. ME: Did this countless times. No go...

Question owner

YOU:

Open a new tab or window. type about:support in the address box and press enter. Or Press the Alt or F10 key to bring up the tool bar. Then Help > Troubleshooting Information.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate these files;

prefs.js - along with any files that look like this Invalidprefs.js

Then rename or delete them.

Restart Firefox.


ME: Didn't find any of the files you mentioned. Closest are : addons.jsn, extensions.jsn, hotfix.v10140527.01jsn, search.jsn, search-metadata.jsn, sessionCheckpoints.jsn, times.jsn, prefs.

I left them coz these these weren't the ones you mentioned. It just had the JSN suffix. a

Also the 'prefs' was close to what you mentioned. But I left that as well.

Didn't work.

YOU: Open a new tab or window. type about:support in the address box and press enter. Or Press the Alt or F10 key to bring up the tool bar. Then Help > Troubleshooting Information. Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Locate these files; prefs.js - along with any files that look like this Invalidprefs.js Then rename or delete them. Restart Firefox. ME: Didn't find any of the files you mentioned. Closest are : addons.jsn, extensions.jsn, hotfix.v10140527.01jsn, search.jsn, search-metadata.jsn, sessionCheckpoints.jsn, times.jsn, prefs. I left them coz these these weren't the ones you mentioned. It just had the JSN suffix. a Also the 'prefs' was close to what you mentioned. But I left that as well. Didn't work.

Question owner

I've tried re setting again as per Firefox troubleshooting, but the evil beast NCH is still lurking about.

Hellp!

I've tried re setting again as per Firefox troubleshooting, but the evil beast NCH is still lurking about. Hellp!
cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157372 answers

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Question owner

YOU: There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


ME: Don't have the one you mentioned but I have WOT but that doesn't protect anything just warns about bad websites.

Appreciate your time though thanks.

Still need an exorcist!

YOU: There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software. ME: Don't have the one you mentioned but I have WOT but that doesn't protect anything just warns about bad websites. Appreciate your time though thanks. Still need an exorcist!
AliceWyman
  • Moderator
240 solutions 2593 answers

Chosen Solution

Did you try removing the NCH software (e.g., a NCH Toolbar?) from the Firefox Add-ons Extensions list (or from the Windows Control Panel) and then reset your home page? I found this uninstall guide linked from the NCH Software site:

These Firefox Support articles have more information:

You should also furnish more troubleshooting information, as follows:

  1. Use ONE of these methods to open the Firefox Troubleshooting Information page:
    • Click the menu button New Fx Menu , click on help Help-29 and select Troubleshooting Information.
    • Type about:support into the Firefox address bar and press the enter key.
  2. At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it.
  3. Now, go back to your forum post, right-click in the reply box and select Paste from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Did you try removing the [http://www.nchsoftware.com/ NCH software] (e.g., a '''NCH Toolbar'''?) from the Firefox Add-ons Extensions list (or from the Windows Control Panel) and '''then''' reset your home page? I found this uninstall guide linked from the NCH Software site: *http://www.nch.com.au/general/uninstall.html These Firefox Support articles have more information: * [[Remove a toolbar that has taken over your Firefox search or home page]] *[[Cannot uninstall an add-on]] You should also furnish more troubleshooting information, as follows: # Use ONE of these methods to open the Firefox Troubleshooting Information page: #* Click the menu button [[Image:New Fx Menu]], click on help [[Image:Help-29]] and select ''Troubleshooting Information''. #* Type '''about:support''' into the Firefox address bar and press the enter key. # At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it. #Now, go back to your forum post, right-click in the reply box and select '''Paste''' from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post. If you need further information about the Troubleshooting information page, please read the article [[Use the Troubleshooting Information page to help fix Firefox issues]].

Question owner

YOU:

Did you try removing the NCH software (e.g., a NCH Toolbar?) from the Firefox Add-ons Extensions list (or from the Windows Control Panel) and then reset your home page? I found this uninstall guide linked from the NCH Software site:

   http://www.nch.com.au/general/uninstall.html 

These Firefox Support articles have more information:

   Remove a toolbar that has taken over your Firefox search or home page
   Cannot uninstall an add-on 

ME: Yes. Done that right from the start.


YOU: You should also furnish more troubleshooting information, as follows:

   Use ONE of these methods to open the Firefox Troubleshooting Information page:
       Click the menu button New Fx Menu , click on help Help-29 and select Troubleshooting Information.
       Type about:support into the Firefox address bar and press the enter key. 
   At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it.
   Now, go back to your forum post, right-click in the reply box and select Paste from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post. 

ME: I got up to "Copy text to clipboard". Click it. [ Clicked it...nothing happened so.....I went to....} "Now, go back to your forum post, right-click in the reply box and select Paste" [ no 'paste' showed up...tried the whole procedure from start to finish and nothing happened.]

Thanks

YOU: Did you try removing the NCH software (e.g., a NCH Toolbar?) from the Firefox Add-ons Extensions list (or from the Windows Control Panel) and then reset your home page? I found this uninstall guide linked from the NCH Software site: http://www.nch.com.au/general/uninstall.html These Firefox Support articles have more information: Remove a toolbar that has taken over your Firefox search or home page Cannot uninstall an add-on ME: Yes. Done that right from the start. YOU: You should also furnish more troubleshooting information, as follows: Use ONE of these methods to open the Firefox Troubleshooting Information page: Click the menu button New Fx Menu , click on help Help-29 and select Troubleshooting Information. Type about:support into the Firefox address bar and press the enter key. At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it. Now, go back to your forum post, right-click in the reply box and select Paste from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post. ME: I got up to "Copy text to clipboard". Click it. [ Clicked it...nothing happened so.....I went to....} "Now, go back to your forum post, right-click in the reply box and select Paste" [ no 'paste' showed up...tried the whole procedure from start to finish and nothing happened.] Thanks
AliceWyman
  • Moderator
240 solutions 2593 answers

Try copying the troubleshooting information again- see Use the Troubleshooting Information page to help fix Firefox issues

Try copying the troubleshooting information again- see [[Use the Troubleshooting Information page to help fix Firefox issues]]

Question owner

Thank you all here at the forum for your generous help! Much thanks especially to Alice Wyman, Moderator!

I went to the 'Trouble shooting' area as she suggested and though it didn't work out as planned...my eye did catch the 'Reset Firefox to its default state' button. I know that somewhere and sometime during this deathly struggle with the NCH demon I tried resetting Firefox but to no avail. However, this time it ushered in VN day! [ Victory over NCH]

So the war's over and while I was typing this Alice Wyman was hard at work helping in the war effort still!

Thanks a million Alice! The Victoria Cross is yours!

Chanbara

Thank you all here at the forum for your generous help! Much thanks especially to Alice Wyman, Moderator! I went to the 'Trouble shooting' area as she suggested and though it didn't work out as planned...my eye did catch the 'Reset Firefox to its default state' button. I know that somewhere and sometime during this deathly struggle with the NCH demon I tried resetting Firefox but to no avail. However, this time it ushered in VN day! [ Victory over NCH] So the war's over and while I was typing this Alice Wyman was hard at work helping in the war effort still! Thanks a million Alice! The Victoria Cross is yours! Chanbara

Modified by Chanbara

Question owner

Again , if it weren't for Alice's suggestion , the war with the NCH demon would've continued on. Salvation has arrived!

Thanks Alice!

Chanbara

Again , if it weren't for Alice's suggestion , the war with the NCH demon would've continued on. Salvation has arrived! Thanks Alice! Chanbara

Modified by Chanbara