Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After installing or upgrading to Firefox 31, starting Firefox does not show homepage, customize shows a blank page and the option button does not work

  • 14 replies
  • 11 have this problem
  • Last reply by pctechdave

more options

I am the Windows admin for a university department and install PCs with Firefox all the time. This problem does not happen with every PC I maintain, only a select few (different model laptops with Windows 8.1 and update 1.) Until today, it only happened with new user accounts (with admin rights) that I setup on the laptops for our staff. Today this happened with The Administrator account while setting up a new laptop. In all cases so far, I install Windows from a saved image that was created using sysprep.

I have tried the many suggestions of resetting Firefox, deleting the users Firefox profile, deleting the users Windows profile, uninstalling/reinstalling Firefox, uninstalling/reinstalling Firefox and the latest Java, but nothing helps. After uninstalling, I run an app to delete temp files and caches and will even manually remove registry keys HKLM\SOFTWARE\Mozilla and HKCU\SOFTWARE\Mozilla. Plus I reboot and make sure the install folder is deleted after uninstall.

Results are the same: after installing Firefox 31, the initial setup window for migrating IE and/or Chrome pops up and after clicking the Finish button, Firefox starts, but does not show the initial new user page, only a blank page. Clicking on the Options button (3 bars) does nothing. Right-clicking in the proper area, the popup menu appears so I can choose to Customize, but that only opens another tab with about:customize in the URL and the page is blank. From the right-click popup menu, I can enable the Menu Bar and get to Options from that.

My latest attempt has helped a little. I uninstalled Firefox 31, cleaned up, deleted user Firefox profile, rebooted and then installed Firefox 30. Inital startup runs, and tells me I'm not up to date, and the Options button works. But I still cannot customize.

I then upgraded to Firefox 31, but then it's back to no startup page, no options button and no customize. I can downgrade to 30 and get all but customize working again.

Only Addon is one for McAfee Scriptscan for Firefox 15.1.0, which just after installing is disabled.

Any help would be appreciated. Thank you.

Chosen solution

Can you try a different Windows theme?

Did you try to boot the computer in Windows Safe Mode?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

Read this answer in context 👍 2

All Replies (14)

more options

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe it's an issue with hardware acceleration and updating the system's graphics drivers could help...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Whoops, forgot to mention I had tried safe mode already. Since I had downgraded to 30, both the user account and the Administrator account have the same problem and the startup works and the Options button too, but cannot customize. I upgraded to 31, and startup, the Options button and customize don't work in normal or safe mode.

I will try the other suggestions now from the link you gave and reply again when I finish.

more options

Ok. I disabled hardware acceleration. The only extension is the McAfee Scriptscan for Firefox 15.1.0, which was already disabled. I then disabled all plugins (Acrobat, Google Update, Intel Identity Protection (2x), Java Deployment Toolkit, Java Platform, MS Office 2013, Quicktime, Shockwave, Silverlight), which were all up to date.

Normal or safe mode still has same result. No startup, no option button and no customize.

Thanks for your help. Got any other suggestions?

more options

Pick one of the problem computers. Use it to Download Firefox Full Installer All languages {web link} See if the installer fixes the problem.

more options

That is what I used already. Although I choose the custom path, I do not make any changes. Looking at the tags for this report, it shows Windows 7, but that is my work PC that does not have the problem. I just finished imaging another laptop and the Administrator account had no problem with 31, but once I created a new user (with admin rights) and ran Firefox, that user could not customize, click the Options button and would not start with homepage. I deleted both Firefox profiles (Administrator and user) uninstalled 31 and cleaned up, rebooted and then installed 30. Again, the Administrator had no problems at all, but the user only had the blank customize problem.

I am going home now. Will try to do a fresh Win8.1 (not from image) install tomorrow on the laptop where both profiles have all 3 problems with version 31 and see if imaging could be part of the cause.

One note though, I maintain 40+ desktops and all are Windows 7. None of them have had this problem with version 30 or 31. So I'd guess it's only Win8.1. As for whether Update 1 has any bearing on this, I could test that at a later date.

Modified by pctechdave

more options

It's possible that Win7 is different from Win8 for the installer.

more options

Well, today I installed a fresh copy of Windows 8.1 Enterprise. Installed drivers and then installed Update 1 and then updated from MS Updates. I then proceeded to install the usual software (Firefox, Chrome, Java, Office13, Quicktime, Flash, Acrobat Reader, MS Expression, PDFCreator and McAfee Enterprise 8.8 patch 4). After installing Firefox 31, as Administrator, I had no problems with 31. Although I was going to make a new image of this system, I decided to create the user account for the person getting the laptop. Once logged in as new user, with admin rights, I first setup and configure IE and then proceed to start Firefox. Again, it migrates the homepage and after clicking Finish, Firefox starts without the new user page, the Options button doesn't work and neither does Customize.

So I don't believe that imaging has anything to do with this problem.

More details, in case it could help. The 2 laptops I've had this problem on:

1) Sony Vaio svs15123cxb, 6GB RAM, installed with UEFI. This is the laptop I worked on today.

2) an old Acer Travelmate 6493, 4GB RAM, and just normal MBR.

I also worked on another identical model Sony laptop, but with Windows 7, not 8.1, and had no problem with Firefox.

Guess I will have to use version 30, or even 29, if I can't find a solution, and hope that version 32 is better.

more options

OK. I installed a new laptop and tried running the setup using Windows 7 Compatibility mode. Administrator account had no problems, but added new user and all 3 problems are there. Checked Admin again and no problems.

I deleted the user account and profile and created a new user. This time I set the preferences for firefox.exe to Windows 7 compatibility mode. And all 3 problems were there. Tried running as admin, no change.

So then I played around with the other compatibility settings and found that if I enable "Reduced color mode" and set it to "8-bit (256) color", then all 3 problems go away, however the minimize/maximize/close buttons in the upper right corner of the window does not show. I can still click where the buttons should be and they work normally.

If I disable "Reduced color mode" or set it to 16-bit, the 3 problems are back.

Oddly, if I set compatibility to XP (sp3) mode, the problems still exist, but the Menu bar is shown. Where the min/max/close buttons should be, it is clear (see-thru), but still works.

So, the problem is related to the "Reduced color mode" somehow. But the Administrator account does not have this problem on this laptop.

FYI, The display drivers are from Sony, as it's a Vaio laptop, and is their custom driver for the Intel HD 4000 graphics. It is over a year old and no newer driver is available from Sony. The latest Intel driver would not install due to Sony custom driver, but I uninstalled the graphics drivers and was then able to install the latest Intel driver. But this did not change anything.

more options

WOW ! ! That's a lot of work.

more options

I prep several laptops a day around the beginning of a new semester, so I stay busy and can easily try different things.

Hope knowing about the "Reduced color mode" will help with fixing the problem in future releases. Still will have to use version 30 for now.

more options

Chosen Solution

Can you try a different Windows theme?

Did you try to boot the computer in Windows Safe Mode?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

more options

Well I tried Safe Mode and that didn't help. In fact, it rendered the "Reduced color mode" useless.

After booting into normal mode, I changed the theme from a solid color background to the Win8.1 default "Harmony" background and the problem went away. Tried switching to different backgrounds and colors (auto or selected) and could not get the problem to reoccur.

So you found the solution: Change the theme. Seems the default(unchanged) theme was somehow wonky. Thanks Cor-el! And Fred.

Thanks for the help

more options

I changed the theme from a solid color It's great you fond the problem. Where ever you got your theme, contact and let them know of the problem. They may come up with a fix.

more options

Not a 3rd party theme, just whatever Windows gives the new user. As Administrator, I change the background to solid color (Black) and change the Window Color to blue. Used to be that when I created a new user account, it would use the default Window theme Harmony (Yellow with shapes) and automatic color, but recently it copies the Administrator theme.

I installed another laptop, 1 of many today, and while setting up the new user, had the same 3 problems with Firefox. But, changing the background did not help. It was changing the Windows Color from Automatic to a specific color that fixed it.

So, to clarify, the problem is not with the background picture or solid color, but with the Color setting (right next to the Desktop Background setting.