Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is there a border at the top and left side when fullscreen?

more options

The window is normal when FF is not fullscreen. As soon as I click the fullscreen button, after the animation I can see a small dark gray at the top and a smaller lighter border at the left side of my monitor.

Modified by Aljaž Srebrnič

All Replies (8)

more options

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

I tried starting in safe mode as you suggested, and the border on the left disappeared, but the one on the top remains. You can actually see the whole tab bar descend a few pixels when going in full screen, and rise back up when exiting.

I'm attaching an image, the upper left corner is actually the screen edge.

Modified by Aljaž Srebrnič

more options

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Hello! no, unfortunately I still see the border at the top. :(

more options

Has this happened before?

more options

As I recall, it was from Firefox 29 onward.

more options

If you have not already, please try disabling any Firefox themes that you may have installed. Ensure that you are running the default theme.

If the issue goes away, it was caused by the theme itself.

more options

Ok.
So I don't know if you know or not, but it was version 29.0 that Firefox implemented their Australis update. This was an update that dramatically changed the layout and appearance of the user interface on Firefox.

My guess is that this update has caused this border to appear. I have tested it on my Windows computer, but no border appears. It must be an issue related to the Mac build of Firefox.

I am not a Firefox developer, but you can file a bug report on Bugzilla. The Mozilla developers will look at the issue and hopefully patch it as soon as possible. Once you file a bug report, please post the link to it here.

Since the issue is still present in Safe Mode, it is most likely something wrong with the way Firefox is built and you will not be able to fix it. As for your border on the side; since that went away in Safe Mode, that border is most likely caused by an add-on. You will need to follow the instructions in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article.