X
Tap here to go to the mobile version of the site.

Support Forum

Why do I keep getting the message "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to s"?

Posted

I have 3 firefox windows with multiple tabs in each, but the main one (and sometimes others) freeze and preclude browsing showing a box saying "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://fctoolbar841468a1d7f44bd384e6bb0f13a06c64/content/fctoolbar.js:1" What stops the script? I gather it's not to do with Google Chrome but FF's internal template for web pages. So, an FF shortcoming, inability to cope, but with what? AFAIK, all software is up to date. I've restarted FF, restarted the laptop, but still the FF problem persists. What is causing it?

I have 3 firefox windows with multiple tabs in each, but the main one (and sometimes others) freeze and preclude browsing showing a box saying "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. Script: chrome://fctoolbar841468a1d7f44bd384e6bb0f13a06c64/content/fctoolbar.js:1" What stops the script? I gather it's not to do with Google Chrome but FF's internal template for web pages. So, an FF shortcoming, inability to cope, but with what? AFAIK, all software is up to date. I've restarted FF, restarted the laptop, but still the FF problem persists. What is causing it?

Chosen solution

This is most likely caused by a toolbar that is installed onto your version of Firefox. Most scripts that start with chrome:// are extensions. I think that it is most likely the Nectar Search Toolbar that is causing the issue because it appears to be the only toolbar installed on your computer.

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 14.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • 5.1.30214.0
  • VLC media player Web Plugin 2.1.3
  • Picasa plugin
  • Garmin Communicator Plug-In 4.1.0.0
  • GEPlugin
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • BT DesktopHelp plug-in for Mozilla Browsers
  • BT Management plug-in for Mozilla Browsers
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Citrix Online App Detector Plugin
  • HP Product Detection Plugin
  • HP Active Check Plugin
  • Windows Activation Technologies Plugin for Mozilla
  • NPWLPG

Application

  • Firefox 30.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/

Extensions

  • Autofill Forms 0.9.9.0 (autofillForms@blueimp.net)
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • HP Detect 1.0.16.0 ({ab91efd4-6975-4081-8552-1b3922ed79e2})
  • Nectar Search Toolbar 1.300.436 ({841468a1-d7f4-4bd3-84e6-bb0f13a06c64})
  • ReloadEvery 28.0.2 ({888d99e7-e8b5-46a3-851e-1ec45da1e644})
  • Skype Click to Call 7.2.15747.10003 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Classic Theme Restorer 1.2.1 (ClassicThemeRestorer@ArisT2Noia4dev) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-26-2012
  • driverDate2:
  • driverVersion: 8.951.9.1000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 3
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • browser.tabs.loadInBackground: False
  • browser.tabs.onTop: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 30.0
  • font.internaluseonly.changed: False
  • gfx.direct2d.disabled: True
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1403698776
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.enable_tls: False
  • security.mixed_content.block_active_content: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1402433870

Misc

  • User JS: Yes
  • Accessibility: No
Wesley Branton 435 solutions 4033 answers

Chosen Solution

This is most likely caused by a toolbar that is installed onto your version of Firefox. Most scripts that start with chrome:// are extensions. I think that it is most likely the Nectar Search Toolbar that is causing the issue because it appears to be the only toolbar installed on your computer.

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

This is most likely caused by a toolbar that is installed onto your version of Firefox. Most scripts that start with <code>chrome://</code> are extensions. I think that it is most likely the '''Nectar Search Toolbar''' that is causing the issue because it appears to be the only toolbar installed on your computer. '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu: *In Firefox 29.0 and above, click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. *In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on ''Help'' (or click on ''Help'' in the Menu bar, if you don't have a Firefox button) then click on ''Restart with Add-ons Disabled''. If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode".<br> [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.''

Question owner

Seems to have worked. Emailed Nectar to advise them of their inadequate tool!

Seems to have worked. Emailed Nectar to advise them of their inadequate tool!
Wesley Branton 435 solutions 4033 answers

I am glad to hear that your problem has been resolved.

If you have not already, please mark this thread as solved by marking the solution.
This will help other users experiencing similar problems find help faster and more efficiently.

I hope you continue using our products and thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you have not already, please mark this thread as solved by marking the solution.<br> This will help other users experiencing similar problems find help faster and more efficiently. I hope you continue using our products and thank you for contacting Mozilla Support.

Question owner

A variation on the theme: Having disabled the Nectar toolbar, when FF restarts (after computer restart) the main FF window has the Restore Session box, but on clicking Restart it soon comes up with box showing "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://browser/content/tabbrowser.xml:3035"

If not cleared, all the tabs show New Tab and would be lost if I don't restore a previous version of sessionstore.js Any ideas what's causing this inability of FF to restart transparently?

A variation on the theme: Having disabled the Nectar toolbar, when FF restarts (after computer restart) the main FF window has the Restore Session box, but on clicking Restart it soon comes up with box showing "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. Script: chrome://browser/content/tabbrowser.xml:3035" If not cleared, all the tabs show New Tab and would be lost if I don't restore a previous version of sessionstore.js Any ideas what's causing this inability of FF to restart transparently?

Question owner

Now crashed and 2nd box has shown the message

Script: chrome://global/content/bindings/text.xml:31

Any ideas?

Now crashed and 2nd box has shown the message Script: chrome://global/content/bindings/text.xml:31 Any ideas?