X
Tap here to go to the mobile version of the site.

Support Forum

Firefox won't open at blank page, but always defaults back to Home Page.

Posted

I keep resetting Firefox (latest version) to open at a blank page, but it continues to open at the default Home Page. That home page has an unwanted Firefox logo in the middle, with a search bar underneath. I don't want to see any of that when I open Firefox, but can't seem to get rid of it. There is nothing in Extensions or Plug-Ins that could cause this.

I keep resetting Firefox (latest version) to open at a blank page, but it continues to open at the default Home Page. That home page has an unwanted Firefox logo in the middle, with a search bar underneath. I don't want to see any of that when I open Firefox, but can't seem to get rid of it. There is nothing in Extensions or Plug-Ins that could cause this.

Chosen solution

Note that there is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • 5.1.30214.0
  • Dragon NaturallySpeaking Rich Internet Application Support - Plugin
  • GEPlugin
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 30.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Dragon NaturallySpeaking Rich Internet Application Support 1.0.0.9 (jid0-lmZNVK7a82O8cufhdfB9dUDfA2w@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6570
  • adapterDescription2:
  • adapterDeviceID: 0x6759
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 4-17-2014
  • driverDate2:
  • driverVersion: 14.100.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6570 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.privatebrowsing.autostart: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • browser.urlbar.autocomplete.enabled: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 30.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1403624377
  • places.history.expiration.transient_current_max_pages: 80446
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npgoogleupdate: 0
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1403489679

Misc

  • User JS: No
  • Accessibility: No
vanik84 7 solutions 44 answers

Tools > Options > General > Restore to Default

try this and that might help you solve the issue

Tools > Options > General > Restore to Default try this and that might help you solve the issue
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158571 answers

If you do not keep changes after a restart or otherwise have problems with preferences, see:

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.


You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program. ---- You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data. *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Multiple_profile_files_created Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

Helpful Reply

I have tried Restore to default, which changed nothing. I have tried opening a new tab which brings up a blank page, then closing the original unwanted page, then selecting that blank page as the Home page, but no joy; it still opens the unwanted Home page. I have checked the .js folders and they are not Read only. I have checked the shortcut target line, and it is formatted correctly. I think that my next step will be to backup my Bookmarks, then completely uninstall Firefox from my PC, followed by a Registry 'power clean' to remove any lingering entries. Once that has been done, I'll do a cold reboot, then download Firefox again and reinstall it. I see no other solution to this problem. If that doesn't work, then I'll have to give serious consideration to making Google Chrome my default browser (or Opera).

I have tried Restore to default, which changed nothing. I have tried opening a new tab which brings up a blank page, then closing the original unwanted page, then selecting that blank page as the Home page, but no joy; it still opens the unwanted Home page. I have checked the .js folders and they are not Read only. I have checked the shortcut target line, and it is formatted correctly. I think that my next step will be to backup my Bookmarks, then completely uninstall Firefox from my PC, followed by a Registry 'power clean' to remove any lingering entries. Once that has been done, I'll do a cold reboot, then download Firefox again and reinstall it. I see no other solution to this problem. If that doesn't work, then I'll have to give serious consideration to making Google Chrome my default browser (or Opera).

Question owner

That 'next step' worked, and the problem no longer exists. Thanks for the suggestions!

That 'next step' worked, and the problem no longer exists. Thanks for the suggestions!
jscher2000
  • Top 10 Contributor
8772 solutions 71719 answers

I've never heard of a power clean but hopefully you won't encounter this again.

If you do, keep in mind that some security/utility software will protect you from unwanted changes to your browser settings by rolling back changes every time you exit Firefox. One such program is Advanced SystemCare (Surfing Protection feature). I'm not sure that has been added to the help article yet: How to fix preferences that won't save.

I've never heard of a power clean but hopefully you won't encounter this again. If you do, keep in mind that some security/utility software will protect you from unwanted changes to your browser settings by rolling back changes every time you exit Firefox. One such program is Advanced SystemCare (Surfing Protection feature). I'm not sure that has been added to the help article yet: [[How to fix preferences that won't save]].

Question owner

Thanks for the info. My 'power clean' is me going into the registry and manually removing all references to Mozilla and/or Firefox. It takes time, but does ensure that whatever my registry cleaning programs miss is caught by me personally. I use ASC but without the Surfing Protection enabled. My protection is provided by Zone Alarm, which I have used for years. I have yet to find anything better.

I may still have a problem. After resolving the problem, I shut my PC down while I was out for several hours. When I booted it on returning, Firefox once again showed the unwanted page. I selected Blank page, closed it, reopened it, and it opened to a Blank page. I may have to live with opening Firefox each morning, and re-selecting Blank page in the Options. From my perspective, this is a software flaw within Firefox/Mozilla.

Thanks for the info. My 'power clean' is me going into the registry and manually removing all references to Mozilla and/or Firefox. It takes time, but does ensure that whatever my registry cleaning programs miss is caught by me personally. I use ASC but without the Surfing Protection enabled. My protection is provided by Zone Alarm, which I have used for years. I have yet to find anything better. I may still have a problem. After resolving the problem, I shut my PC down while I was out for several hours. When I booted it on returning, Firefox once again showed the unwanted page. I selected Blank page, closed it, reopened it, and it opened to a Blank page. I may have to live with opening Firefox each morning, and re-selecting Blank page in the Options. From my perspective, this is a software flaw within Firefox/Mozilla.

Modified by Gowisha

jscher2000
  • Top 10 Contributor
8772 solutions 71719 answers

It is not normal for Firefox to lose settings and you should not have to put up with it.

First, could you confirm that your change is taking effect? You can press Ctrl+n to launch a new window to make sure the change is not being ignored or overridden. Let's assume that's okay.

Could you confirm that Firefox is writing the update out to disk? To do this, you can check the prefs.js file timestamp, or open it in a text editor. This file is in your currently active profile folder, which you can open using the Troubleshooting Information page. To do that, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. Here you can find prefs.js and see whether Firefox is updating the file after you change your home page.

It is ''not normal'' for Firefox to lose settings and you should not have to put up with it. First, could you confirm that your change is taking effect? You can press Ctrl+n to launch a new window to make sure the change is not being ignored or overridden. Let's assume that's okay. Could you confirm that Firefox is writing the update out to disk? To do this, you can check the prefs.js file timestamp, or open it in a text editor. This file is in your currently active profile folder, which you can open using the Troubleshooting Information page. To do that, either: * "3-bar" menu button > "?" button > Troubleshooting Information * Help menu > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. Here you can find prefs.js and see whether Firefox is updating the file after you change your home page.

Question owner

If I make the change to Blank page, it is writing at that specific time to the prefs.js file. Using Ctrl-n opens a new page that is blank. If I then close Firefox and reopen it, I still have a blank page. However, just now I changed the start page preference to blank, closed Firefox, and then shut down my PC. I waited 30-seconds to ensure the capacitors discharged, and did a cold boot. Voila, when I opened Firefox it had reverted to the unwanted page, and that change had been written to the prefs.js file at the same time.

If I make the change to Blank page, it is writing at that specific time to the prefs.js file. Using Ctrl-n opens a new page that is blank. If I then close Firefox and reopen it, I still have a blank page. However, just now I changed the start page preference to blank, closed Firefox, and then shut down my PC. I waited 30-seconds to ensure the capacitors discharged, and did a cold boot. Voila, when I opened Firefox it had reverted to the unwanted page, and that change had been written to the prefs.js file at the same time.

Question owner

I just ran that same scenario again, and realize that the change to the prefs.js file happened at the time Windows started, and not when I reopened Firefox. I then made the change to Blank page on opening, and it wrote to the prefs.js file at that same moment. Ctrl-n now produces a clean, blank page.

I just ran that same scenario again, and realize that the change to the prefs.js file happened at the time Windows started, and not when I reopened Firefox. I then made the change to Blank page on opening, and it wrote to the prefs.js file at that same moment. Ctrl-n now produces a clean, blank page.
jscher2000
  • Top 10 Contributor
8772 solutions 71719 answers

This is mysterious. Do you have any "cleaning" type programs that run at Windows startup which might be touching your Firefox settings? If not Advanced SystemCare, maybe some other program that has a home page protection or browsing protection feature.

This is mysterious. Do you have any "cleaning" type programs that run at Windows startup which might be touching your Firefox settings? If not Advanced SystemCare, maybe some other program that has a home page protection or browsing protection feature.

Question owner

Nothing like that at all. Zone Alarm starts, but it does not impact the settings of any programs. Also, this is a problem that only started with the installation of Firefox 30.0. Prior to that, the 'home' page was always blank, as I had set it that way with 29.0 and it subsequently stayed at that setting. When the upgrade to 30.0 installed, this problem showed up. That's why I think it must be a software glitch in Firefox. Mind you, that wouldn't explain why the prefs.js file changes when I boot the system.

Nothing like that at all. Zone Alarm starts, but it does not impact the settings of any programs. Also, this is a problem that only started with the installation of Firefox 30.0. Prior to that, the 'home' page was always blank, as I had set it that way with 29.0 and it subsequently stayed at that setting. When the upgrade to 30.0 installed, this problem showed up. That's why I think it must be a software glitch in Firefox. Mind you, that wouldn't explain why the prefs.js file changes when I boot the system.

Question owner

This is from the Troubleshooting file.

{

 "application": {
   "name": "Firefox",
   "version": "30.0",
   "userAgent": "Mozilla/5.0 (Windows NT 5.1; rv:30.0) Gecko/20100101 Firefox/30.0",
   "supportURL": "https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/"
 },
 "crashes": {
   "submitted": [],
   "pending": 0
 },
 "modifiedPreferences": {
   "browser.cache.disk.capacity": 358400,
   "browser.cache.disk.smart_size.first_run": false,
   "browser.cache.disk.smart_size.use_old_max": false,
   "browser.cache.disk.smart_size_cached_value": 358400,
   "browser.places.smartBookmarksVersion": 7,
   "browser.privatebrowsing.autostart": true,
   "browser.sessionstore.upgradeBackup.latestBuildID": "20140605174243",
   "browser.startup.homepage_override.mstone": "30.0",
   "browser.startup.homepage_override.buildID": "20140605174243",
   "dom.mozApps.used": true,
   "extensions.lastAppVersion": "30.0",
   "gfx.direct3d.last_used_feature_level_idx": 0,
   "network.cookie.prefsMigrated": true,
   "places.database.lastMaintenance": 1403724932,
   "places.history.expiration.transient_current_max_pages": 80446,
   "plugin.importedState": true,
   "plugin.disable_full_page_plugin_for_types": "application/pdf",
   "privacy.donottrackheader.enabled": true,
   "privacy.sanitize.migrateFx3Prefs": true,
   "storage.vacuum.last.places.sqlite": 1403724932,
   "storage.vacuum.last.index": 0
 },
 "graphics": {
   "numTotalWindows": 1,
   "numAcceleratedWindows": 1,
   "windowLayerManagerType": "Direct3D 10",
   "windowLayerManagerRemote": false,
   "adapterDescription": "AMD Radeon HD 6570",
   "adapterVendorID": "0x1002",
   "adapterDeviceID": "0x6759",
   "adapterRAM": "2048",
   "adapterDrivers": "aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva",
   "driverVersion": "14.100.0.0",
   "driverDate": "4-17-2014",
   "adapterDescription2": "",
   "adapterVendorID2": "",
   "adapterDeviceID2": "",
   "adapterRAM2": "",
   "adapterDrivers2": "",
   "driverVersion2": "",
   "driverDate2": "",
   "isGPU2Active": false,
   "direct2DEnabled": true,
   "directWriteEnabled": true,
   "directWriteVersion": "6.3.9600.17111",
   "webglRenderer": "Google Inc. -- ANGLE (AMD Radeon HD 6570 Direct3D9Ex vs_3_0 ps_3_0)",
   "info": {
     "AzureCanvasBackend": "direct2d",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "cairo",
     "AzureContentBackend": "direct2d"
   }
 },
 "javaScript": {
   "incrementalGCEnabled": true
 },
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 },
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.6",
     "version": "4.10.6"
   },
   "NSS": {
     "minVersion": "3.16 Basic ECC",
     "version": "3.16 Basic ECC"
   },
   "NSSUTIL": {
     "minVersion": "3.16",
     "version": "3.16"
   },
   "NSSSSL": {
     "minVersion": "3.16 Basic ECC",
     "version": "3.16 Basic ECC"
   },
   "NSSSMIME": {
     "minVersion": "3.16 Basic ECC",
     "version": "3.16 Basic ECC"
   }
 },
 "userJS": {
   "exists": false
 },
 "extensions": [
   {
     "name": "Dragon NaturallySpeaking Rich Internet Application Support",
     "version": "1.0.0.9",
     "isActive": false,
     "id": "jid0-lmZNVK7a82O8cufhdfB9dUDfA2w@jetpack"
   }
 ]

}

This is from the Troubleshooting file. { "application": { "name": "Firefox", "version": "30.0", "userAgent": "Mozilla/5.0 (Windows NT 5.1; rv:30.0) Gecko/20100101 Firefox/30.0", "supportURL": "https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/" }, "crashes": { "submitted": [], "pending": 0 }, "modifiedPreferences": { "browser.cache.disk.capacity": 358400, "browser.cache.disk.smart_size.first_run": false, "browser.cache.disk.smart_size.use_old_max": false, "browser.cache.disk.smart_size_cached_value": 358400, "browser.places.smartBookmarksVersion": 7, "browser.privatebrowsing.autostart": true, "browser.sessionstore.upgradeBackup.latestBuildID": "20140605174243", "browser.startup.homepage_override.mstone": "30.0", "browser.startup.homepage_override.buildID": "20140605174243", "dom.mozApps.used": true, "extensions.lastAppVersion": "30.0", "gfx.direct3d.last_used_feature_level_idx": 0, "network.cookie.prefsMigrated": true, "places.database.lastMaintenance": 1403724932, "places.history.expiration.transient_current_max_pages": 80446, "plugin.importedState": true, "plugin.disable_full_page_plugin_for_types": "application/pdf", "privacy.donottrackheader.enabled": true, "privacy.sanitize.migrateFx3Prefs": true, "storage.vacuum.last.places.sqlite": 1403724932, "storage.vacuum.last.index": 0 }, "graphics": { "numTotalWindows": 1, "numAcceleratedWindows": 1, "windowLayerManagerType": "Direct3D 10", "windowLayerManagerRemote": false, "adapterDescription": "AMD Radeon HD 6570", "adapterVendorID": "0x1002", "adapterDeviceID": "0x6759", "adapterRAM": "2048", "adapterDrivers": "aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva", "driverVersion": "14.100.0.0", "driverDate": "4-17-2014", "adapterDescription2": "", "adapterVendorID2": "", "adapterDeviceID2": "", "adapterRAM2": "", "adapterDrivers2": "", "driverVersion2": "", "driverDate2": "", "isGPU2Active": false, "direct2DEnabled": true, "directWriteEnabled": true, "directWriteVersion": "6.3.9600.17111", "webglRenderer": "Google Inc. -- ANGLE (AMD Radeon HD 6570 Direct3D9Ex vs_3_0 ps_3_0)", "info": { "AzureCanvasBackend": "direct2d", "AzureSkiaAccelerated": 0, "AzureFallbackCanvasBackend": "cairo", "AzureContentBackend": "direct2d" } }, "javaScript": { "incrementalGCEnabled": true }, "accessibility": { "isActive": false, "forceDisabled": 0 }, "libraryVersions": { "NSPR": { "minVersion": "4.10.6", "version": "4.10.6" }, "NSS": { "minVersion": "3.16 Basic ECC", "version": "3.16 Basic ECC" }, "NSSUTIL": { "minVersion": "3.16", "version": "3.16" }, "NSSSSL": { "minVersion": "3.16 Basic ECC", "version": "3.16 Basic ECC" }, "NSSSMIME": { "minVersion": "3.16 Basic ECC", "version": "3.16 Basic ECC" } }, "userJS": { "exists": false }, "extensions": [ { "name": "Dragon NaturallySpeaking Rich Internet Application Support", "version": "1.0.0.9", "isActive": false, "id": "jid0-lmZNVK7a82O8cufhdfB9dUDfA2w@jetpack" } ] }
jscher2000
  • Top 10 Contributor
8772 solutions 71719 answers

Firefox itself doesn't do anything at Windows startup. The Mozilla maintenance service probably would be started by Windows to check for updates. You can try disabling the service and see whether that makes any difference. There is a checkbox for that in the Advanced section of the Options dialog. This article has the details: Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox.

If you are the kind of person that can't rest without knowing what process is doing this? you could try the auditing feature. I don't know how it works in Windows 8, but here is a recent post about using that feature in Windows 7: https://support.mozilla.org/questions/1006677#answer-593071.

Firefox itself doesn't do anything at Windows startup. The Mozilla maintenance service probably would be started by Windows to check for updates. You can try disabling the service and see whether that makes any difference. There is a checkbox for that in the Advanced section of the Options dialog. This article has the details: [[Advanced settings for accessibility, browsing, system defaults, network, updates, and encryption]]. If you are the kind of person that can't rest without knowing ''what process is doing this?'' you could try the auditing feature. I don't know how it works in Windows 8, but here is a recent post about using that feature in Windows 7: [https://support.mozilla.org/questions/1006677#answer-593071].
jscher2000
  • Top 10 Contributor
8772 solutions 71719 answers

Hmm, automatic private browsing. I wonder whether that has anything to do with it? Still shouldn't cause things to happen on Windows startup.

Hmm, automatic private browsing. I wonder whether that has anything to do with it? Still shouldn't cause things to happen on Windows startup.

Question owner

I'll play with those settings tomorrow, and see what happens. Right now it's time for me to shut things down for the night. And I am the kind of person who will eventually find out where the problem lies. For the moment I disabled the Auto Update, and I'll see what happens in the morning when I restart the PC.

Thanks for your input, it is truly appreciated.

I'll play with those settings tomorrow, and see what happens. Right now it's time for me to shut things down for the night. And I am the kind of person who will eventually find out where the problem lies. For the moment I disabled the Auto Update, and I'll see what happens in the morning when I restart the PC. Thanks for your input, it is truly appreciated.

Question owner

The first thing I did this morning after Windows had fully loaded, was to look at the time stamps on the prefs.js and the sessionstore.js, and both were 10:04 pm last night, which was when I changed my preference to Blank page and closed Firefox. I had also disabled Auto Update. When I opened Firefox this morning, it opened again to the unwanted default page, and the prefs.js time stamp changed to 9:22 am. As Churchill once said "It is a riddle wrapped in a mystery inside an enigma...". However, as I have time I'll keep trying different scenarios until I find the cause of this problem. I think my next step will be to dig into the actual prefs.js file and see if I can make a change in there; perhaps changing a 'true' to a 'false', or vice-versa. Once I find the solution, I'll let you know.

The first thing I did this morning after Windows had fully loaded, was to look at the time stamps on the prefs.js and the sessionstore.js, and both were 10:04 pm last night, which was when I changed my preference to Blank page and closed Firefox. I had also disabled Auto Update. When I opened Firefox this morning, it opened again to the unwanted default page, and the prefs.js time stamp changed to 9:22 am. As Churchill once said "It is a riddle wrapped in a mystery inside an enigma...". However, as I have time I'll keep trying different scenarios until I find the cause of this problem. I think my next step will be to dig into the actual prefs.js file and see if I can make a change in there; perhaps changing a 'true' to a 'false', or vice-versa. Once I find the solution, I'll let you know.

Question owner

I just booted into Safe Mode, opened Firefox and made the changes to about:blank for home page, and open to Blank page, closed Firefox, rebooted again in Safe Mode, and the changes held. Firefox opened the way I had set it. Then I shut down the PC, restarted it, opened Firefox, and it was back to the unwanted default settings. I've tried disabling Zone Alarm before rebooting, just in case there is something there, but it made no difference. I've also checked everything in the Startup menu, and see nothing there that logically could be the problem. So, as I have time, I'm going to disable things via the msconfig, and see what happens. More as it happens...

I just booted into Safe Mode, opened Firefox and made the changes to about:blank for home page, and open to Blank page, closed Firefox, rebooted again in Safe Mode, and the changes held. Firefox opened the way I had set it. Then I shut down the PC, restarted it, opened Firefox, and it was back to the unwanted default settings. I've tried disabling Zone Alarm before rebooting, just in case there is something there, but it made no difference. I've also checked everything in the Startup menu, and see nothing there that logically could be the problem. So, as I have time, I'm going to disable things via the msconfig, and see what happens. More as it happens...

Question owner

I have now given up on trying to resolve this problem, and have switched to Opera as a browser. I have been 'playing' around with computers since 1980, have designed software, have built computers, and this time the 'puter won the battle. There is no need for me to comment further about this problem, so it will remain unsolved.

To those who have responded with suggestions, I thank you.

I have now given up on trying to resolve this problem, and have switched to Opera as a browser. I have been 'playing' around with computers since 1980, have designed software, have built computers, and this time the 'puter won the battle. There is no need for me to comment further about this problem, so it will remain unsolved. To those who have responded with suggestions, I thank you.
nikosd66 0 solutions 1 answers

Helpful Reply

I had the same problem. I found a file user.js containing one line: user_pref("browser.sessionstore.resume_session_once", true); I removed this file and problem was resolved.

This file is in your currently active profile folder, which you can open using the Troubleshooting Information page. To do that, either:

 3-bar menu button > ? button > Troubleshooting Information
 Help menu > Troubleshooting Information
 type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. Here you can find prefs.js and see whether Firefox is updating the file after you change your home page.

I had the same problem. I found a file user.js containing one line: user_pref("browser.sessionstore.resume_session_once", true); I removed this file and problem was resolved. ''This file is in your currently active profile folder, which you can open using the Troubleshooting Information page. To do that, either: 3-bar menu button > ? button > Troubleshooting Information Help menu > Troubleshooting Information type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. Here you can find prefs.js and see whether Firefox is updating the file after you change your home page.''

Modified by nikosd66

Question owner

Stranger things have happened. I did a global search on why the about:config file was not retaining the changes I made (open as about:blank instead of about:home). One of the comments at Mozilla suggested removing all add-ons and extensions. As I did not have any of those, I moved further down the page. The next suggestion was to go into Menu > Help > Troubleshooting Information, and click on Reset Firefox. I did that and the problem was solved. Firefox opens at a blank page. Now to see if it retains that setting during a reboot.

The change did not survive a cold boot of my system. It has reverted to the problem page. But, I have now given up. There is more to life than chasing an errant software bug.

Stranger things have happened. I did a global search on why the about:config file was not retaining the changes I made (open as about:blank instead of about:home). One of the comments at Mozilla suggested removing all add-ons and extensions. As I did not have any of those, I moved further down the page. The next suggestion was to go into Menu > Help > Troubleshooting Information, and click on Reset Firefox. I did that and the problem was solved. Firefox opens at a blank page. Now to see if it retains that setting during a reboot. The change did not survive a cold boot of my system. It has reverted to the problem page. But, I have now given up. There is more to life than chasing an errant software bug.

Modified by Gowisha