Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox reverts to never remember history immediately after I tell it to use custom history.

  • 3 replies
  • 4 have this problem
  • 1 view
  • Last reply by pmxf

more options

Firefox will not keep my "custom history" setting. I tell it to use custom history. I close the options window and even if I do not do anything, when I open the options window again, Firefox has reverted to "never remember history". I've tried deleting cookie and preference files. I have tried uninstalling & reinstalling Firefox. I have tried deleting the profile.js file or whatever it's called. I have tried all the solutions I have found online and nothing works.

Firefox will not keep my "custom history" setting. I tell it to use custom history. I close the options window and even if I do not do anything, when I open the options window again, Firefox has reverted to "never remember history". I've tried deleting cookie and preference files. I have tried uninstalling & reinstalling Firefox. I have tried deleting the profile.js file or whatever it's called. I have tried all the solutions I have found online and nothing works.

Chosen solution

Thank you for your response. I do understand that changes need made or it defaults back. I had made a change. I did solve the problem on my own with some more tinkering, though. I changed a different thing, then changed it back and that somehow made the settings stay.

Read this answer in context 👍 1

All Replies (3)

more options

I read somewhere that after you choose Custom settings, before you OK out of the dialog, you need to make at least one change to a history setting in order to keep that, otherwise, Firefox keeps what you had before.

What are you trying to customize?

more options

If you see "(Never) Remember History" then that means that all history and cookie settings are set to the default value (i.e. cookies are enabled). "Never Remember History" means that Private Browsing is active and "Always use private browsing mode" gets a checkmark.

The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".

more options

Chosen Solution

Thank you for your response. I do understand that changes need made or it defaults back. I had made a change. I did solve the problem on my own with some more tinkering, though. I changed a different thing, then changed it back and that somehow made the settings stay.