X
Tap here to go to the mobile version of the site.

Support Forum

As of today Firefox won't let me access SharePoint. Get '401 unauthorized' message

Posted

In the past, I've been able to access our SharePoint hosted service without a problem.

Although I've not accessed SharePoint for a while, when I tried today (upgraded to Foxfire 30 in the meantime) I get the error message above.

Am able to access the site via Google Chrome.

SP hoster help desk tells me other Firefox users are having the same problem accessing their own (separate) SP servers.

In the past, I've been able to access our SharePoint hosted service without a problem. Although I've not accessed SharePoint for a while, when I tried today (upgraded to Foxfire 30 in the meantime) I get the error message above. Am able to access the site via Google Chrome. SP hoster help desk tells me other Firefox users are having the same problem accessing their own (separate) SP servers.

Chosen solution

addled,

The first thing to do is to contact that SP hoster help desk, and let them know about this Bug report. https://bugzilla.mozilla.org/show_bug.cgi?id=828183

They're using an old method of authentication which isn't considered secure any longer. The preference you just changed so that you can log into that website un-did a security fix that is new in Firefox 30. http://www.mozilla.org/en-US/firefox/30.0/releasenotes/

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.30317.0
  • Garmin Communicator Plug-in Version 4.1.0.0
  • iPhoto6
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • WebEx64 General Plugin Container Version 205
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Garmin Communicator Plug-in Version 4.0.3.0
  • doubleTwist Web Plugin

Application

  • Firefox 30.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0/Darwin/en-US/

Extensions

  • CleanPrint 4.8.3 (cleanprint@formatdynamics.com)
  • Clearly 10.1.1.2 (readable@evernote.com)
  • Easy Access 1.0.1 (quicklaunch@mozillaonline.com)
  • Evernote Web Clipper 5.9.1 ({E0B8C461-F8FB-49b4-8373-FE32E9252800})
  • eWallet AutoPass 2.1.0.33259 (ewalletautopass@iliumsoft.com)
  • Flash Video Downloader - Full HD Download 5.9.1 (artur.dubovoy@gmail.com)
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Map This 0.3.1 ({05f6a7ea-896b-11da-8bde-f66bad1e3f3a})
  • PDF Viewer 1.0.277 (uriloader@pdf.js)
  • pearltrees 7.1 (collector@broceliand.fr)
  • TinyURL Generator 2.6.1 (tinyurl.addon@fast-chat.co.uk)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Zotero 4.0.20.2 (zotero@chnm.gmu.edu)
  • Xmarks 4.3.1 (foxmarks@kei.com) (Inactive)
  • Yahoo! Toolbar 3.2.4.20140604103324 ({635abd67-4fe9-1b23-4f01-e679fa7484c1}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage: http://www.gmu.edu
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • browser.urlbar.autocomplete.enabled: False
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 30.0
  • font.internaluseonly.changed: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1403194243
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.sharepointbrowserplugin: 1
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1403110801

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
3170 solutions 42806 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache

Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > Network > Cached Web Content: Clear Now

and

  • Remove Cookies

This will log you out of all sites you're logged in to. Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Privacy. Under History, select Firefox will Use Custom Settings. There is a button on the right side called Show Cookies.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache Press the '''<Alt>''' or '''<F10>''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Advanced > Network > Cached Web Content: Clear Now''' and * Remove Cookies ''This will log you out of all sites you're logged in to. '' Press the '''<Alt>''' or '''<F10>''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Privacy.''' Under '''History''', select Firefox will '''Use Custom Settings'''. There is a button on the right side called '''Show Cookies'''. If there is still a problem, '''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''''' {web link} While you are in safe mode; Press the '''<Alt>''' or '''<F10>''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Advanced > General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites and see if there is still a problem. Then restart

Question owner

Tried all the suggestions, thank you. But the problem still remains. Simply cannot access SharePoint using Firefox. Chrome works and so does Safari - this is on a Mac. As far as I can see it has nothing to do with cookies or the cache, etc.

Tried all the suggestions, thank you. But the problem still remains. Simply cannot access SharePoint using Firefox. Chrome works and so does Safari - this is on a Mac. As far as I can see it has nothing to do with cookies or the cache, etc.
Aman Routh 77 solutions 607 answers
Hello, see this for help * [[Firefox can't load websites but other browsers can]] * https://support.mozilla.org/en-US/kb/configure-firewalls-so-firefox-can-access-internet
the-edmeister
  • Top 25 Contributor
  • Moderator
5103 solutions 37610 answers

401 Unauthorized is a server error message related to an incorrect username / password.

http://pcsupport.about.com/od/findbyerrormessage/a/401error.htm

401 Unauthorized is a server error message related to an incorrect username / password. http://pcsupport.about.com/od/findbyerrormessage/a/401error.htm
the-edmeister
  • Top 25 Contributor
  • Moderator
5103 solutions 37610 answers

Helpful Reply

That type of message might be related to Insecure NTLM (pre-NTLMv2) authentication being disabled in Firefox 30.

Type about:config in the URL bar and hit Enter. Accept the warning. Type NTLM in the Search bar at the top. Right-click network.negotiate-auth.allow-insecure-ntlm-v1 and select Toggle. Then close Firefox and restart.

See if you can access that SharePoint website without getting that 401 message.

That type of message might be related to Insecure NTLM (pre-NTLMv2) authentication being disabled in Firefox 30. Type '''about:config''' in the URL bar and hit Enter. Accept the warning. Type '''NTLM''' in the Search bar at the top. Right-click '''network.negotiate-auth.allow-insecure-ntlm-v1''' and select '''Toggle'''. Then close Firefox and restart. See if you can access that SharePoint website without getting that 401 message.

Helpful Reply

The ed-meister

Thank you very much for your advice. This has resolved the problem. I suspected it had something to do with Firefox 30, but I'd never have pinpointed the issue on my own! I don't no how best to spread the word because I'm sure there are others out there with the same problem.

Regards

Mark

The ed-meister Thank you very much for your advice. This has resolved the problem. I suspected it had something to do with Firefox 30, but I'd never have pinpointed the issue on my own! I don't no how best to spread the word because I'm sure there are others out there with the same problem. Regards Mark
FredMcD
  • Top 10 Contributor
3170 solutions 42806 answers

You have chosen a solution. That means this post is marked as solved. Anyone that looks thru the forum will see it. Good Luck.

You have chosen a solution. That means this post is marked as solved. Anyone that looks thru the forum will see it. Good Luck.
the-edmeister
  • Top 25 Contributor
  • Moderator
5103 solutions 37610 answers

Chosen Solution

addled,

The first thing to do is to contact that SP hoster help desk, and let them know about this Bug report. https://bugzilla.mozilla.org/show_bug.cgi?id=828183

They're using an old method of authentication which isn't considered secure any longer. The preference you just changed so that you can log into that website un-did a security fix that is new in Firefox 30. http://www.mozilla.org/en-US/firefox/30.0/releasenotes/

addled, The first thing to do is to contact that SP hoster help desk, and let them know about this Bug report. https://bugzilla.mozilla.org/show_bug.cgi?id=828183 They're using an old method of authentication which isn't considered secure any longer. The preference you just changed so that you can log into that website un-did a security fix that is new in Firefox 30. http://www.mozilla.org/en-US/firefox/30.0/releasenotes/

Question owner

the-edmeister

I've notified the tech support people at the hosting company via a trouble ticket which was still open. I sent them most your not, above, with the links.

Thanks again.

the-edmeister I've notified the tech support people at the hosting company via a trouble ticket which was still open. I sent them most your not, above, with the links. Thanks again.
radascuta 1 solutions 4 answers

Mozilla is making a choice to not use the local user's security profile and integrated Kerberos or NTLM authentication, as the other three major browsers do. This may be the right choice politically or for one technical reason or another, but ultimately, this affects users who use SharePoint, or maybe even Office 365. It makes one adopt Chrome quicker.

Also, not all Mac configurations need this change, and no Windows systems that we noticed need it. We have the same Mac OS level machines that do and others that do not need this NTLM v1 allowed configuration setting to connect to SharePoint - no idea why.

Mozilla is making a choice to not use the local user's security profile and integrated Kerberos or NTLM authentication, as the other three major browsers do. This may be the right choice politically or for one technical reason or another, but ultimately, this affects users who use SharePoint, or maybe even Office 365. It makes one adopt Chrome quicker. Also, not all Mac configurations need this change, and no Windows systems that we noticed need it. We have the same Mac OS level machines that do and others that do not need this NTLM v1 allowed configuration setting to connect to SharePoint - no idea why.

Question owner

Thanks radascuta

It's helpful to get this kind of information and, for someone who is not technically trained, it suggests that with today's software 'secure' and 'simple' (to use) are probably both distant goals (wishful thinking?) and may not be compatible.

BTW I find that Chrome loads SharePoint pages very slowly and can't figure out why!

Thanks radascuta It's helpful to get this kind of information and, for someone who is not technically trained, it suggests that with today's software 'secure' and 'simple' (to use) are probably both distant goals (wishful thinking?) and may not be compatible. BTW I find that Chrome loads SharePoint pages very slowly and can't figure out why!