X
Tap here to go to the mobile version of the site.

Support Forum

Mac OSX Keychain Services Integration issues with Firefox Nightly 32.0a1 and 33.0a1

Posted

Moderator edited the title of this thread to reflect the affected versions - this not a support issue at this time as it involves pre-release versions that are currently in the Alpha testing phase

It seems Firefox definitely has some password link problems. It no longer asks me if I want to save new passwords and when I try to access passwords in security, it freezes and I have to hard quit. (See "frozen screen" grab attached.)

Hi Julian, Keychain Services Integration still not working in Firefox 32.0a1 (2014-05-29) I have bug reporting selected but can find no log reports for Keychain Services Integration in console. I have completely removed and installed fresh many times. All indications in the browser say it's active but nothing happens. I have disabled every other tool / add-on I use with no change. I'm not any kind of expert but can generally find some indication of problems. In this case nothing. All looks good but I still have to enter my passwords every time I open my regular pages. Thanks for the good work. I really miss the convenience.


On May 17, 2014, at 12:12 PM, Julian wrote:

Hi Steve, I'm not aware of anything, no. And I'm afraid I'm traveling at the moment so it will be at least a couple of weeks before I have a chance to take a look... The logs may reveal something... Let me know if you can narrow it down. Julian

On 17 May 2014 15:30, "SDK" wrote:

Hi Julian, Keychain Services Integration has stopped working for me in a recent update to Firefox Nightly (32.0a1 (2014-05-16)) Are you aware of any software conflicts that would cause that ?

''Moderator edited the title of this thread to reflect the affected versions - this not a support issue at this time as it involves pre-release versions that are currently in the Alpha testing phase'' It seems Firefox definitely has some password link problems. It no longer asks me if I want to save new passwords and when I try to access passwords in security, it freezes and I have to hard quit. (See "frozen screen" grab attached.) Hi Julian, Keychain Services Integration still not working in Firefox 32.0a1 (2014-05-29) I have bug reporting selected but can find no log reports for Keychain Services Integration in console. I have completely removed and installed fresh many times. All indications in the browser say it's active but nothing happens. I have disabled every other tool / add-on I use with no change. I'm not any kind of expert but can generally find some indication of problems. In this case nothing. All looks good but I still have to enter my passwords every time I open my regular pages. Thanks for the good work. I really miss the convenience. On May 17, 2014, at 12:12 PM, Julian wrote: Hi Steve, I'm not aware of anything, no. And I'm afraid I'm traveling at the moment so it will be at least a couple of weeks before I have a chance to take a look... The logs may reveal something... Let me know if you can narrow it down. Julian On 17 May 2014 15:30, "SDK" wrote: Hi Julian, Keychain Services Integration has stopped working for me in a recent update to Firefox Nightly (32.0a1 (2014-05-16)) Are you aware of any software conflicts that would cause that ?

Modified by the-edmeister

Chosen solution

Here's a Bugzilla report about a Keychain Services Integration problem that was related to Firefox Sync back in 2011. https://bugzilla.mozilla.org/show_bug.cgi?id=642785

That is the only Bugzilla report I found regarding Keychain Services Integration.

_SDK_, I suggest that you file a Bugzilla report about your findings. That is one of the "responsibilities" of testing Nightly's - reporting the "bugs" you find so that the developers are aware of problems like this. https://bugzilla.mozilla.org/

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 13.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides communication between running browsers and Sheep Systems bookmarks management applications.
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.5
  • View PDF documents within your web browser.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

Santosh Viswanatham 0 solutions 6 answers

Hello follow the below steps.

  • click on the menu button on top right of the screen(below close button)
  • click on options.
  • Under security tab enable "Remember passwords for sites".
  • Click on "Ok"

This should work.

Hello follow the below steps. * click on the menu button on top right of the screen(below close button) * click on options. * Under security tab enable "Remember passwords for sites". * Click on "Ok" This should work.

Question owner

Hi Santosh, Tried all the obvious, basic, operational things. No matter what when I try to access any of the password windows, Firefox freezes and I have to hard quit to access it again. It's been happening over several updates. Not sure when it started... Just noticed I had to start filling in my passwords again. Thought it was Julian Fitzell's Keychain Services Integration but no, It's definitely something with Firefox. I'm not a tech so sorry if my info is lacking details. Regards.

Hi Santosh, Tried all the obvious, basic, operational things. No matter what when I try to access any of the password windows, Firefox freezes and I have to hard quit to access it again. It's been happening over several updates. Not sure when it started... Just noticed I had to start filling in my passwords again. Thought it was Julian Fitzell's Keychain Services Integration but no, It's definitely something with Firefox. I'm not a tech so sorry if my info is lacking details. Regards.
FredMcD
  • Top 10 Contributor
4220 solutions 58909 answers

Were there any crash reports?

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste that into the "Post a Reply" box.

SubmittedCrashReports-Win7

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

Were there any crash reports? We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash. #Enter ''about:crashes'' in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below. #Copy the '''5''' most recent Report IDs that start with '''bp-''' and then go back to your forum question and paste that into the "Post a Reply" box. [[Image:SubmittedCrashReports-Win7|width=520]] <br><br> Thank you for your help! More information and further troubleshooting steps can be found in the [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]] article.
FredMcD
  • Top 10 Contributor
4220 solutions 58909 answers

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

While you are in safe mode, see if you can get to the password manager.

'''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''''' {web link} While you are in safe mode; Press the '''<Alt>''' or '''<F10>''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Advanced > General.''' Look for and turn off '''Use Hardware Acceleration'''. While you are in safe mode, see if you can get to the password manager.
cor-el
  • Top 10 Contributor
  • Moderator
17409 solutions 157269 answers

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox. Rename the key3.db and signons.sqlite files in the Firefox profile folder. You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost. If that has worked then you can remove the renamed files that are no longer needed. Otherwise you can rename the files to their previous names (signons.sqlite and key3.db).

See:

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history). *https://support.mozilla.org/kb/Private+Browsing *Firefox > Preferences > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use Private Browsing mode" ---- It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox. Rename the key3.db and signons.sqlite files in the Firefox profile folder. You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost. If that has worked then you can remove the renamed files that are no longer needed. Otherwise you can rename the files to their previous names (signons.sqlite and key3.db). See: * "Troubleshooting" in http://kb.mozillazine.org/Password_Manager * http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

Thanks all,

None of the above work. When I access password exceptions, The screen still freezes and Firefox becomes unusable. I am actually able to quit normally though. I just hard quit by default reaction. There are no crash reports. All is well on restart but, still no password actions. Firefox still freezes when I access passwords window. Currently version 33.0a1 (2014-06-10) P.S. I have never saved passwords in firefox. I have only manually entered. I started using "Keychain Services Integration" addon when it was released and never had any trouble until lately. I have always allowed Nightly to auto update so do not know exactly what version the trouble started with.

UPDATE: Just for the heck of it I started my old Firefox on the same profile. Passwords and Keychain Services Integration worked perfectly.

Thanks all, None of the above work. When I access password exceptions, The screen still freezes and Firefox becomes unusable. I am actually able to quit normally though. I just hard quit by default reaction. There are no crash reports. All is well on restart but, still no password actions. Firefox still freezes when I access passwords window. Currently version 33.0a1 (2014-06-10) P.S. I have never saved passwords in firefox. I have only manually entered. I started using "Keychain Services Integration" addon when it was released and never had any trouble until lately. I have always allowed Nightly to auto update so do not know exactly what version the trouble started with. UPDATE: Just for the heck of it I started my old Firefox on the same profile. Passwords and Keychain Services Integration worked perfectly.

Modified by _SDK_

FredMcD
  • Top 10 Contributor
4220 solutions 58909 answers

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is there for. Also, check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder Linux:

  • Ubuntu Unity {web link}
  • Xfce: Applications Menu category sections
  • options depends on the package manager and the desktop environment

Go thru the list. If you find something that you don't know what it is, use a web search.

Troubleshoot Firefox Issues Caused By Malware {web link}

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is there for. Also, check the programs that are on your computer '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder '''Linux:''' * [http://www.freesoftwaremagazine.com/articles/see_all_your_installed_applications_ubuntu_unity Ubuntu Unity]''' {web link} * Xfce: Applications Menu category sections * options depends on the package manager and the desktop environment Go thru the list. If you find something that you don't know what it is, use a web search. '''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware Troubleshoot Firefox Issues Caused By Malware]''''' {web link}
cor-el
  • Top 10 Contributor
  • Moderator
17409 solutions 157269 answers

Does it has any effect if you disable the Keychain Services Integration extension?

Did you try to move or rename the signons.sqlite and key3.db files temporarily to see if that makes it possible to access the password manager?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

Does it has any effect if you disable the Keychain Services Integration extension? Did you try to move or rename the signons.sqlite and key3.db files temporarily to see if that makes it possible to access the password manager? ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

Hi Fred, Thanks for the advice. I've pulled all the add-ons and started in safe mode, no change. As I said before, My older version Firefox with all the add-ons works perfectly using the same profile. The problem started after a new nightly version was installed, a few versions back. Problem is I do not know which one caused the problem. I have it set to auto update.

Hi Fred, Thanks for the advice. I've pulled all the add-ons and started in safe mode, no change. As I said before, My older version Firefox with all the add-ons works perfectly using the same profile. The problem started after a new nightly version was installed, a few versions back. Problem is I do not know which one caused the problem. I have it set to auto update.

Question owner

Hi Cor-el, Thanks for the advice. I created a new, clean, profile and same problem. My old version 25 still works perfectly with the same profile. I reverted back to my old profile, upgraded to v30 of the old Firefox and it still works perfectly with my original profile. It does not work with what is now 33.0a1 (2014-06-11)

Regards

Hi Cor-el, Thanks for the advice. I created a new, clean, profile and same problem. My old version 25 still works perfectly with the same profile. I reverted back to my old profile, upgraded to v30 of the old Firefox and it still works perfectly with my original profile. It does not work with what is now 33.0a1 (2014-06-11) Regards

Question owner

This problem has not been resolved and I will regretfully have to stop using and recommending Firefox if it is not addressed soon.

This problem has not been resolved and I will regretfully have to stop using and recommending Firefox if it is not addressed soon.
cor-el
  • Top 10 Contributor
  • Moderator
17409 solutions 157269 answers

Try to delete the logins.json file in the Firefox profile folder and reset the signon.importedFromSqlite pref on the about:config page to the default value via the right-click context menu to force Firefox to reimport the passwords. from the signons.sqlite file.


Firefox 32 and later builds store the passwords in the logins.json file in the profile folder. You can try to force Firefox to reimport the passwords from the signons.sqlite file.

  • reset the signon.importedFromSqlite pref on the about:config page to the default value via the right-click context menu
  • delete the logins.json file in the Firefox profile folder with Firefox closed

When you restart Firefox then you should have the signon.importedFromSqlite pref with the value set to true.

Try to delete the logins.json file in the Firefox profile folder and reset the signon.importedFromSqlite pref on the <b>about:config</b> page to the default value via the right-click context menu to force Firefox to reimport the passwords. from the signons.sqlite file. ---- Firefox 32 and later builds store the passwords in the logins.json file in the profile folder. You can try to force Firefox to reimport the passwords from the signons.sqlite file. * reset the <b>signon.importedFromSqlite</b> pref on the <b>about:config</b> page to the default value via the right-click context menu * delete the <b>logins.json</b> file in the Firefox profile folder with Firefox closed When you restart Firefox then you should have the signon.importedFromSqlite pref with the value set to true.

Modified by cor-el

Question owner

Thanks for the advice Cor-el but I question why, when I create a brand new profile and have the same problem, I would need to continue to delete files in the old one that is still working perfectly with the FF release version 30.0 ? I have given up messing with it as a waste of time. Someone at Mozilla can be confronted with it later. I just don't have the time. No more Alpha testing for me :-(

Thanks for the advice Cor-el but I question why, when I create a brand new profile and have the same problem, I would need to continue to delete files in the old one that is still working perfectly with the FF release version 30.0 ? I have given up messing with it as a waste of time. Someone at Mozilla can be confronted with it later. I just don't have the time. No more Alpha testing for me :-(

Question owner

This passwords problem was never resolved and I have stopped using Firefox Nightly Alpha as my main browser. Most of the troubles I previously discovered were tended to quite quickly. This one was not and directly affected my ability to continue as a tester within the Alpha program. I'm disappointed and hope the problem will not find its way into the final release. :-(

This passwords problem was never resolved and I have stopped using Firefox Nightly Alpha as my main browser. Most of the troubles I previously discovered were tended to quite quickly. This one was not and directly affected my ability to continue as a tester within the Alpha program. I'm disappointed and hope the problem will not find its way into the final release. :-(
John99 971 solutions 13138 answers

It is probably a good idea to use the Nightly version for testing but always have the Release or another PreRelease maybe the Beta channel Firefox available.

Thanks for the testing but the Nightlies are not considered stable or intended to be used reliably as the working browser. Aurora is a lot more stable I personally use that as my usual day to day browser.

It is probably a good idea to use the Nightly version for testing but always have the Release or another PreRelease maybe the [http://www.mozilla.org/firefox/channel/#beta/beta-desktop Beta channel Firefox] available. * Consider http://kb.mozillazine.org/Testing_pre-release_versions#Installing_multiple_versions Thanks for the testing but the Nightlies are not considered stable or intended to be used reliably as the working browser. [http://www.mozilla.org/firefox/channel/#aurora Aurora] is a lot more stable I personally use that as my usual day to day browser.

Question owner

Thanks John, I loved the excitement of the cutting edge and more often than not found the quality of the cool new features outweighed the occasional problems. I'll just take a break for a while and let other adventurers forge ahead. I still have XBMC Gotham to play with :-) Regards

Thanks John, I loved the excitement of the cutting edge and more often than not found the quality of the cool new features outweighed the occasional problems. I'll just take a break for a while and let other adventurers forge ahead. I still have XBMC Gotham to play with :-) Regards
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 solutions 40083 answers

Chosen Solution

Here's a Bugzilla report about a Keychain Services Integration problem that was related to Firefox Sync back in 2011. https://bugzilla.mozilla.org/show_bug.cgi?id=642785

That is the only Bugzilla report I found regarding Keychain Services Integration.

_SDK_, I suggest that you file a Bugzilla report about your findings. That is one of the "responsibilities" of testing Nightly's - reporting the "bugs" you find so that the developers are aware of problems like this. https://bugzilla.mozilla.org/

Here's a Bugzilla report about a Keychain Services Integration problem that was related to Firefox Sync back in 2011. https://bugzilla.mozilla.org/show_bug.cgi?id=642785 That is the only Bugzilla report I found regarding Keychain Services Integration. _SDK_, I suggest that you file a Bugzilla report about your findings. That is one of the "responsibilities" of testing Nightly's - reporting the "bugs" you find so that the developers are aware of problems like this. https://bugzilla.mozilla.org/

Question owner

Thanks to the-edmeister... Foolish me ! I actually thought I was reporting. Ha! Also though I realized the problem is in the Nightly version itself. A clean, fresh copy w/ a new profile has the same problem. Key chain integration (and passwords) works as intended in the released V30.0. Regards.

Thanks to the-edmeister... Foolish me ! I actually thought I was reporting. Ha! Also though I realized the problem is in the Nightly version itself. A clean, fresh copy w/ a new profile has the same problem. Key chain integration (and passwords) works as intended in the released V30.0. Regards.

Modified by _SDK_

cor-el
  • Top 10 Contributor
  • Moderator
17409 solutions 157269 answers

Could be caused by the recent change about where Firefox 32 and later store the names and passwords.

Firefox 32 and later builds store the passwords in the logins.json file in the profile folder and no longer use the signons.sqlite file.

You can try to force Firefox to reimport the passwords from the signons.sqlite file.

  • reset the signon.importedFromSqlite pref on the about:config page to the default value via the right-click context menu
  • delete the logins.json file in the Firefox profile folder with Firefox closed
Could be caused by the recent change about where Firefox 32 and later store the names and passwords. Firefox 32 and later builds store the passwords in the logins.json file in the profile folder and no longer use the signons.sqlite file. You can try to force Firefox to reimport the passwords from the signons.sqlite file. * reset the <b>signon.importedFromSqlite</b> pref on the <b>about:config</b> page to the default value via the right-click context menu * delete the <b>logins.json</b> file in the Firefox profile folder with Firefox closed