X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

high CPU usage

Posted

after updating to firefox 29 and then 29.0.1, the cpu usage that firefox are using are insane,

it ranges between 50%-100% cpu usage.

and it happens even on normal non flash tab,

besides even if the site is using flash, i am using flash block and adblock plus,

so anykind of flash material wont play or uses cpu.

please fix this ASAP, because firefox has now gone from useable to resource hog,

oh and i don't like the new look, because firefox has become more similar to chrome on User interface,

and i don't use chrome, because i don't like the UI, and now firefox tried to be chrome twin ?

i think that's all, thanks in advance.

edit : fixed some typo

after updating to firefox 29 and then 29.0.1, the cpu usage that firefox are using are insane, it ranges between 50%-100% cpu usage. and it happens even on normal non flash tab, besides even if the site is using flash, i am using flash block and adblock plus, so anykind of flash material wont play or uses cpu. please fix this ASAP, because firefox has now gone from useable to resource hog, oh and i don't like the new look, because firefox has become more similar to chrome on User interface, and i don't use chrome, because i don't like the UI, and now firefox tried to be chrome twin ? i think that's all, thanks in advance. edit : fixed some typo

Modified by DM789

Chosen solution

i agree with what you are suggesting,

but you might want to simplify your suggestion,

because at first its clear, but from the middle it became too complicated for average user to understand what you are trying to say.

and i kinda confused by your reply, but it is probably because i have a bad stomach ache (something i eat caused it), and can't think straight.

so should i mark it as solved ? or you would do it and then do what you wanna do with this thread ?

oh btw, the firefox ram usage is kinda high with only 2 tab open, is that normal or not, btw the firefox RAM usage is 310KB, with only the gmail and this tab opened.


Comment from a forum moderator ~J99 I will mark this post as the solution to the thread.

Anyone with similar problems

  1. Please see my summary comment here
  2. Use this special link if you need to start your own question

P.S.

  • Look at the first page for posts answering the part of the question relating to Firefox appearance
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 12.0 r0
  • Foxit Reader Plug-In For Firefox and Netscape
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 29.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
  • Support URL: https://support.mozilla.org/1/firefox/29.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AutoProxy 0.4b2.2013051811 (autoproxy@autoproxy.org)
  • Flashblock 1.5.17 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Greasemonkey 1.15 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • IDM CC 7.3.72 (mozilla_cc@internetdownloadmanager.com)
  • Magrent 0.4.2 (jid1-9tZMAIdeuiEjHg@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AMD Steady Video 2.0 (steadyvideo@amd.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6819
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 12-6-2013
  • driverDate2:
  • driverVersion: 13.251.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7800 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.search.update: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140506152807
  • browser.startup.homepage: about:newtab
  • browser.startup.homepage_override.buildID: 20140506152807
  • browser.startup.homepage_override.mstone: 29.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 29.0.1
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1401459609
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1399467808

Misc

  • User JS: No
  • Accessibility: No
Moses
  • Top 25 Contributor
  • Moderator
444 solutions 3555 answers

after updating to firefox 29 and then 29.0.1, the cpu usage that firefox are using are insane,

 it ranges between 50%-100% cpu usage

Try to follow the steps listed below to see if this fixes the high CPU usage

 oh and i don't like the new look, because firefox has become more similar to chrome on User interface,

Here are a few suggestions for restoring the old design. I hope you’ll find one that works for you:

after updating to firefox 29 and then 29.0.1, the cpu usage that firefox are using are insane, it ranges between 50%-100% cpu usage Try to follow the steps listed below to see if this fixes the high CPU usage *https://support.mozilla.org/kb/firefox-uses-too-much-memory-ram oh and i don't like the new look, because firefox has become more similar to chrome on User interface, Here are a few suggestions for restoring the old design. I hope you’ll find one that works for you: *Use the [https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ Classic Theme Restorer] to bring back the old design. Learn more here: [[How to make the new Firefox look like the old Firefox]] *Use the [https://addons.mozilla.org/en-US/firefox/addon/the-addon-bar/ Add-on Bar Restored] to bring back the add-on bar. Learn more here: [[What happened to the Add-on Bar?]]

Question owner

thanks for the classic theme restorer addons.

and the uses too much ram, doesn't have anything to do with my issue,

mine is CPU usage are too high,

besides right now i have disabled all of the plugins except flash and java.

to make it easier : 1. enabling and disabling hardware acceleration doesn't help 2. i only use basic plugins, and this plugins have been in use for a long time, and i never had high cpu usage. 3. this cpu usage only started to happens after updating to 29 and then later 29.0.1, it doesn't happens on previous version.

i think that's all related to the high cpu usage, and remember its high CPU usage and not high RAM usage, well the RAM usage is kinda high for my liking, but its not leaking RAM.

thanks for the classic theme restorer addons. and the uses too much ram, doesn't have anything to do with my issue, mine is CPU usage are too high, besides right now i have disabled all of the plugins except flash and java. to make it easier : 1. enabling and disabling hardware acceleration doesn't help 2. i only use basic plugins, and this plugins have been in use for a long time, and i never had high cpu usage. 3. this cpu usage only started to happens after updating to 29 and then later 29.0.1, it doesn't happens on previous version. i think that's all related to the high cpu usage, and remember its high CPU usage and not high RAM usage, well the RAM usage is kinda high for my liking, but its not leaking RAM.
Moses
  • Top 25 Contributor
  • Moderator
444 solutions 3555 answers

Looks like I gave you the wrong link. Here's the correct one. Please try the fixes there to see if it resolves your issue

Try disabling Hardware Acceleration.

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.


Looks like I gave you the wrong link. Here's the correct one. Please try the fixes there to see if it resolves your issue *https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix Try disabling Hardware Acceleration. <br> #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. ----

Helpful Reply

i doesn't use any themes, except that newly recommended classic restorer, but i think that's an addon.

and the extension that i use are the same extension that i use on the previous version, i haven't use any new extension, and the extension itself are only : 1. adblock plus. 2. flashblock 3. grease monkey (rarely used) 4. IDM CC 5. Magrent 6. auto proxy

and just now i have disabled hardware acceleration for flash, but i don't know if it will help, since i rarely use youtube or any kind of flash, that's why i use flash block, to block all kind of flash in all sites that i visited.

and like i said, this high cpu usage started after updating to 29 & 29.0.1,

before 29 & 29.0.1, i don't have this high cpu usage issue.

and let me make it clear, my extension and plugins are the same like on previous version, and the only thing changes are only the firefox version, and the newly installed classic restorer addons.

so by logic, the cause of the issue is because of something inside firefox 29 & 29.0.1.

thanks for trying to help, but i suggest to look internally inside firefox 29, instead of suggesting user to disable things that were proven normal on previous firefox.

i doesn't use any themes, except that newly recommended classic restorer, but i think that's an addon. and the extension that i use are the same extension that i use on the previous version, i haven't use any new extension, and the extension itself are only : 1. adblock plus. 2. flashblock 3. grease monkey (rarely used) 4. IDM CC 5. Magrent 6. auto proxy and just now i have disabled hardware acceleration for flash, but i don't know if it will help, since i rarely use youtube or any kind of flash, that's why i use flash block, to block all kind of flash in all sites that i visited. and like i said, this high cpu usage started after updating to 29 & 29.0.1, before 29 & 29.0.1, i don't have this high cpu usage issue. and let me make it clear, my extension and plugins are the same like on previous version, and the only thing changes are only the firefox version, and the newly installed classic restorer addons. so by logic, the cause of the issue is because of something inside firefox 29 & 29.0.1. thanks for trying to help, but i suggest to look internally inside firefox 29, instead of suggesting user to disable things that were proven normal on previous firefox.
jrh_engineering 0 solutions 16 answers

Helpful Reply

I turned off hardware acceleration for Firefox as well as for Flash. After restarting Firefox, the problem went away for a few hours, but then came back. Next I restarted Firefox in safe mode and had no high CPU usage. Now I think it is an addon, so I restart Firefox normally and plan to shut off each addon one at a time until the problem goes away again. However, now I cannot re-create the problem. When I restart Firefox in normal mode, I restore the previous session because it seems that some web pages generate higher CPU usage than others. As it turns out, for me, the problem is intermittent. This is a big problem for Firefox users, because someone tries a fix, and it seems to work- only to return the next day. Now the user is ashamed to admit they still have a problem, or the problem is dubbed "Solved" and no-one is listening anymore. So, my input to this issue is just because you think you have a fix, please don't close the issue until you have seen Firefox running correctly for several days with moderate usage. I keep my Task Manager open all the time while using Firefox now to monitor it's performance.

By the way, I use several computers in my house. All computers running on Windows XP have the problem. All computers running Ubuntu Linux do not have a problem. Perhaps there is something there for comparison.

I turned off hardware acceleration for Firefox as well as for Flash. After restarting Firefox, the problem went away for a few hours, but then came back. Next I restarted Firefox in safe mode and had no high CPU usage. Now I think it is an addon, so I restart Firefox normally and plan to shut off each addon one at a time until the problem goes away again. However, now I cannot re-create the problem. When I restart Firefox in normal mode, I restore the previous session because it seems that some web pages generate higher CPU usage than others. As it turns out, for me, the problem is intermittent. This is a big problem for Firefox users, because someone tries a fix, and it seems to work- only to return the next day. Now the user is ashamed to admit they still have a problem, or the problem is dubbed "Solved" and no-one is listening anymore. So, my input to this issue is just because you think you have a fix, please don't close the issue until you have seen Firefox running correctly for several days with moderate usage. I keep my Task Manager open all the time while using Firefox now to monitor it's performance. By the way, I use several computers in my house. All computers running on Windows XP have the problem. All computers running Ubuntu Linux do not have a problem. Perhaps there is something there for comparison.
Moses
  • Top 25 Contributor
  • Moderator
444 solutions 3555 answers

We haven't closed your thread at all. Others can still comment and offer solutions. You, as the OP, can undo any marked solutions in case the problem isn't solved. Doing so will put your question back in queue. Also, you'll know when its closed when me or another Moderator "locks" the thread and when you see this screen: (Note: your thread isn't closed. I just temporarily closed it for illustration purposes) http://i.imgur.com/7ItSoyQ.png


I know this is a frustrating issue and you feel like just ripping your hairs out but I've escalated this thread so that way someone from the full-time professional SUMO HelpDesk team can get back to you and provide you more information than I know. Please wait 24-72 hours for a response

We haven't closed your thread at all. Others can still comment and offer solutions. You, as the OP, can undo any marked solutions in case the problem isn't solved. Doing so will put your question back in queue. Also, you'll know when its closed when me or another Moderator "locks" the thread and when you see this screen: (Note: your thread isn't closed. I just temporarily closed it for illustration purposes) http://i.imgur.com/7ItSoyQ.png ---- I know this is a frustrating issue and you feel like just ripping your hairs out but I've escalated this thread so that way someone from the full-time professional SUMO HelpDesk team can get back to you and provide you more information than I know. Please wait 24-72 hours for a response

Modified by Moses

jrh_engineering 0 solutions 16 answers

Here is my task manager with 5 instances of Firefox running with a total of 22 tabs open. This is with Windows XP service pack 3 and a Pentium 4 processor. I have the following extensions: Adblock Plus 2.6 Easy Youtube Video Downloader 6.8 McAfee SiteAdvisor 3.7.0 NewTabURL 2.2.3 WOT 20131118 YouTube Auto Replay 2.88 Zoom Page 10.4

Here is my task manager with 5 instances of Firefox running with a total of 22 tabs open. This is with Windows XP service pack 3 and a Pentium 4 processor. I have the following extensions: Adblock Plus 2.6 Easy Youtube Video Downloader 6.8 McAfee SiteAdvisor 3.7.0 NewTabURL 2.2.3 WOT 20131118 YouTube Auto Replay 2.88 Zoom Page 10.4
jrh_engineering 0 solutions 16 answers

Here is my CPU usage when trying to post a reply on this forum:

Here is my CPU usage when trying to post a reply on this forum:
jrh_engineering 0 solutions 16 answers

And finally, after browsing for a while at Amazon, my CPU is back up to 99% again. Ignore the memory usage, because I closed several tabs to see if this would fix the issue. However, watching Task Manager it is clear that the memory usage continues to climb as the CPU usage goes up.

Now I will restart Firefox and restore this session...

As expected, my CPU usage is down to 3% and memory is down to 330,000K- even as I am typing into this response box. It does, however, jump to 20% whenever I mouse over a hyperlink. I would call it a performance feature if Firefox would pre-fetch page information from a link, but once the information is pre-fetched, the CPU cycles should go down again. However, this does not happen, and as long as my mouse pointer is hovering over a hyperlink (pointer turns into a hand), my Firefox CPU percent bounces from 17% to 27%.

And finally, after browsing for a while at Amazon, my CPU is back up to 99% again. Ignore the memory usage, because I closed several tabs to see if this would fix the issue. However, watching Task Manager it is clear that the memory usage continues to climb as the CPU usage goes up. Now I will restart Firefox and restore this session... As expected, my CPU usage is down to 3% and memory is down to 330,000K- even as I am typing into this response box. It does, however, jump to 20% whenever I mouse over a hyperlink. I would call it a performance feature if Firefox would pre-fetch page information from a link, but once the information is pre-fetched, the CPU cycles should go down again. However, this does not happen, and as long as my mouse pointer is hovering over a hyperlink (pointer turns into a hand), my Firefox CPU percent bounces from 17% to 27%.

Modified by jrh_engineering

Question owner

the issue still exist even now, same like jrh_engineering,

the reason i didn't reply is because the mods went silent after my last reply,

did one of the mods marked my issue as solved ?

if so, why ?

did you guys expecting me to reply daily saying that i still got the issue ?

and if i didn't do that the issue will be marked as solved ?

btw my previous statement still stand, the issue started on firefox 29 and still exist on 29.0.1,

so by logic, the issue isn't caused by any of the existing addons or plugins, because not a single one of my addons or plugins changes.

the issue still exist even now, same like jrh_engineering, the reason i didn't reply is because the mods went silent after my last reply, did one of the mods marked my issue as solved ? if so, why ? did you guys expecting me to reply daily saying that i still got the issue ? and if i didn't do that the issue will be marked as solved ? btw my previous statement still stand, the issue started on firefox 29 and still exist on 29.0.1, so by logic, the issue isn't caused by any of the existing addons or plugins, because not a single one of my addons or plugins changes.
cor-el
  • Top 10 Contributor
  • Moderator
15579 solutions 141067 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

ehem, not to undermind you,

but i've already checked all the extension that i got,

my list of extension are simple lists, that kinda like a must have list.

my extension list : 1. Ad block plus 2. Flash block 3. Auto Proxy 4. Grease Monkey (currently off, because don't need to use it) 5. Magrent (for converting magnet link into torrent) 6. IDM CC (Internet Download Manager Extension).

and are you trying to tell me, that this popular extension that doesn't cause high cpu usage in firefox 28, to be starting causing high cpu usage in firefox 29 ?

and about themes, i do not use themes,

and i just newly started using classic firefox, when i said i hate the new look, and then moses suggested using classic firefox, and i love it, but that is newly added, and before i use classic firefox, the issue already existed.

the issue is now not that severe, but the chances of it randomly using 50-100% cpu is around 50%, not like before, before i do what moses linked to me, the high cpu usage happens all the time.

so things to be checked : 1. my extension are not to blame 2. my profile is not corrupt 3. this issue started directly after updating to firefox 29 4. my extension are the same, with the addition of classic firefox, since firefox 29 changes the UI, into that abomination UI.

and look i'm a former software engineer, so i know how this thing works, when new issue came up, after a new version is out, its usually because the new version had bugs.

i am not a software engineer anymore, because i had to quit being software engineer because of medical reason.

just my 2 cent, if you still insist on me disabling things, then i guess firefox is beyond hope.

ehem, not to undermind you, but i've already checked all the extension that i got, my list of extension are simple lists, that kinda like a must have list. my extension list : 1. Ad block plus 2. Flash block 3. Auto Proxy 4. Grease Monkey (currently off, because don't need to use it) 5. Magrent (for converting magnet link into torrent) 6. IDM CC (Internet Download Manager Extension). and are you trying to tell me, that this popular extension that doesn't cause high cpu usage in firefox 28, to be starting causing high cpu usage in firefox 29 ? and about themes, i do not use themes, and i just newly started using classic firefox, when i said i hate the new look, and then moses suggested using classic firefox, and i love it, but that is newly added, and before i use classic firefox, the issue already existed. the issue is now not that severe, but the chances of it randomly using 50-100% cpu is around 50%, not like before, before i do what moses linked to me, the high cpu usage happens all the time. so things to be checked : 1. my extension are not to blame 2. my profile is not corrupt 3. this issue started directly after updating to firefox 29 4. my extension are the same, with the addition of classic firefox, since firefox 29 changes the UI, into that abomination UI. and look i'm a former software engineer, so i know how this thing works, when new issue came up, after a new version is out, its usually because the new version had bugs. i am not a software engineer anymore, because i had to quit being software engineer because of medical reason. just my 2 cent, if you still insist on me disabling things, then i guess firefox is beyond hope.
jrh_engineering 0 solutions 16 answers

I will restart in safe mode and see if I can duplicate the problem. However, if I don't see a problem, it doesn't exactly prove that it is an extension, because just restarting Firefox causes the problem to go away. It can take an hour to a day to get it to fail again. I trust that I have the same problem as DM789. I am also a software programmer of many years. Perhaps together we can give Mozilla some good feedback to solve this issue. Chrome is no option for me as I hate it's UI and IE is a virus as far as I am concerned.

I will restart in safe mode and see if I can duplicate the problem. However, if I don't see a problem, it doesn't exactly prove that it is an extension, because just restarting Firefox causes the problem to go away. It can take an hour to a day to get it to fail again. I trust that I have the same problem as DM789. I am also a software programmer of many years. Perhaps together we can give Mozilla some good feedback to solve this issue. Chrome is no option for me as I hate it's UI and IE is a virus as far as I am concerned.
shape5 1 solutions 21 answers

i'm having the same problem. i have been trying to solve this for a couple weeks, tried all the suggestions here that i wasn't already doing:

I thought that NoScript did the trick initially (was already using Flashblock & AdBlock Plus), but then after using Pinterest.com again (had stopped for a while when the CPU went down) then the CPU started going up to 100-150%. even after closing Pinterest it still remains just as high though. It seems to happen if i load a board with tons of images on it. I'm also just starting to use the browser (switching from Safari) so I have a fresh profile. I'm also on Lion (10.7.5), am going to upgrade to Mountain Lion, but when i had this type of problem with Safari on Snow Leopard a couple yrs back, i thought that upgrading to Lion would solve the problem and it didn't. (and No i can't upgrade to Mavericks yet for compatibility reasons with 3rd party software).

I posted a response in this help thread, but then it was archived shortly after:

i'm having the same problem. i have been trying to solve this for a couple weeks, tried all the suggestions here that i wasn't already doing: * https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix * "Using fewer tabs" - well, obviously this would do the trick. ideally just close all tabs :) I thought that NoScript did the trick initially (was already using Flashblock & AdBlock Plus), but then after using Pinterest.com again (had stopped for a while when the CPU went down) then the CPU started going up to 100-150%. even after closing Pinterest it still remains just as high though. It seems to happen if i load a board with tons of images on it. I'm also just starting to use the browser (switching from Safari) so I have a fresh profile. I'm also on Lion (10.7.5), am going to upgrade to Mountain Lion, but when i had this type of problem with Safari on Snow Leopard a couple yrs back, i thought that upgrading to Lion would solve the problem and it didn't. (and No i can't upgrade to Mavericks yet for compatibility reasons with 3rd party software). I posted a response in this help thread, but then it was archived shortly after: *[https://support.mozilla.org/en-US/questions/979518?esab=a&s=&r=2&as=s Firefox is eating up between 90% CPU usage to %230 CPU usage]

Modified by shape5

katep99 0 solutions 16 answers

I have this problem also I did all the fixes listed here and got nothing fixed so I did a full reinstall of my pc and now I am still having the problem if I have plug ins running or zero plug ins running I have noticed it seems to happen more when I am watching videos on media players and since the reinstall its worse than ever as before it was just memory being used till the pc locked and the only option was to force close it in task manager but now its the cpu also jumping up over 70 or 80

I have this problem also I did all the fixes listed here and got nothing fixed so I did a full reinstall of my pc and now I am still having the problem if I have plug ins running or zero plug ins running I have noticed it seems to happen more when I am watching videos on media players and since the reinstall its worse than ever as before it was just memory being used till the pc locked and the only option was to force close it in task manager but now its the cpu also jumping up over 70 or 80
shape5 1 solutions 21 answers

i have been testing the Nightly versions (now 33.0a1) and the CPU% has been much lower. with the same pages loaded, same add-ons, same prefs, everything. after launching and all pages finish loading the Nightly runs at around 25% CPU vs. about 75% for FF 30.

i have been testing the Nightly versions (now 33.0a1) and the CPU% has been much lower. with the same pages loaded, same add-ons, same prefs, everything. after launching and all pages finish loading the Nightly runs at around 25% CPU vs. about 75% for FF 30.
katep99 0 solutions 16 answers

For me even with one page open it happens and I have to force close with task manager

I have noted it is worse at certain times of the day it can go a full 2 hours at times and at other go after 20 mins and it's normally when I have videos in vlc or media player classic going I have tried everything I updated my plugins they are all up to date I disable all my add ons and then put them back on one by one still no help I even read about a problem with adblock so shut that down and used noscript but so far nothing works

For me even with one page open it happens and I have to force close with task manager I have noted it is worse at certain times of the day it can go a full 2 hours at times and at other go after 20 mins and it's normally when I have videos in vlc or media player classic going I have tried everything I updated my plugins they are all up to date I disable all my add ons and then put them back on one by one still no help I even read about a problem with adblock so shut that down and used noscript but so far nothing works
katep99 0 solutions 16 answers

ok I just had the cpu and memory going to lock up and noted I had a process called ffmpeg.exe that was not there at any other time

now I shut that down the cpu and memory droped between 0 and 10 for cpu and 430.000k memory

what is ffmpeg.exe and it the problem

ok I just had the cpu and memory going to lock up and noted I had a process called ffmpeg.exe that was not there at any other time now I shut that down the cpu and memory droped between 0 and 10 for cpu and 430.000k memory what is ffmpeg.exe and it the problem
gedit 0 solutions 3 answers

I have the exact same problem and I am getting sick and tired of FF updates that only repeat the problem and resetting my previous configuration. So I have to go to options and make selections of how I want it to behave... But in my case the process that chocks CPU is Firefox itself... I have tried Reset, safe mode, no adds-on, you name it.. So I've gone back to iexplorer/

Another issue (i guess because it resets my settings), is that my privacy is gone out the window. Sites are tracking other sites I am visiting, and they post ads related to my previous searches such as on Amazon. This is outrageous...

I have the exact same problem and I am getting sick and tired of FF updates that only repeat the problem and resetting my previous configuration. So I have to go to options and make selections of how I want it to behave... But in my case the process that chocks CPU is Firefox itself... I have tried Reset, safe mode, no adds-on, you name it.. So I've gone back to iexplorer/ Another issue (i guess because it resets my settings), is that my privacy is gone out the window. Sites are tracking other sites I am visiting, and they post ads related to my previous searches such as on Amazon. This is outrageous...
katep99 0 solutions 16 answers

are firefox even working on this as I had to force close firefox 8 times in 3 hours yesterday and its impossible to have video on while surfing be it flash videos online like youtube or in my vlc or media player classic

or is there away to down grade as this only started with the last new version

are firefox even working on this as I had to force close firefox 8 times in 3 hours yesterday and its impossible to have video on while surfing be it flash videos online like youtube or in my vlc or media player classic or is there away to down grade as this only started with the last new version