Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Unlink this device" hangs when attempting to set up new sync

  • 9 replies
  • 6 have this problem
  • Last reply by guigs

more options

Firefox's old sync was clunky but extremely useful. I can't get the new sync to work at all, which is not at all useful. Basically, I've gone to Settings > Options > Sync > Unlink this device. That displays a very large dialog box with just one very short statement on it which reads "Determining your account status ..." Apparently, that task takes a very long time indeed because I've let it sit there for two days, and it's still determining my account status. I can click OK or Cancel, and the dialog box will go away. Then, if I go back to Settings > Options > Sync, it doesn't even give me a chance to tell it I want to unlink. Instead it goes directly to the dialog box stating that it's still determining my account status.

I would very much like to be able to sync Firefox across a couple of computers. Is there any way to do that?

All Replies (9)

more options

hello larry, is this problem still occurring? unfortunately there has been a downtime of the sync service just in the time where you had posted your question...

more options

I just tried, and all is the same. Still sticks at "Determining your account status..."

more options

Larry, are there any errors in the console if you do this?

  • Quit Firefox
  • Launch Firefox
  • Open the Browser Console
  • Open Sync preferences

If so, please copy and paste them here.

more options

Here's what I got with the browser console:

XUL box for p element contained an inline #text child, forcing all its children to be wrapped in a block. preferences.xml:711 1401744184488 Sync.Tracker.Clients WARN Changed IDs file clients contains non-object value.

1401744184493 Sync.Tracker.Bookmarks WARN Changed IDs file bookmarks contains non-object value.

1401744184496 Sync.Tracker.Forms WARN Changed IDs file forms contains non-object value.

1401744184499 Sync.Tracker.History WARN Changed IDs file history contains non-object value.

1401744184502 Sync.Tracker.Passwords WARN Changed IDs file passwords contains non-object value.

1401744184509 Sync.Tracker.Addons WARN Changed IDs file addons contains non-object value.

this._storage is null nsLoginManager.js:323 [Exception... "[JavaScript Error: "this._storage is null" {file: "resource://gre/components/nsLoginManager.js" line: 323}]'[JavaScript Error: "this._storage is null" {file: "resource://gre/components/nsLoginManager.js" line: 323}]' when calling method: [nsILoginManager::findLogins]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: resource://services-sync/identity.js :: _getLogins :: line 434" data: yes] preferences.xml:738 [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIJumpListBuilder.addListToBuild]" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: resource://app/modules/WindowsJumpLists.jsm :: WTBJL__buildTasks :: line 288" data: no]

more options

It looks like your password database isn't being accessed correctly.

Larry, are you using an add-on that saves your passwords somewhere else (Lastpass, 1Password, Keychain Services Integration, etc.)? about:support has a "Copy text to clipboard" button you can use if you just want to dump it here.

Do you have a master password set?

more options

I use RoboForm. It does have a master password set, although RoboForm allows you to save passwords without protecting them with the master password, so I rarely use it. I don't believe I've ever used the Firefox password "feature," nor would I ever want to. I'd just as soon disable it.

more options

I'm pretty confident in pointing the finger at RoboForm. It's not correctly implementing the nsILoginManagerStorage interface, so Sync isn't able to determine if Sync is set up.

You should be able to work around this by disabling RoboForm, setting up Sync, then re-enabling it.

I suggest you disable password sync if you have RoboForm enabled, because (a) it will probably fail for the same reason, and (b) RoboForm has its own password sync functionality.

more options

Unfortunately, I've tried disabling RoboForm and restarting Firefox. That made no difference at all. I'm seriously beginning to wonder if its all worth it. I mostly keep Firefox around because of Firebug and its utility in Web development. As for actual browsing, I've just finished doing extensive testing on multiple machines and multiple browsers. Firefox is soooooooooooooo much slower than Chrome (20% or more), that it's virutally useless for browsing. Now that it's got so many new features, it may not be worth it.

more options

One of your add ons may be causing this, if you disable add on syncing, does the issue continue?