Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Still getting" Firefox already running error" with latest update (continuation of /questions/998822)

  • 7 replies
  • 5 have this problem
  • 231 views
  • Last reply by John99

more options

I'm using Windows 8.1 and was initially having trouble with Firefox after the update to 29. Well I thought the update to 29.1 would resolve my problem. At first it appeared to have done so but I started getting the errors again. I don't know what I haven't tried but nothing has worked so far. I even did the popular parent.lock delete suggestion. This IE11 is killing me, HELP!

Modified by Moses

Chosen solution

There is still a known issue. When you post questions it helps to include troubleshooting information. Could you visit the troubleshooting page and paste your troubleshooting information into your next reply please.

Key in about:support into the address bar and hit Return to get the information there is a button [copy text to clipboard] Then Ctrl+ V should paste into an open reply. (You could edit out print details to savespace).


Currently Firefox sometimes has an issue with not closing down properly if you have set Firefox to clear History at closedown. This is a known problem mainly seen in Firefox 29 and people are working on trying to fix that, although the Fix is unlikely to be before Fx30.

The workaround is to not set Firefox to clear History when it shuts down, instead set it to remember History.

  • Use New Button -> Preferences -> |Privacy| History Firefox will: [Remember History v]
  • Note you should be able to use a private browsing window if that helps..
    You may need to close that window before exiting from Firefox
    Private Browsing - Use Firefox without saving history ­

Please try following the advice and post back with how you get on.

Please say whether or not you have Firefox set to clear History at shutdown ?
(Full troubleshooting information was not provided when the question was asked)

Read this answer in context 👍 1

All Replies (7)

more options

Chosen Solution

There is still a known issue. When you post questions it helps to include troubleshooting information. Could you visit the troubleshooting page and paste your troubleshooting information into your next reply please.

Key in about:support into the address bar and hit Return to get the information there is a button [copy text to clipboard] Then Ctrl+ V should paste into an open reply. (You could edit out print details to savespace).


Currently Firefox sometimes has an issue with not closing down properly if you have set Firefox to clear History at closedown. This is a known problem mainly seen in Firefox 29 and people are working on trying to fix that, although the Fix is unlikely to be before Fx30.

The workaround is to not set Firefox to clear History when it shuts down, instead set it to remember History.

  • Use New Button -> Preferences -> |Privacy| History Firefox will: [Remember History v]
  • Note you should be able to use a private browsing window if that helps..
    You may need to close that window before exiting from Firefox
    Private Browsing - Use Firefox without saving history ­

Please try following the advice and post back with how you get on.

Please say whether or not you have Firefox set to clear History at shutdown ?
(Full troubleshooting information was not provided when the question was asked)

more options

I'm at work now but will try that method as soon as I get home and update of results sometime after. I definitely have Firefox set to clear history when I close it, so I'm extremely interested in giving this a whirl. Thanks

more options

I'm gonna use private browsing as well to relieve the purpose of clearing Firefox upon exit. Thanks again

more options

I'm confident I can say the setting of Firefox to "remember history" has done the trick. There have been NO errors at all since. I don't know if it made a difference but I notice Firefox was by default set to " remember history" on my daughters computer. I commented how she had no problem with Updated Firefox, so I wonder was this the reason. Then again, she's running Windows 7 instead of Windows 8.1. Maybe that played a difference, I don't know. Anyway, things seem to okay with this new setting, thanks again.

more options

Glad it works again thanks for posting back.

I know it is not a fix yet only a workaround, but people are working on trying to get the underlying causes fixed.

more options

I agree with your wording, workaround is more appropriate. A fix is actually up to Firefox.  :>)

more options

UPDATE

Note one potential fix is now in the very recent Firefox Beta 30b8 Initial reports suggest this fixes the issue. (Bug1005487#c38) If you have been suffering from this problem and want a fix now instead of in a few weeks time you may wish to download and install the Beta version of Firefox.

The beta version is effectively a release candidate but is only intended for advanced users or testers. I would be interested to hear feedback from those of you that do test this out.

Beta version download