Firefox hängt oder reagiert nicht mehr

Manchmal bleibt Firefox hängen, antwortet nicht mehr auf Benutzereingaben und scheint auch sonst nichts zu tun. Zusätzlich wird „Keine Rückmeldung“ in der Titelleiste des Fensters angezeigt. Der Mauszeiger ändert sich in ein rotierendes Auslastungssymbol, wenn man ihn über das Firefox-Fenster bewegt. Dieser Artikel beschreibt einige Problemlösungen, abhängig davon, wann Firefox hängen bleibt.

Um Probleme mit hängendem Firefox zu lösen, die in diesem oder einem der genannten Artikel nicht explizit angesprochen werden oder wenn die vorgeschlagenen Lösungen nicht helfen, erhalten Sie hier weitere Hilfestellungen: Allgemeine Fehlersuche.

Hinweis: Das Zurücksetzen von Firefox in seinen Ausgangszustand kann viele Probleme beheben, wobei Sie wichtige Daten vorher sichern können. Ziehen Sie diese Art der Problembehebung in Erwägung, bevor Sie eine langwierige Suche nach der Ursache und der Lösung Ihres Problems beginnen.
Hinweis: Wenn Sie ein Häkchen bei der Einstellung Performanz-Daten senden gesetzt haben, werden Informationen über das Problem an Mozilla gesendet. Das hilft, zukünftige Versionen von Firefox zu verbessern.

Firefox hängt zufällig

Wenn Firefox zufällig und nicht bei einer bestimmten Funktion (z.B. Download einer Datei oder beim Beenden von Firefox) hängen bleibt, dann versuchen Sie die Lösungsvorschläge in diesem Abschnitt.

Anlegen einer neuen Datenbank für Ihre Lesezeichen und Chronik

Wenn die Hänger periodisch auftreten, könnten Sie durch eine beschädigte Datenbank „places.sqlite“ verursacht sein.

Gehen Sie folgendermaßen vor, um eine neue Places-Datenbank zu erstellen:
Warnung: Dadurch werden die Chronik Ihrer besuchten Seiten und die in der letzten Sitzung angelegten Lesezeichen gelöscht.
  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8

    Profilordner öffnen - Fx29 - Linux

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

    Warten Sie, bis Firefox vollständig beendet ist.
  4. Suchen Sie im Profilordner von Firefox die Dateien places.sqlite und places.sqlite-journal und benennen Sie sie in places.sqlite.old bzw. places.sqlite-journal.old um (falls vorhanden).
    • Um eine Datei umzubenennen, klicken Sie mit der rechten Maustaste auf den Namen und wählen aus dem Kontextmenü den Eintrag „umbenennen“ aus.klicken Sie einmal darauf um die Datei auszuwählen und dann ein zweites Mal um den Namen ändern zu können. Fügen Sie dem Dateinamen z.B. .old hinzu.
  5. Anschließend starten Sie Firefox wieder.
    • Wenn Firefox neu geöffnet wird, legt er die gelöschten Dateien wieder an. Ihre Chronik der besuchten Seiten geht dabei verloren, Ihre Lesezeichen werden jedoch automatisch aus der letzten Sicherungskopie importiert.

Schalten Sie die Hardwarebeschleunigung ab

Mit bestimmten Einstellungen von einigen Grafikkarten und deren Treibern kann Firefox hängen bleiben wenn die Hardwarebeschleunigung genutzt wird. Deaktivieren Sie testweise die Hardware-Beschleunigung um zu prüfen, ob das Problem dadurch behoben werden kann.

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie Einstellungen.Klicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Einstellungen.Klicken Sie in der Menüleiste auf das das Menü Firefox und wählen Sie Einstellungen....Klicken Sie oben im Firefox-Fenster auf das Menü Bearbeiten (oder auf die Schaltfläche Firefox, wenn die Menüleiste ausgeblendet ist) und wählen Sie Einstellungen....

    Einstellungen - Fx20 - Win7


    EinstellungenFx4Win7.png


    Einstellungen - Fx20 - WinXP


    Einstellungen_Fx4_Linux


    010897fd58f6e294a60e43bbcf0ffe51-1281982768-69-1.png

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Einstellungen.

    Einstellungen öffnen - Fx29 - Win7



    Einstellungen öffnen - Fx29 - Win8



    Einstellungen öffnen - Fx29 - Linux

  2. Wählen Sie Erweitert und dort den Abschnitt Allgemein.
  3. Entfernen Sie das Häkchen vor: Hardware-Beschleunigung verwenden, wenn verfügbar.
  4. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  5. Starten Sie Firefox so wie immer.

Wenn das Problem nun nicht mehr besteht, war die Hardwarebeschleunigung wahrscheinlich die Ursache. Sie können versuchen, die Grafiktreiber zu aktualisieren um zu prüfen, ob das Problem dann noch immer besteht oder einfach ohne Hardwarebeschleunigung arbeiten, falls das möglich ist.

Probleme mit Plugins beheben

Webseiten, welche Plugins wie Java, Adobe Reader oder Flash verwenden, können Probleme in Firefox verursachen. Ob Plugins Ursache für bestehende Probleme sind und wie Sie diese lösen, beschreibt der Artikel: Fehlerbehebung bei Plugins wie Flash oder Java, um verbreitete Probleme mit Firefox zu lösen.

Löschen doppelt vorhandener Sitzungs-Wiederherstellungsdateien

Firefox kann ausgebremst werden oder hängen bleiben, wenn viele Kopien der für die Sitzungswiederherstellung benötigten Dateien angelegt wurden.

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8

    Profilordner öffnen - Fx29 - Linux

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Suchen Sie nach der Datei sessionstore.js und löschen Sie diese und alle Kopien, wie z.B. sessionstore-1.js, sessionstore-2.js usw.

Ändern Sie die Proxy-Autokonfigurationseinstellungen

Wenn Sie eine Proxy-Autokonfigurationsdatei (PAC) verwenden, kann sich Firefox aufhängen, wenn versucht wird Seiten zu laden, die nicht (mehr) existieren oder die länger nicht geöffnet wurden.
So können Sie feststellen, ob Sie eine Autokonfigurationsdatei verwenden:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie Einstellungen.Klicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Einstellungen.Klicken Sie in der Menüleiste auf das das Menü Firefox und wählen Sie Einstellungen....Klicken Sie oben im Firefox-Fenster auf das Menü Bearbeiten (oder auf die Schaltfläche Firefox, wenn die Menüleiste ausgeblendet ist) und wählen Sie Einstellungen....

    Einstellungen - Fx20 - Win7


    EinstellungenFx4Win7.png


    Einstellungen - Fx20 - WinXP


    Einstellungen_Fx4_Linux


    010897fd58f6e294a60e43bbcf0ffe51-1281982768-69-1.png

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Einstellungen.

    Einstellungen öffnen - Fx29 - Win7



    Einstellungen öffnen - Fx29 - Win8



    Einstellungen öffnen - Fx29 - Linux

  2. Klicken Sie auf Erweitert.
  3. Klicken Sie auf den Tab Netzwerk.
  4. Klicken Sie auf Einstellungen. Der Dialog für Verbindungseinstellungen öffnet sich.
  5. Wenn Automatische Proxy-Konfigurations-URL: angewählt ist, dann verwenden Sie eine Autokonfigurationsdatei. Ändern Sie diese Einstellung nicht, Sie kommen sonst nicht mehr ins Internet! Geben Sie statt dessen diese Informationen zur Problemlösung an Ihren Netzwerkadministrator weiter.
  6. Klicken Sie auf Abbrechen.

Firefox hängt beim Abspielen eines Flash Videos

Lesen Sie dazu den Artikel Flash-Plugin – aktuell halten und Probleme beheben.

Firefox hängt nach längerer Benutzung

Aktualisieren Sie Firefox

Die letzte Version des Browsers enthält Optimierungen der Speicherplatzverwaltung, gerade bei langen Sitzungen, siehe: Firefox auf die letzte Version aktualisieren.

Firefox neu starten

Wenn Firefox sehr lange geöffnet war und dann hängen bleibt, können Sie das Problem evtl. durch einen Neustart lösen.

Wenn Sie Firefox regelmäßig geöffnet lassen, weil Sie später an der gleichen Stelle weiter arbeiten möchten, könnten Sie die Sitzungswiederherstellung von Firefox nutzen. Für weitere Informationen lesen Sie den Artikel Sitzungswiederherstellung konfigurieren.

Firefox hängt beim Laden des ersten Fensters

Beschleunigen der Sitzungswiederherstellung

Wenn Firefox beim Starten viele Tabs laden muss kann es vorkommen, dass Firefox dabei hängen bleibt. Stellen Sie sicher, dass die Option Tabs erst laden, wenn sie angewählt werden im Abschnitt „Tabs“ unter Einstellungen ausgewählt ist, damit nur die Seite im ersten Tab beim Starten geladen wird. Sie können auch versuchen, Tab-Gruppen zu verwenden, so dass nur die Seiten in der sichtbaren Tab-Gruppe geladen werden.

Firefox hängt beim Herunterladen von Dateien oder beim Speichern von Grafiken

Wenn Firefox beim Herunterladen von Dateien oder beim Speichern von Grafiken hängen bleibt, versuchen Sie diese Lösungsansätze:

Download-Chronik löschen

Firefox hängt möglicherweise beim Herunterladen von Dateien, wenn Ihre Download-Chronik zu groß geworden ist. Wie Sie die Download-Chronik löschen können:

  1. Klicken Sie oben im Firefox-Fensterin der Menüleiste auf das Menü Extras und wählen Sie den Eintrag Downloads. Das Download-Fenster öffnet sich.Klicken Sie auf die Download-Schaltfläche fx20 download icon und dort auf Alle Downloads anzeigen. Das Bibliotheks-Fenster wird sich öffnen.
  2. Klicken Sie auf die Schaltfläche Liste leeren. Die Download-Chronik wird damit gelöschtKlicken Sie auf die Schaltfläche Liste leeren, um die Download-Chronik zu löschen.
  3. Laden Sie einige Testdateien herunter, um zu prüfen, ob das Problem verschwunden ist.

Ein anderes Download-Zielverzeichnis wählen

Firefox hängt möglicherweise, wenn das letzte Download-Zielverzeichnis nicht mehr verfügbar ist (z.B. auf einem USB-Stick). Um dieses Problem zu lösen:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie Einstellungen.Klicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Einstellungen.Klicken Sie in der Menüleiste auf das das Menü Firefox und wählen Sie Einstellungen....Klicken Sie oben im Firefox-Fenster auf das Menü Bearbeiten (oder auf die Schaltfläche Firefox, wenn die Menüleiste ausgeblendet ist) und wählen Sie Einstellungen....

    Einstellungen - Fx20 - Win7


    EinstellungenFx4Win7.png


    Einstellungen - Fx20 - WinXP


    Einstellungen_Fx4_Linux


    010897fd58f6e294a60e43bbcf0ffe51-1281982768-69-1.png

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Einstellungen.

    Einstellungen öffnen - Fx29 - Win7



    Einstellungen öffnen - Fx29 - Win8



    Einstellungen öffnen - Fx29 - Linux

  2. Wechseln Sie zum Abschnitt Allgemein.
  3. Wählen Sie im Bereich "Downloads" Alle Dateien in folgendem Ordner abspeichern und klicken Sie auf die Schaltfläche Durchsuchen.
  4. Wählen Sie im sich öffnenden Fenster Ordner suchen das neue Zielverzeichnis für heruntergeladene Dateien aus.
  5. Klicken Sie auf OK, um das Einstellungen-Fenster zu schließenKlicken Sie auf Schließen, um das Einstellungen-Fenster zu schließenSchließen Sie das Einstellungen-Fenster .

Überprüfen Sie, ob das Herunterladen von Dateien oder das Speichern von Grafiken nun möglich ist. Wenn es funktioniert, können Sie zu den Firefox-Einstellungen zurückkehren und, falls Sie dies möchten, die Option Jedes Mal nachfragen, wo eine Datei gespeichert werden soll aktivieren.

Virenprüfung in den Firefox-Einstellungen deaktivieren

Beim Einsatz von einigen Antivirus-Anwendungen kann es vorkommen, dass Firefox hängen bleibt, wenn Dateien beim Download auf Viren überprüft werden. Sie können die Virenprüfung in Firefox wie folgt deaktivieren (dadurch wird ihr Antivirus-Programm nicht abgeschaltet):

  1. Tippen Sie in die Adressleiste about:config und drücken Sie die EingabetasteReturn.

    • Die Warnung „Hier endet möglicherweise die Gewährleistung!“ erscheint beim Aufruf von about:config. Klicken Sie auf Ich werde vorsichtig sein, versprochen!, um fortzufahren.

      about_config_win_fx4 about:config - Linux - Fx18 about_config_mac_fx4

      about:config - Fx29 - Linux about:config - Fx29 - Mac about:config - Fx29 - Win8
  2. Suchen Sie die Einstellung browser.download.manager.scanWhenDone. Klicken Sie nun diesen Eintrag doppelt an um damit dessen Wert auf false zu ändern.

Firefox hängt beim Beenden

Es kann sein, dass Firefox beim Beenden nicht mehr reagiert und im Speicher bleibt, obwohl kein Fenster mehr geöffnet ist. Dies kann Firefox beim nächsten Start Probleme bereiten oder Sie erhalten den „Firefox schließen“-Dialog mit dem Hinweis
Firefox wird bereits ausgeführt, reagiert aber nicht. Um ein neues Fenster zu öffnen, müssen Sie zunächst den vorhandenen Firefox-Prozess schließen oder das System neu starten.
Sie müssen nun zunächst alle Firefox-Prozesse beenden oder einen Systemneustart durchführen, bevor sich Firefox neu öffnen lässt. (Zu anderen Ursachen und Lösungen lesen Sie auch den Artikel Firefox wird bereits ausgeführt aber reagiert nicht.)

Firefox vollständig beenden

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  2. Schließen Sie alle noch offenen Dialoge oder abhängige Fenster, bspw. das Download-Fenster.


Wenn Firefox-Prozesse beim Beenden immer wieder im Speicher hängen bleiben, versuchen Sie diese Lösungsmöglichkeiten:

Untersuchen Sie Ihre Erweiterungen

Problembehaftete Erweiterungen können die Ursache für Hänger sein. Dies können Sie durch Deaktivieren oder Deinstallieren der betreffenden Erweiterung beseitigen. Lesen Sie dazu den Artikel Fehlerbehebung bei Erweiterungen, Themes und Hardware-Beschleunigung für weitere Informationen.

Aktualisieren oder Deaktivieren Sie das Java-Plugin

Manchmal können Java-Applets den Firefox-Prozess nach dem Beenden noch im Speicher halten. Bringen Sie Java auf den neuesten Stand oder aber - falls Sie Java nicht benötigen - deaktivieren Sie das Java-Plugin im Abschnitt „Plugins“ im Add-ons-Manager. Lesen Sie für weitere Informationen dazu den Artikel Das Java-Plugin für interaktive Webinhalte nutzen.

Überprüfen Sie Ihre Internet-Sicherheitssoftware

Bei Verwendung bestimmter Sicherheits-Software gegen Gefahren aus dem Internet (Firewall, Antivirus-Anwendungen) wird berichtet, dass es Probleme auf einigen Systemen gibt. Lesen Sie dazu den Artikel Probleme durch eine Firewall für weitere Informationen.



Basiert auf Informationen des Artikels Firefox hangs (mozillaZine KB)

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: Wawuschel, gk0moz, pollti. Auch Sie können helfen – erfahren Sie, wie.