Allgemeine Fehlersuche

Viele der bekanntesten Firefox-Probleme können mit einem der folgenden Schritte der Fehlersuche gelöst werden.

Standard-Fehlersuche

Wenn Sie ein Problem mit Firefox feststellen, führen Sie Schritt für Schritt die folgenden Anweisungen aus. Führt der jeweilige Schritt nicht zur Lösung des Problems, versuchen Sie den nächsten.


Firefox neu starten

Beenden Sie Firefox vollständig:

Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

Danach starten Sie Ihren Computer neu und rufen Firefox wieder auf.


Cookies löschen und Cache leeren

Viele Probleme beim Laden von Webseiten können durch das Löschen von Cookies und Leeren des Caches gelöst werden:

  1. Klicken Sie oben im Firefox-Fensterin der Menüleiste auf das Menü Extrasdas Menü Extrasdie Schaltfläche Firefox, gehen Sie zum Menü Chronik und wählen Sie Neueste Chronik löschen... und wählen Sie Neueste Chronik löschen....
    Unter Windows XP: Klicken Sie oben im Firefox-Fensterin der Menüleiste auf das Menü Extras und wählen Sie Neueste Chronik löschen....

    Wenn die Firefox-Schaltfläche aktiviert und die Menüleiste ausgeblendet ist: Klicken Sie oben im Firefox-Fensterin der Menüleiste auf die Schaltfläche Firefox, gehen Sie zum Menü Chronik und wählen Sie Neueste Chronik löschen....


    b1c4f16b8b94fddeeacea99fb339b5eb-1261827677-801-1.png b1c4f16b8b94fddeeacea99fb339b5eb-1261827772-883-1.png b1c4f16b8b94fddeeacea99fb339b5eb-1261827772-883-2.png Chronik löschen 1 win Fx19 ChronikLöschen1_mac_Fx4 ChronikLöschen1_linux_Fx4

  2. Wählen Sie im Auswahlmenü, in dem Sie den Zeitrahmen festlegen können, den Sie löschen möchten, Alles aus.
  3. Klicken Sie auf den kleinen Pfeil neben Details, um die Liste der zu löschenden Objekte anzeigen zu lassen. Setzen Sie bei folgenden Einträgen ein Häkchen und entfernen Sie es bei den anderen:
    • Cache
    • Cookies

      d3ae3f9253a1d3f53dccef8ab9b98de7-1262958992-506-4.png Allgemeine Fehlersuche Linux 02 8081c0a63e42bf5aff2a9552bfc5de57-1259090115-188-1.png

  4. Klicken Sie auf Jetzt löschen.

Weitere Informationen finden Sie im Artikel Neueste Surf-, Such- und Download-Chronik löschen.


Fehlersuche bei Erweiterungen und Themes

Manchmal können Firefox-Add-ons (Erweiterungen oder Themes) Probleme verursachen. Um herauszufinden, ob Ihr Problem durch ein Add-on verursacht wird, starten Sie Firefox im Abgesicherten Modus:

Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Mit deaktivierten Add-ons neu starten.... Firefox wird neu starten und das Dialogfenster für den Abgesicherten Modus zeigen.

Abgesicherter Modus - WinXP - Fx23 Abgesicherter Modus - Win7 - Fx23 AbgesicherterModus_Fx4_linux AbgesicherterModus_Fx4_mac

Hinweis: Sie können Firefox ebenso im Abgesicherten Modus starten, wenn Sie die Umschalttaste gedrückt halten, während Sie Firefox starten.

Umschalt-Taste + Doppelklick - Win7 - Fx23
die Wahltaste mac-wahltaste gedrückt halten, während Sie Firefox starten.
Firefox beenden, das Terminal aufrufen und folgendes ausführen: firefox -safe-mode
Eventuell müssen Sie das Installationsverzeichnis von Firefox angeben (z.B. /usr/lib/firefox-4 -safe-mode).
So öffnen Sie das Terminal (das auch Shell oder Konsole genannt wird):
  • (Unity wie bei Ubuntu) Öffnen Sie den Schnellstart (Dash-Startseite). Klicken Sie dazu entweder auf das Ubuntu-Symbol im Unity-Startmenü oder betätigen Sie einfach die Taste Windows/Super. Tippen Sie das Wort „terminal“ ein und klicken Sie dann auf das erscheinende Symbol mit dem schwarzen Bildschirm darunter.
  • (GNOME wie bei Fedora, Linux Mint) Öffnen Sie das Menü Anwendungen, wählen Sie Zubehör und dann Terminal.
  • (KDE wie bei Kubuntu, openSUSE, Knoppix) Öffnen Sie den Anwendungen-Starter links unten am Bildschirmrand. Geben Sie im Feld Suchen den Befehl Terminal ein und drücken Sie danach die Eingabetaste.
Klicken Sie in der Titelleiste auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Mit deaktivierten Add-ons neu starten. Firefox startet dann neu im Abgesicherten Modus.
Hinweis: Sie können Firefox auch im Abgesicherten Modus starten, indem Sie Firefox zuvor beenden und die Umschalttaste die Wahltaste mac-wahltaste gedrückt halten, während Sie Firefox starten.
Sie können Firefox ebenso im Abgesicherten Modus starten, wenn Sie Firefox beenden, das Terminal aufrufen und folgendes ausführen: firefox -safe-mode
Eventuell müssen Sie das Installationsverzeichnis von Firefox angeben (z. B. /usr/lib/firefox).
So öffnen Sie das Terminal (das auch Shell oder Konsole genannt wird):
  • (Unity wie bei Ubuntu) Öffnen Sie den Schnellstart (Dash-Startseite). Klicken Sie dazu entweder auf das Ubuntu-Symbol im Unity-Startmenü oder betätigen Sie einfach die Taste Windows/Super. Tippen Sie das Wort „terminal“ ein und klicken Sie dann auf das erscheinende Symbol mit dem schwarzen Bildschirm darunter.
  • (GNOME wie bei Fedora, Linux Mint) Öffnen Sie das Menü Anwendungen, wählen Sie Zubehör und dann Terminal.
  • (KDE wie bei Kubuntu, openSUSE, Knoppix) Öffnen Sie den Anwendungen-Starter links unten am Bildschirmrand. Geben Sie im Feld Suchen den Befehl Terminal ein und drücken Sie danach die Eingabetaste.

  1. Klicken Sie im "Abgesicherter Modus"-Dialog auf Im abgesicherten Modus weiterarbeiten.

    9385902f222717c74060af78014c6b6b-1263035085-519-2.png Allgemeine Fehlersuche Linux 04 9385902f222717c74060af78014c6b6b-1264240792-124-1.png
    ab Firefox 3.6 ::

    9385902f222717c74060af78014c6b6b-1263035085-519-1.png 9385902f222717c74060af78014c6b6b-1264241465-934-1.png ca2d4a16c5806bded84fb895dd9604e9-1253555181-530-2.png
    bis Firefox 3.5


  2. Überprüfen Sie, ob Ihr Problem weiterhin besteht.

Sollte Ihr Problem im Abgesicherten Modus nicht mehr auftreten, ist wahrscheinlich eine Erweiterung oder ein Theme für das Problem verantwortlich. Für weitere Informationen zur Fehlersuche bei Erweiterungen und Themes und wie Sie herausfinden, welches Add-on genau das Problem verursacht, lesen Sie den Artikel Fehlerbehebung bei Erweiterungen, Themes und Hardware-Beschleunigung.


Einstellungen zurücksetzen

Wenn das Problem im Abgesicherten Modus nicht besteht, aber auch nicht durch das Deaktivieren von Add-ons beseitigt werden konnte, müssen Sie eventuell Veränderungen zurücksetzen, die Sie in den Firefox-Einstellungen vorgenommen haben:

Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Mit deaktivierten Add-ons neu starten.... Firefox wird neu starten und das Dialogfenster für den Abgesicherten Modus zeigen.

Abgesicherter Modus - WinXP - Fx23 Abgesicherter Modus - Win7 - Fx23 AbgesicherterModus_Fx4_linux AbgesicherterModus_Fx4_mac

Hinweis: Sie können Firefox ebenso im Abgesicherten Modus starten, wenn Sie die Umschalttaste gedrückt halten, während Sie Firefox starten.

Umschalt-Taste + Doppelklick - Win7 - Fx23
die Wahltaste mac-wahltaste gedrückt halten, während Sie Firefox starten.
Firefox beenden, das Terminal aufrufen und folgendes ausführen: firefox -safe-mode
Eventuell müssen Sie das Installationsverzeichnis von Firefox angeben (z.B. /usr/lib/firefox-4 -safe-mode).
So öffnen Sie das Terminal (das auch Shell oder Konsole genannt wird):
  • (Unity wie bei Ubuntu) Öffnen Sie den Schnellstart (Dash-Startseite). Klicken Sie dazu entweder auf das Ubuntu-Symbol im Unity-Startmenü oder betätigen Sie einfach die Taste Windows/Super. Tippen Sie das Wort „terminal“ ein und klicken Sie dann auf das erscheinende Symbol mit dem schwarzen Bildschirm darunter.
  • (GNOME wie bei Fedora, Linux Mint) Öffnen Sie das Menü Anwendungen, wählen Sie Zubehör und dann Terminal.
  • (KDE wie bei Kubuntu, openSUSE, Knoppix) Öffnen Sie den Anwendungen-Starter links unten am Bildschirmrand. Geben Sie im Feld Suchen den Befehl Terminal ein und drücken Sie danach die Eingabetaste.
Klicken Sie in der Titelleiste auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Mit deaktivierten Add-ons neu starten. Firefox startet dann neu im Abgesicherten Modus.
Hinweis: Sie können Firefox auch im Abgesicherten Modus starten, indem Sie Firefox zuvor beenden und die Umschalttaste die Wahltaste mac-wahltaste gedrückt halten, während Sie Firefox starten.
Sie können Firefox ebenso im Abgesicherten Modus starten, wenn Sie Firefox beenden, das Terminal aufrufen und folgendes ausführen: firefox -safe-mode
Eventuell müssen Sie das Installationsverzeichnis von Firefox angeben (z. B. /usr/lib/firefox).
So öffnen Sie das Terminal (das auch Shell oder Konsole genannt wird):
  • (Unity wie bei Ubuntu) Öffnen Sie den Schnellstart (Dash-Startseite). Klicken Sie dazu entweder auf das Ubuntu-Symbol im Unity-Startmenü oder betätigen Sie einfach die Taste Windows/Super. Tippen Sie das Wort „terminal“ ein und klicken Sie dann auf das erscheinende Symbol mit dem schwarzen Bildschirm darunter.
  • (GNOME wie bei Fedora, Linux Mint) Öffnen Sie das Menü Anwendungen, wählen Sie Zubehör und dann Terminal.
  • (KDE wie bei Kubuntu, openSUSE, Knoppix) Öffnen Sie den Anwendungen-Starter links unten am Bildschirmrand. Geben Sie im Feld Suchen den Befehl Terminal ein und drücken Sie danach die Eingabetaste.

  1. Markieren Sie im "Abgesicherter Modus"-Dialog von Firefox die Optionen Alle Symbolleisten zurücksetzen und Alle Benutzereinstellungen zurücksetzen.
  2. Um die Änderungen zu übernehmen, klicken Sie auf Änderungen ausführen und neustarten.

    9385902f222717c74060af78014c6b6b-1263036704-208-2.png Allgemeine Fehlersuche Linux 06 9385902f222717c74060af78014c6b6b-1264237196-802-1.png
    ab Firefox 3.6

    9385902f222717c74060af78014c6b6b-1263036704-208-1.png 9385902f222717c74060af78014c6b6b-1263036664-700-1.png 9385902f222717c74060af78014c6b6b-1251467781-900-3.png
    bis Firefox 3.5

Fehlersuche bei Plugins

Manchmal können Firefox-Plugins (wie z.B. Adobe Reader, Flash, Java, QuickTime, RealPlayer und Windows Media Player) Probleme verursachen.

  1. Öffnen Sie das Add-on-Fenster von Firefox über das Menü Extras und wählen Sie Add-ons aus.
  2. Klicken Sie auf die Plugin-Schaltfläche oben im Add-on-Fenster.
  3. Klicken Sie jedes Plugin in der Liste an und wählen Sie jeweils Deaktivieren.
  4. Überprüfen Sie, ob das Problem weiterhin besteht.


Weitere Informationen über die verschiedenen Plugins und was Sie tun müssen, falls ein Plugin Ihr Problem verursacht, können Sie im Artikel Fehlerbehebung bei Plugins wie Flash oder Java, um verbreitete Probleme mit Firefox zu lösen nachlesen.


Weitere Schritte zur Fehlersuche

Wenn die oben genannten Schritte das Problem nicht beseitigen können, führen Sie die folgenden Anweisungen aus.


Ein neues Profil erstellen

Ein defektes Firefox-Profil kann verschiedene Probleme verursachen. Sie können ein neues Profil erstellen und testen, ob dies Ihr Problem behebt. Sollte dies der Fall sein, können Sie Ihre persönlichen Daten (Lesezeichen, gespeicherte Passwörter usw.) in das neue Profil übernehmen.

  1. Starten Sie den Profil-Manager. Eine Anleitung dazu finden Sie bei Profil-Manager starten.
  2. Erstellen Sie ein neues Profil. Lesen Sie dazu die Anleitung Profil erstellen.
  3. Wählen Sie das neu erstellte Profil im Profil-Manager aus und klicken Sie auf Firefox starten.

Überprüfen Sie, ob Ihr Problem mit einem neuen Profil weiterhin besteht. Ist dies nicht der Fall, können Sie Ihre persönlichen Daten nach folgender Anleitung in das neue Profil übernehmen: Wiederherstellen wichtiger Daten aus einem alten Profil. Kopieren Sie - auch um Fehler auszuschließen - nur Ihre Lesezeichen und die gespeicherten Passwörter in das neue Profil.


Saubere Neuinstallation

Einige Firefox-Probleme können durch das Neuinstallieren von Firefox gelöst werden. Laden Sie sich Firefox von GetFirefox.com herunter, beenden Sie anschließend Firefox, löschen Sie dann den Programmordner von Firefox und installieren Sie Firefox neu. Sollte das nicht helfen oder wollen Sie Firefox lieber komplett deinstallieren, um "ganz von vorn zu beginnen", führen Sie die folgenden Schritte aus:

  1. Laden Sie die neueste offizielle Version von Firefox hier herunter: GetFirefox.com.
    • Vermeiden Sie es, Firefox von inoffiziellen Seiten herunterzuladen, die Firefox mit anderen Programmen wie z.B. der Google Toolbar koppeln.
  2. Wenn Sie Ihr aktuelles Firefox-Profil behalten wollen, legen Sie eine Sicherung davon an. Lesen Sie dazu den Artikel Daten in Firefox-Profilen sichern und wiederherstellen.
  3. Deinstallieren Sie Firefox nach der Anleitung Firefox deinstallieren. Stellen Sie sicher, dass:
    • Firefox durch die Deinstallationsroutine Ihres Betriebssystems entfernt wurde,
    • der Firefox-Programmordner gelöscht wurde und
    • der Firefox-Profilordner gelöscht wurde. Wie Sie den Profilordner finden, lesen Sie bitte nach bei Wo befindet sich Ihr Profil.
  4. Installieren Sie Firefox neu, so wie es bei Firefox installieren beschrieben wird.
  5. Wenn Firefox das erste Mal gestartet wird, erscheint der Import-Assistent und ein neues Profil wird erstellt.
  6. Überprüfen Sie, ob die Probleme nicht mehr auftreten.
  7. Wenn Sie Ihr altes Profil gesichert haben und die darin enthaltenen Daten wiederherstellen wollen, lesen Sie den Artikel Wiederherstellen wichtiger Daten aus einem alten Profil. Kopieren Sie - auch um Fehler zu vermeiden - nur Ihre Lesezeichen und die gespeicherten Passwörter in das neue Profil.
  8. Installieren Sie Ihre Erweiterungen und Themes eine nach der anderen neu, um zu überprüfen, ob eines (und wenn ja, welches) der Add-ons Ihr Problem verursacht.

Andere Lösungen

Wenn Sie die oben genannten Schritte befolgt haben, inklusive einer sauberen Neuinstallation, und das Problem besteht weiterhin, könnten Ihnen die folgenden Lösungsvorschläge helfen.

Hinweis: Dieser Bereich enthält keine Schritt-für-Schritt-Anleitungen. Für weitere Informationen zu den Lösungsvorschlägen ziehen Sie die zugehörige Dokumentationen Ihres Betriebssystem bzw. der entsprechenden Programme zu Rate.


Internet-Sicherheitsprogramme

Manche Internet-Sicherheitsprogramme (einschließlich Virenscanner, Anti-Spyware-Programme und Firewalls) können Probleme mit Firefox verursachen. Eventuell können Sie einige Webseiten nicht mehr aufrufen, Firefox könnte sogar abstürzen usw.

Wenn Sie eine Firewall oder ein anderes Internet-Sicherheitsprogramm nutzen, stellen Sie sicher, dass Firefox von diesen Programmen der Zugriff auf das Internet nicht verwehrt wird.

Meistens können Sie die entsprechenden Programmeinstellungen aufrufen, Firefox aus der Liste der erlaubten bzw. vertrauenswürdigen Programme entfernen, Firefox von dem Programm neu erkennen lassen, und Ihr Problem sollte gelöst sein. Diesen Schritt sollten Sie auch ausführen, wenn Sie vorher keine Probleme mit Ihrem Internet-Sicherheitsprogramm hatten. Wenn Ihr Programm in der Liste der Probleme durch eine Firewall aufgelistet ist, können Sie den spezifischen Anweisungen folgen, um dieses Programm neu einzustellen.


Viren und Spyware

Überprüfen Sie von Zeit zu Zeit Ihren Computer auf Viren, Spyware oder andere Schadprogramme. Einer der folgenden kostenlosen Dienste kann Ihnen bei der Suche nach Viren helfen:

Schadprogramme könnten direkt die Firefox-Programmdatei angreifen. Die folgenden Schritte können Ihnen helfen, ein solches Problem festzustellen:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  2. Öffnen Sie den Firefox-Programmordner. Standardmäßig ist dies:
    C:\Programme\Mozilla Firefox.
  3. Benennen Sie die Datei firefox.exe in firefox1.exe um.
  4. Doppelklicken Sie auf firefox1.exe, um Firefox zu starten.
  5. Wenn Firefox jetzt ohne Probleme läuft, hat möglicherweise ein Schadprogramm die Datei (firefox.exe) angegriffen. Überprüfen Sie Ihren Computer auf Schadprogramme unter Verwendung der oben genannten Links oder Ihres eigenen Virenscanners bzw. Anti-Spyware-Programms.

Es ist auch möglich, dass Werbeblocker, Verbindungs-Beschleuniger, Virenscanner oder andere laufende Programme mit Firefox in Konflikt treten. Versuchen Sie, diese Programme testweise nacheinander zu deaktivieren.


Dateisystem-Fehler

Wenn das Dateisystem Ihres Computers ein Problem hat, könnte dieses Firefox am Starten hindern. Führen Sie das Fehlersuch-Programm Chkdsk aus, um nach Fehlern auf Ihrem Laufwerk zu suchen und sie zu beheben.


Für weitere Hilfe

Wenn Sie nach dem Befolgen aller obigen Schritte immer noch Probleme mit Firefox haben:



Basiert auf Informationen von Standard diagnostic - Firefox (mozillaZine KB)

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: Wawuschel. Auch Sie können helfen – erfahren Sie, wie.