X
Tap here to go to the mobile version of the site.

Support Forum

Videos can no longer be downloaded

Posted

I have been using Firefox (for Linux Desktop) to download videos for offline viewing for a long time now. I've used DownloadHelper and Flash Video Downloader addons and they've always done the job, just fine. However, after updating to Firefox 29.0 yesterday or the day before, they will no longer download videos. I've tried a few other addons (to see if maybe it was the addons themselves), but the result is the same -- I've tried it on different websites, as well, but it still doesn't work. The download will initiate, 1-6Mb will be downloaded, then it will "fail." Even with a download manager that allows you to resume paused or broken downloads, it will fail. The strange thing is, if I download a video without using any addon, it works. The issue is, in many cases it's not possible to download a video without the help of an addon. I think maybe there's something wrong with the way Firefox is handling the downloading of videos through addons. Is there a fix for this? I'm happy to provide technical information (browser configuration, etc.) if it'll help.

I have been using Firefox (for Linux Desktop) to download videos for offline viewing for a long time now. I've used DownloadHelper and Flash Video Downloader addons and they've always done the job, just fine. However, after updating to Firefox 29.0 yesterday or the day before, they will no longer download videos. I've tried a few other addons (to see if maybe it was the addons themselves), but the result is the same -- I've tried it on different websites, as well, but it still doesn't work. The download will initiate, 1-6Mb will be downloaded, then it will "fail." Even with a download manager that allows you to resume paused or broken downloads, it will fail. The strange thing is, if I download a video without using any addon, it works. The issue is, in many cases it's not possible to download a video without the help of an addon. I think maybe there's something wrong with the way Firefox is handling the downloading of videos through addons. Is there a fix for this? I'm happy to provide technical information (browser configuration, etc.) if it'll help.

Chosen solution

Clear the Cache
Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

Remove Cookies
Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

If there is still a problem, Start Firefox in Safe Mode
While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration. Then restart.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The Totem 3.0.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • Firefox 29.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0
  • Support URL: https://support.mozilla.org/1/firefox/29.0/Linux/en-US/

Extensions

  • Adblock Plus 2.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Browse By Name 1.1 (jid0-BJHK9jcBnvyTwamzSSjJvyQXmOE@jetpack)
  • DownThemAll! 2.0.17 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • DuckDuckGo Plus 0.3.16 (jid1-ZAdIEUB7XOzOJw@jetpack)
  • Flash and Video Download 1.54 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Keyword Search 1.0.7 (keywordsearch@kaply.com)
  • keyword.URL Hack! 0.4.0 (keyword@evilpie.com)
  • Savedeo video downloader 0.4.1 (savedeo-video-downloader@fczbkk.com)
  • TiddlyFox extension for Firefox 1.0alpha18 (tiddlyfox@tiddlywiki.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.7 (ubufox@ubuntu.com)
  • DownloadHelper 4.9.22 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)
  • Flash Video Downloader - Full HD Download 5.9.1 (artur.dubovoy@gmail.com) (Inactive)
  • FlashGot 1.5.5.98 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34}) (Inactive)
  • FoxyProxy Standard 4.2.4 (foxyproxy@eric.h.jung) (Inactive)
  • Greasemonkey 1.15 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)
  • Less Spam, please 0.8.0 (lessspamplease@developer.org) (Inactive)
  • Media Stealer 1.3.4 (stealer@physacco.com) (Inactive)
  • NoScript 2.6.8.23 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)
  • ScrapBook 1.5.9 ({53A03D43-5363-4669-8190-99061B2DEBA5}) (Inactive)
  • Spell Checker 1.3.2 (gaurangnshah@gmail.com) (Inactive)
  • Zotero 4.0.20.2 (zotero@chnm.gmu.edu) (Inactive)
  • Zotero LibreOffice Integration 3.5.9 (zoteroOpenOfficeIntegration@zotero.org) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: X.Org R300 Project -- Gallium 0.4 on ATI RS690
  • adapterDeviceID: Gallium 0.4 on ATI RS690
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org R300 Project
  • driverDate:
  • driverVersion: 2.1 Mesa 8.0.4
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: X.Org R300 Project -- Gallium 0.4 on ATI RS690
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.casesensitive: 1
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 6
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140428194100
  • browser.startup.homepage: https://ixquick.com/eng/?&cat=web&query=&r=699763&t=night
  • browser.startup.homepage_override.buildID: 20140428194100
  • browser.startup.homepage_override.mstone: 29.0
  • browser.urlbar.default.behavior: 2
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 29.0
  • font.default.x-western: sans-serif
  • font.name.sans-serif.x-western: Arial
  • font.name.serif.x-western: Arial
  • keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1399612737
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 49426
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.soname.list:
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1399441683

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Chosen Solution

Clear the Cache
Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

and

Remove Cookies
Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

If there is still a problem, Start Firefox in Safe Mode
While you are in safe mode;
Firefox Options > Advanced > General.
Look for and turn off Use Hardware Acceleration. Then restart.

Clear the Cache<BR> '''''Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"'''''<BR><BR> and<BR><BR> Remove Cookies<BR>'''''Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"'''''<BR><BR> If there is still a problem, '''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''''' <BR>While you are in safe mode;<BR> '''''Firefox Options > Advanced > General'''''.<BR> Look for and turn off '''Use Hardware Acceleration'''. Then restart.

Question owner

I've never had a problem that made me have to clear the cache before, but between that and clearing the cookies, it seems solved. I didn't even have to restart in Safe Mode.

Thank you very much for your help!! :D

I've never had a problem that made me have to clear the cache before, but between that and clearing the cookies, it seems solved. I didn't even have to restart in Safe Mode. Thank you very much for your help!! :D
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Sometimes a bit of bad data gets mixed in. Clearing the drawing board can get rid of it.

Sometimes a bit of bad data gets mixed in. Clearing the drawing board can get rid of it.