Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address bar text is replaced with a solid stripe

  • 6 replies
  • 35 have this problem
  • 54 views
  • Last reply by DevilishDB

more options

All the text in my address bar is obscured by a stripe of the color the text should be. For example now I see a green stripe for the secure connection to Mozilla, gray where http://www. is, black for the domain, and gray for the rest of the URL. Clicking on the stripes reveals portions of the URL Sometimes sections are revealed on mouseover. Curiously, the only time it displays correctly is when I use the back button to access a page.

Fresh install on Xubuntu 14.04 I've tried reboot, reinstalling FF, FF safe mode and reset.

All the text in my address bar is obscured by a stripe of the color the text should be. For example now I see a green stripe for the secure connection to Mozilla, gray where http://www. is, black for the domain, and gray for the rest of the URL. Clicking on the stripes reveals portions of the URL Sometimes sections are revealed on mouseover. Curiously, the only time it displays correctly is when I use the back button to access a page. Fresh install on Xubuntu 14.04 I've tried reboot, reinstalling FF, FF safe mode and reset.

Chosen solution

Hello, Some other users have reported about this issue, installing FXChrome theme helped them out.

https://support.mozilla.org/en-US/questions/997900

Read this answer in context 👍 7

All Replies (6)

more options

Firefox has hardware acceleration set to "on" by default, but it's still young, which means some video cards or drivers might have problems with it. You can try to disable hardware acceleration to see if that alleviates your problems.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps for Firefox version 29.0 and above:

  • Click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux. For Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window, click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.
more options

Hardware acceleration is hardly an issue on Linux as it probably isn't used.

It could be a problem with the font that is used or with the font size.

Does this only happen with the location bar and not with the search bar on the Navigation Toolbar?

Can you paste this hidden text correctly to the clipboard?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

more options

Hardware acceleration is disabled. I've tried a few fonts and font sizes but am back to the default. The search bar is unaffected. Text copies and pastes correctly. Another thing I noticed is when I type in the location bar, the text only changes to the stripe when it gets to a certain point, roughly underneath "bookmarks" on the menu bar. I tried different width characters and and it's the same spot, so it's not based on number of characters. Deleting characters swtches the text back to normal at the same point, until I take focus off the location bar at which point it goes back to the stripes. It always displays incorrectly on pageload despite the URL length however. I've attached a screenshot.

Thanks

more options

Chosen Solution

Hello, Some other users have reported about this issue, installing FXChrome theme helped them out.

https://support.mozilla.org/en-US/questions/997900

more options

Thank you, FXChrome did the trick.

more options