Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I fix websites being shown as text?

  • 1 reply
  • 2 have this problem
  • 42 views
  • Last reply by cor-el

more options

Recently, my Firefox browser has been malfunctioning - it has started rendering a few webpages merely as text with all pictures and whatnot left unread. This problem showed up right before I updated to 29.0, before of which i had the 28.0 version. I know for a matter of fact that this is a problem with my Firefox browser, and not my computer or WiFi etc, because using either Internet Explorer or the more popular Google Chrome to visit the pages broken to Firefox, the pages show up and render completely fine as usual. Now, all pages do not show up incorrectly - however a few important do - such as a few of Mozilla's own sites, the Themes amongst others, and all of the Soundcloud sites. I have a few screenshots that I'd like to share, that I have linked at the bottom of the page - for convenience.

These are the things I have already tried, fruitlessly, to fix the problem: - Updating the Firefox browser (v28 to v29) - Un- and Reinstalling the Firefox browser - Removing my profile and re-uploading my backup profile - Resetting all cookies and cache - Resetting the Firefox browser completely - Followed the rest of Mozilla's "fix slowness, crashes etc."-list

Firefox Themes: http://tinypic.com/view.php?pic=2vxj2p5&s=8 Soundcloud Homepage?: http://tinypic.com/view.php?pic=11tpzrp&s=8 Soundcloud logged in?: http://tinypic.com/view.php?pic=2d828nc&s=8

All Replies (1)

more options

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.